
PGA970 Software Quick Start Guide

User's Guide

Literature Number: SLDU025
November 2016



2 SLDU025–November 2016
Submit Documentation Feedback

Copyright © 2016, Texas Instruments Incorporated

Table of Contents

Contents

1 Procedure to Build PGA970 Code .......................................................................................... 3
2 Procedure to Generate Intel Hex File ...................................................................................... 9
3 Procedure to Run PGA970 Firmware on PGA970EVM ............................................................. 12

3.1 USB2ANY interfacing board along with PGA970GUI and PGA970EVM........................................ 12
3.2 XDS200 USB JTAG emulator and PGA970EVM................................................................... 12
3.3 PGA970EVM, XDS200 USB JTAG Emulator and USB2ANY Usage............................................ 27

4 Troubleshooting XDS200 USB JTAG Emulator....................................................................... 28

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025


3SLDU025–November 2016
Submit Documentation Feedback

Copyright © 2016, Texas Instruments Incorporated

Contents

1 Procedure to Build PGA970 Code
1. Download latest Code Composer Studio (CCS) from TI website.

• processors.wiki.ti.com/index.php/Download_CCS
2. While installing CCS on machine, use option "Setup Type: Complete Feature Set".
3. Check whether rtsv6M0_T_le_eabi.lib is present in following path: C:\ti\ccsv6\tools\compiler\ ti-cgt-

arm_5.2.6\lib\ (if CCS is installed on C:\ drive otherwise select appropriate drive).
4. In case rtsv6M0_T_le_eabi.lib is not presents in above path then copy rtsv6M0_T_le_eabi.lib into path

C:\ti\ccsv6\tools\compiler\ ti-cgt-arm_5.2.6\lib \ (if CCS is installed on C:\ drive otherwise select
appropriate drive).

5. Copy PGA970 folder (having PGA970 code) or ‘code’ folder into any path e.g. D:\temp
6. Launch CCS IDE.
7. Workspace Launcher window will get pop-up.
8. Provide workspace path e.g. D:\temp

Figure 1. CCS Workspace Launcher

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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9. Import PGA970 code using Project->Import CCS Project.

Figure 2. Import CCS Project

10. Import CCS Projects window will get pop-up as shown in Figure 3.

http://www.ti.com
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11. Provide path in Select search-directory option e.g. D:\temp

Figure 3. Select Search-Directory

12. Discovered projects: option shows PGA970 as shown in Figure 3 or code.
13. Click on finish button.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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14. Project Explorer window will display PGA970 folder as shown in Figure 4 or code folder.

Figure 4. PGA970 Project

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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15. Compile PGA970 project using Project-> Clean.

Figure 5. PGA970 Build Project

NOTE: In PGA970 project, Cortex M0 setting is already present. If user wants to confirm it then use
Project->Properties->Build->ARM Compiler->Processor Options->Target processor version

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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Figure 6. Target Processor Cortex M0 Selection

http://www.ti.com
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2 Procedure to Generate Intel Hex File
1. Go to menu Project->Properties

Figure 7.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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2. Select ‘Build’ and user can see ‘Steps’ as shown below:

Figure 8.

http://www.ti.com
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3. In ‘Post-build steps’ mention "${CG_TOOL_HEX}" -i "${BuildArtifactFileName}" -o
"${BuildArtifactFileBaseName}.hex" -order LS -romwidth 32 and in Description field mention ‘Create
flash Image Intel-Hex’ as shown below:

Figure 9.

Command shows:
"${CG_TOOL_HEX}" -i "${BuildArtifactFileName}" -o "${BuildArtifactFileBaseName}.hex" -order LS -
romwidth 32
• -order LS: indicates Little-endian
• -romwidth 32: indicates hex conversion formats width

4. Click on Apply button.
5. Click on OK button.
6. Compile PGA970 code and Intel hex file (PGA970.hex) will get generated in Debug folder.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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3 Procedure to Run PGA970 Firmware on PGA970EVM
There are two development platforms:
1. USB2ANY interfacing board along with PGA970GUI and PGA970EVM.
2. XDS200 USB JTAG emulator and PGA970EVM.

3.1 USB2ANY interfacing board along with PGA970GUI and PGA970EVM
The USB2ANY provides the interface communication between the PGA970EVM and the PGA970GUI.

For more details, please refer to PGA970EVM User's Guide (SLDU017) .

3.2 XDS200 USB JTAG emulator and PGA970EVM
Prerequisite:

• Install CCS
• The Spectrum Digital XDS200 USB JTAG Emulator kit
• PGA970 EVM

Connection between the Spectrum Digital XDS200 USB JTAG Emulator and PGA970EVM
1. For details regarding the Spectrum Digital XDS200 USB JTAG Emulator, refer to XDS200 Quick Start

Guide PDF from the following website:
• emulators.spectrumdigital.com

2. The Spectrum Digital XDS200 USB JTAG Emulator kit contains 3 adapters. Connect CTI20-ARM10
adapter to XDS200.

3. All XDS200 USB drivers and CCS drivers are included with the CCS software installation.
4. Connect the included USB cable to a USB port on the host computer and then connect the USB cable

to the XDS200. Windows will recognize the new hardware connection and complete the XDS200
installation automatically on Windows 7 and higher. On Windows XP follow the hardware installer
instructions and answer “Yes” or “default” if prompted

5. PGA970EVM should be unpowered at this time. Connect CTI20-ARM10 adapter to SWD connector of
PGA970EVM.

Setup the Target Configuration Options
A Target Configuration tells CCS how to connect to the device. It describes the device using gel files and
device configuration files.
1. “PGA970.xml” file is available in the “docs” folder of software release package.
2. Copy “PGA970.xml” file into folder C:\ti\ccsv6\ccs_base\common\targetdb\devices\ (if CCS is installed

on C:\ drive otherwise select appropriate drive).
3. “M0_systick.xml, M0_nvic.xml, pga970_csr.xml” files are available in the “docs” folder of software

release package.
4. Create folder “PGA970” into the CCS installation path C:\ti\ccsv6\ccs_base\common\targetdb\Modules\

(if CCS is installed on C:\ drive otherwise select appropriate drive).
5. Copy “M0_systick.xml, M0_nvic.xml and pga970_csr.xml” files into PGA970 folder path

C:\ti\ccsv6\ccs_base\common\targetdb\Modules\PGA970\ (if CCS is installed on C:\ drive otherwise
select appropriate drive).

6. “pga970.gel” file is available in the “docs” folder of software release package.
7. Copy “pga970.gel” file into folder C:\ti\ccsv6\ccs_base\emulation\gel\ (if CCS is installed on C:\ drive

otherwise select appropriate drive).
8. Launch Code Composer Studio v5 from the shortcut on the desktop. This was created when CCS v6

was installed.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
http://www.ti.com/lit/pdf/sldu017
http://emulators.spectrumdigital.com
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9. The Code Composer Studio v6 window will appear. Click the “File” menu, then select “New-->Target
Configuration File”

10. The “New Target Configuration” window will appear.
• Type a name for the target configuration file. It will have a “.ccxml” suffix.
• Leave the "Use shared location" box checked or mention the path to store configuration path.

11. Select “Finish”.

Figure 10.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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12. The “Basic” configuration setup window will appear. Select “Texas Instruments XDS2xx USB Debug
Probe” from the “Connection” menu.

Figure 11.

http://www.ti.com
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13. Board or Device -> type filter text as “PGA970” and select PGA970 device.

Figure 12.

14. Select “Save”
15. Click on Target Configuration.
16. The “Advanced” configuration setup window will appear.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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Figure 13.

17. Select “Texas Instruments XDS2xx USB Debug Probe_0”

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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18. “Connection Properties” setting should be as shown below:

Figure 14.

Table 1. “Connection Properties” Configured Parameters

Board Data File auto generate
Emulator I/O Port Number 0
The JTAG nTRST Boot-Mode Disabled – Both EMU pins remains hi-z
The Power-On-Reset Boot-Mode Disabled – Both EMU pins remains hi-z
The JTAG TCLK Frequency (MHz) Adaptive with user specified limit
---Enter a value from 0.5MHz to 20.0MHz 1.0MHz
The JTAG Signals Isolation Upon Disconnect Do not isolate JTAG signals when last client disconnects
Apply nReset/SRST pin on the emulation header Do not pulse this pin on emulator startup
JTAG/cJTAG/SWD mode SWD Mode – User COM Port is target UART port

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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19. Select “Save”
20. Apply power to the PGA970EVM.
21. Select “Test Connection”

Figure 15.

http://www.ti.com
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22. “Test Connection” report will be displayed.

Figure 16.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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Launch the Debugger
1. Open the project and compile the code.
2. The debugger can be launched by a right click on the target configuration and selecting "Launch

Selected Configuration".

Figure 17.

http://www.ti.com
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3. The debugger window will appear.

Figure 18.

Connect to the Target
1. In the debug window, select the CPU you wish to connect to.

• In this example the Cortex_M0_0 is selected.
2. Right click on the core and select "Connect Target"

• Alternative: Select "Run->Connect Target"
• Alternative: Use the keyboard shortcut CTRL-ALT-C.

http://www.ti.com
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Figure 19.

NOTE: You can configure the debug button to also automatically connect to the target after launch:
In the CCS Debug perspective: "Tools -> Debugger Options -> Auto Run and Launch
Options" and select "Connect to Target on Debugger Setup".

http://www.ti.com
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Auto Run and Launch Options shall be selected as below:

Figure 20.

http://www.ti.com
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Program/Memory Load Options shall be selected as below:

Figure 21.

http://www.ti.com
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Load the Application
1. Select “Run->Load->Load Program”

Figure 22.

2. Select “Browse Projects”. All projects imported into CCS will be shown along with there .out file if is
exists.

3. Select the .out file you want to load into the MCU.
4. Select “Ok”.

Run the Program
Select the green arrow icon on the toolbar or go to "Run->Resume"

Figure 23.

Figure 24.

http://www.ti.com
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Add Variables to the Expression View
To quickly add variables to the expressions view:

Go to “View->Expressions” and enter name of the global variable e.g. ADC_Count1.

Figure 25.

View PGA970 Registers
Go to “View->Registers”

Figure 26.

http://www.ti.com
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3.3 PGA970EVM, XDS200 USB JTAG Emulator and USB2ANY Usage
Test scenario for simultaneous usage of XDS200 USB JTAG emulator and USB2ANY interfacing board
along with PGA970GUI with PGA970EVM are as below:
1. XDS200 USB JTAG emulator shall be used to load the application into PGA970EVM, run it and debug

the downloaded application.
2. PGA970GUI with USB2ANY interfacing board shall be used to communicate with PGA970EVM using

COMBUF registers when PGA970 microcontroller is running. PGA970GUI shall write data into
COM_DIF_TO_MCU register and read data from COM_MCU_TO_DIF register while PGA970
microcontroller is running.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU025
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4 Troubleshooting XDS200 USB JTAG Emulator
Strategy for troubleshooting XDS200USB JTAG emulator connectivity problems
1. Check that you are using high quality cables for connections.
2. Determine whether USB cable is connected to a USB port of host computer and to the XDS200.
3. Determine whether the emulator is correctly setup in Windows (i.e. is the USB driver, etc. working) by

checking in the Windows System Devices control panel. If this is not right, then you need to check
CCS installed version.

4. Determine whether CTI20-ARM10 adapter is connected to XDS200 and connector PGA970EVM and
check its orientation.

5. Determine whether USB2ANY interfacing board is connected to PGA970EVM. In case it is connected
to PGA970EVM then disconnect it from PGA970EVM or make sure that USB2ANY interfacing board is
connected to a USB port of host computer.

http://www.ti.com
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