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1. 準備するドキュメントや機材など 

1.1. ドキュメント 

MSP430の下記製品ページを開くと、そこからユーザーズ・ガイドやアプリケーション・ノートにアクセスできま

す。アプリケーション・ノートには、多くの資料がありますので、ご活用ください。 

   http://focus.tij.co.jp/jp/mcu/docs/mcuflashtools.tsp?sectionId=95&tabId=1538&familyId=342

 

例として下記のドキュメントをダウンロードします。 

*末尾の「SLAU208」は文書番号です。ドキュメントは改版され末尾に a,b,c… と版数記号が付記されます。 

 

   ・ユーザーズ・ガイド    ・・MSP430x5xx/MSP430x6xx Family User's Guide (SLAU208) 

   ・コンパイラ・マニュアル  ・・MSP430 Optimizing C/C++ Compiler v 3.x User's Guide (SLAU132) 

 

ドキュメントは文書番号で検索できます。上段右側の「キーワード検索」に文書番号を入れて探します。 

例として「SLAU278」と入力して、下記のドキュメントを ダウンロード します。 

   ・ハードウェアツール ユーザーズ・ガイド   ・・MSP430 Hardware Tools User's Guide (SLAU278)  

 

次に、ターゲットデバイスの製品ページを開きます。 

上段右側の「型番検索」にデバイス型番を入れて探すことができます。 

   例として「F5438A」と入力して探すと、MSP430F5438Aの製品紹介ページが開きます。 

     http://focus.tij.co.jp/jp/docs/prod/folders/print/msp430f5438a.html
 
この先頭にある「データシート」を ダウンロード します。 
データシートには、そのデバイスの動作保証スペックなどが記載されていますので、確認をお願いします。 
   ・MSP430F543xA, MSP430F541xA Mixed Signal Microcontroller （SLAS655） 
 

1.2. 評価ボード 

各デバイスの製品紹介ページを開いたら、右欄にある「ソフトウェアおよびツール」をクリックします。 

この「TI ソフトウェアおよびツール」表の中に、開発評価用のターゲットボードがあります。 

MSP430-FET430UIFエミュレータをすでに保有している場合は前者を、保有していない場合は後者を用意します。 

   ・MSP430F5xx 100 ピン・ターゲット・ボード    MSP-TS430PZ5X100   

   ・MSP430F5xx 100 ピン・ターゲット・ボードおよび USB プログラマ   MSP-FET430U5X100  

 

G2xxxやF20xx のデバイス（N14/20 DIPタイプ）では LaunchPad Development Tool も利用できます。 

 

これら評価ボードについては、下記の文書に説明があります。  

 ・MSP430 Hardware Tools User's Guide (SLAU278) 

       評価ボードの回路図などがありますので、ボード開発の参考に利用できます。 

   ・MSP-EXP430G2 LaunchPad Experimenter Board User's Guide (SLAU318) 

       この評価ボードにはJTAGエミュレータが搭載されています。 
 

1.3. Code Examples 

F5438A製品紹介ページの右欄にある「ソフトウェアおよびツール」をクリックして、表示される表の中にある下記 

Code Examples をダウンロードします。この中には、ペリフェラル制御プログラムのひな型が入っています。 

例  MSP430F543xA, MSP430F541xA Code Examples 

 

このCode Examples は後述の CCSｖ4 で利用できます。 

留意すべき制御タイミングに関するコードも含まれているExampleもありますので、ペリフェラル制御ソフトのベー

ス・ひな形としてご利用をお勧めします。このcodeを試すのが、ペリフェラル制御習得の早道です。 
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1.4. JTAGエミュレータ 

（１）MSP-FET430UIF  

このJTAGエミュレータを使い、CCSなどの開発ソフトウェア・ツールと評価ボードを接続します。 

JTAGコネクタとボード上のMPUとの接続回路は、前記文書の「SLAU278」の下記図に説明があります。 

4-wireと2-wireの2通りの接続方法があります。 

   Figure 2-1. Signal Connections for 4-Wire JTAG Communication 

   Figure 2-2. Signal Connections for 2-Wire JTAG Communication (Spy-Bi-Wire) 

 

MSP-FET430UIFを利用するときは、後述のCCS（あるいはIAR-EW430）をインストールした後、PCのUSBに接続する

と、ドライバが自動的にインストールされます。 

CCSのバージョンが変わった時、あるいはCCSとIARの利用を切り替えた時などに Firmware Update するように

window が表示されるときがあります。その時は update yesとします。これで開発ツール対応と新デバイス対応で

きるように更新されます。 

 

（２）LaunchPad  

LaunchPadは、G2xxxとF20xx シリーズ向けの開発キットです。 

User's Guide(SLAU318) Figure 1. LaunchPad Overview の「Emulation」と書かれた部分は、Spy-bi-Wire エミュ

レータとして使用できます。（2-wire接続のみです。また、Firmware Updateはありません。） 

 

J3クリップをはずして、J4から下記table記載のspy-bi-wire信号を取り出せます。信号線は極力短くします。 

   Table 2. eZ430 Debugging Interface 

 

また、PCのHyper Terminalとvirtual COMを使い、このエミュレータ経由でデバイスのUARTと接続できます。 
 

1.5. 開発環境の入手 

（１）ダウンロードとインストール 

下記のURLからCCSｖ４をダウンロードできます。表中にある使用条件・ライセンスの説明を確認してください。 

**１GBほどのサイズがありますので、時間の余裕を見てください。 

    http://processors.wiki.ti.com/index.php/Download_CCS

 

下記①は30-day Free版ですが、製品と同じFULL機能が入っています。 

製品購入した「Activation-ID」を登録することで、製品版（Licensed）として使用できます。 

 

下記②は、code-size１６KB制限があります。製品版と開発機能はほぼ同じですが、モジュール内容は異なります。 

製品版に利用変更する場合は、これをアンインストールして、①を再インストールする必要があります。 

 

① Download latest production DVD image  

② Download latest production MSP430/C28x code size limited image 

 

ダウンロード（zip）したファイルをワークフォルダに解凍して、生成された setup_ccs4.2.xxxxx.exe を実行して

インストールします。 

 

（２）アップデート 

CCSv4を起動して、Help->Software Updates ->Find and Install にて、アップデートができます。 

アップデートするときは、インターネットに接続が必要です。 

**複数ＰＣで共同開発するときは、同じ時期に アップデート して、バージョンを合わせてください。 

 

（３）Emulator ドライバ・インストール 

MSP-FET430UIF あるいは LaunchPad をPCに接続すると、ドライバがインストールされます。 
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2. ソフトウェア開発のポイント 

2.1. ブロック図とレジスタ 

User’s Guide の各ペリフェラルモジュール説明には、ブロック図があります。 

例 Figure 4-1. UCS Block Diagram 

 

レジスタ説明には、この図中の制御信号（制御ビット名）と設定条件の説明があります。 

 例 4.4 UCS Module Registers 

 

Code Examples では、制御ビット名と制御レジスタ名を、symbol 名として使用しています。 

例 msp430x54xA_OF_LFXT1_nmi.c の１文 

UCSCTL7 &= ~(XT1LFOFFG + DCOFFG);       // Clear XT1 & DCO fault flags 

ﾚｼﾞｽﾀ名   制御ﾋﾞｯﾄ名  

 

このように、ブロック図とレジスタ説明、Code Examplesを見ながら、本文の説明を読むと理解が容易になります。 
 

2.2. プログラムヘッダー 

前述の Symbol と物理レジスタや制御ビットとの紐づけは、各デバイスの「ヘッダー」で行っています。 

各 Code Examples の先頭にある include 文を、使用するデバイスに合わせて変更します。 

#include "msp430x54xA.h"  #include "msp430F5438A.h" 

 

これにより、制御レジスタや制御ビットのシンボルが、そのデバイス固有の物理レジスタと物理ビットに割り当て

られます。つまり「ヘッダー」により、デバイスごとの相違をある程度吸収しソフトウェアの互換性を高めていま

す。ですから、制御レジスタ格納値を16記 0x1234 などで記載しないことをお勧めします。 

 

ビット設定がon/offどちらか確認したい時は、このヘッダーをサーチします。 

 

2.3. Code Examplesとペリフェラル制御 

Code Examples には、ほとんどのペリフェラル制御のテンプレートがあります。また、マニュアルに書いてある時

間制約など見落としやすい項目も、Code Examples には記載がありますので、ぜひ事前に目を通してください。 

Code Examples(zip) の中の !README.txt には、Code Examples のリストと簡単な説明があります。 
 

2.4. Interrupt Service Routine （ISR） 

Code Example には ISR の例がありますが、もし該当の ISR 関数名が見つからない場合は、下記の方法で登録されて

いる割り込みベクターと ISR 関数名を見つけられます。 

 

① データシート中のベクタアドレス表を検索します。 例 タイトル 「Interrupt Vector Addresses」 

② 該当するペリフェラルの Priority 値を探します。 

    TA0 TA0CCR0 CCIFG0(3)  Maskable  54  Priority  

③ 各デバイスのヘッダー msp430F5438A.h の中を int54 でサーチします。 

    ヘッダー格納フォルダー \CCSv4\ccsv4\msp430\include 

  Ｃ言語の場合は下記が該当します。 

    #define TIMER0_A0_VECTOR        (54 * 1u)                    /* 0xFFEC Timer0_A5 CC0 */ 

    /*#define TIMER0_A0_ISR(func)     ISR_VECTOR(func, ".int54")  */ /* 0xFFEC Timer0_A5 CC0…   

④ 上記を参考にして、下記のようにISR関数を記述します。 

これで、Time_A0の割り込みベクターに ISR(TIMER0_A0_ISR) のアドレスが設定されます。 
    // Timer0 A0 interrupt service routine 

    #pragma vector=TIMER0_A0_VECTOR 

    __interrupt void TIMER0_A0_ISR(void) { } 
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2.5. 留意ポイント 

（１）変数初期化 

CCSのMSP430コンパイラは、初期値なし変数を初期化しません、不要な初期化時間を省いています。 

初期化が必要な変数は、明示的に初期設定をしてください。 

 

（２）Watch Dog Timer 

WDTのデフォルト設定は 「Power On などの初期起動で動作する」です。必ずアプリケーション先頭でWDTを停止さ

せるか、適切なタイマー値を設定します。さもないと、途中で WDT NMI が入り、再度 main() から走行します。 

Example では、先頭で下記のように停止させています。 

    WDTCTL = WDTPW + WDTHOLD;                 // Stop WDT 

 

（３）InterruptとISR 

割り込み（割り込み可）を利用する場合は、対応する ISR を登録する必要があります。 

ISR が未登録の場合は暴走につながります。暴走は、さらに violation を発生させるケースもあります。 

 

NMI が起きた場合、C言語では main()の先頭から走りますので、対応する事象が起きているか該当レジスタをみて

判定します。デバッグ中は先頭にブレークポイント設定しておくと、この main() 再走行を検知できます。 

 

ベクターは16bits 表現ですから、飛び先の ISR は必ず下位の 64KB に配置する必要があります。 

64KB 以上（アドレス20bits）に配置すると ISR アドレスが正しく登録できず暴走します。 

 

（４）ＶｃｃとＣＰＵクロックの注意点 

Data-Sheet（SLAS655x）に下記の図があります。Figure 1. Frequency vs. Supply Voltage 

他のデバイスでも同じような図があります。 

CPUクロックが、この範囲（グレー領域）を絶対にオーバーしないように（時間変化や経年変化を含め）注意してく

ださい。この範囲をオーバーするとCPUが誤動作する恐れがあります。 
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3. ＣＣＳｖ４操作のポイント 

3.1. Workspaceの作成 

Workspace は、CCS のプロジェクトを格納するフォルダーです。この配下に、各プロジェクトのディレクトリが生成

されます。大きな作業単位、たとえばシステムやサブシステム単位でワーク領域を作ることに相当します。 

 

事前にこのフォルダー（例 workspace1）を作っておきます。CCSv4 を起動して、この workspace 入力を要求された

とき、このフォルダーを指定します。 

 

CCSv4 起動後に切り替えることもできます。 

    File -> Switch Workspace 

 

3.2. プロジェクトの生成 

Workspace の配下に、プロジェクトディレクトリを生成し、使用するデバイスを選択する操作です。 

Ｃ言語用の project を生成してみます。 

［操作法］ 

・File -> New -> CCS Project ： プロジェクト名を指定します。 

・Next -> Next -> Next で デバイス種別の選択画面になります。 

・デバイス種別 F5438A を選択、他は Default のままとします。 

 

  ** CGT のバージョンの注意は後で説明します 

 

Finish すると、下記の２種類の file が自動生成され、project の入れ物が完成します。 

   xxxxx.ccxml ・・デバイスとデバッグの設定 file 

   link_xxxxx.cmd ・・リンクコマンド file 
 

3.3. ソースファイルの移植 

LED 点滅させる CCS の Code Examples を移植してみます。 

［操作法］ 

・File -> Open File ->  ここで CCSv4 格納フォルダーの下記を選択します。 

  \ccsv4\msp430\examples\msp430x5xx\C-sourceSource File\msp430x5xx_fet_1.c 

・ソースファイルが表示されます。この Example は、デバイスヘッダーを下記に修正します。 

 （本当は、修正しなくとも動きますが、機能追加に備えて訂正しておきます。） 

   #include "msp430F5438A.h" 

・File -> Save As  ファイル名を main.c として書き込みます。 

 

これで、project にアプリケーション main() ソースが加えられました。 
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3.4. Build（コンパイル＋リンク） 

コンパイル、リンクして実行用オブジェクトを生成する操作です。 

［操作法］ 

・Project -> Build Active Project により、コンパイル->リンク 実施されて、xxxx.out が生成されます。 

・必ず、コンパイルエラーやリンクエラーが無いか、console, problem window でチェックします。 
 

3.5. LED 点滅Exampleの動作確認 

必要な機器を、下記の様に接続します。 

  ［ＰＣ］---<USB>---［MSP-FET430UIF］---<JTAG>---［評価ボード：MSP-TS430PZ5X100＋F5438A］ 

 

メニューバー上の虫マーク(Debug Launch)をクリックするか、Target-> Debug Active Project により、評価ボー

ドの Flash-Memory へ Program が書き込まれます。そして CPU が Reset されて Program が start して、main の最初で

停止します。 

 

int main（void） 

{   ここで停止します。 

 

Target-> Run あるいは、メニューバーの play マーク |＞ をクリックすると program が動き、評価ボード上の LED

が点滅します。 

 

3.6. Debug例 

（１）Debug Example の書き込み 

上記の project の main.c を下記のように書き直します。青い●は code ではありません。 

ヘッダーは各デバイス用に直します。 

 

#include "msp430f5438A.h" 

int a,b=0; 

 

int main(void) 

{ 

int x; 

  WDTCTL = WDTPW + WDTHOLD;             // Stop watchdog timer 

  a = 5;  

  b += 2*a; 

  x = a + b;  

● } 

 

最後の ｝ の左欄をダブルクリックすると青い●が表示されます。これがブレークポイントです。 

ブレークポイントは、デバッガー内部でも、同様の操作で設定できます。 

この状態で、前項のように Build-> Debug で、ターゲットに書き込みます。 

 

（２）Debug 画面 

Debug 画面例を下記に示します。 

最初は、main の入り口で、停止します。右側にある Local（local 変数）/Watch（global 変数）window で値とア

ドレスを調べられます。 

（例では、変数を同時に表示するため、もう一つ別に watch-window を開いています） 

 

Local 変数は自動で表示されます。 

Global 変数は <new>をクリックして a, b 変数名を入力すると表示されます。 
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この入口では、変数 b のみ初期値がセットされています。 

変数表示 window の FORMAT 欄の Natural を右クリック-> Format で表示形式（16 進、10 進など）を変えられます。 

 

さらに Run させると、ブレークポイント設定した main 出口の●で止まります。 

画像の例は下記となります。 

 

 

各変数に値が入りました。変数ｂは書き換えが起きたので赤表示されます。 

各変数の Value 欄をクリックして、数値を書きかえることができます。 

 

ここで、さらに Run すると、Local 変数 X は消滅し、表示から消えます。 

 

3.7. メモリ配置の確認 

プログラムが、メモリ上にどう配置されたかの確認方法について、前項でbuildした Debug Example の例で、簡単

にポイントを説明します。 

 

（１）セクション 

最初に入手した下記のマニュアルに、プログラムの配置される「section」の説明があります。 

特に関係するのは、code（.text）と variable（.bss）です。  

コンパイラマニュアル  ・・MSP430 Optimizing C/C++ Compiler v 3.x User's Guide (SLAU132) 

Table 4-1. Initialized Sections Created by the Compiler 

Table 4-2. Uninitialized Sections Created by the Compiler 
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（２）リンクコマンド 

メモリ名とそのアドレス範囲、セクション名と配置するメモリ名の関係を定義して、object の配置を決めます。 

リンクコマンドのうち、アプリケーションに関係する部分だけ抜粋したものを下記に示します。 

 

<リンクコマンド：xxxxf5438a.cmd> 

/* SPECIFY THE SYSTEM MEMORY MAP */ 

MEMORY 

{ 

    RAM                     : origin = 0x1C00, length = 0x4000 配置アドレス、サイズ 

    FLASH                   : origin = 0x5C00, length = 0xA380 

    FLASH2                  : origin = 0x10000,length = 0x35C00 

 

/* SPECIFY THE SECTIONS ALLOCATION INTO MEMORY  */ 

SECTIONS 

{ 

    .bss       : {} > RAM                /* GLOBAL & STATIC VARS   */ 

    .stack     : {} > RAM (HIGH)         /* SOFTWARE SYSTEM STACK  */ 

    .text      : {}>> FLASH | FLASH2     /* CODE                   */ 

    .text:_isr : {} > FLASH              /* ISR CODE SPACE         */ 

 

変数は .bss:RAM に配置し、コードは .text:FLASH に配置します。 

F5438Aは 64KB 以上の部分が FLASH2 と定義されています。 

ISRのコードは 64KB 以下に配置されます。 

 

 

（３）リンクマップ 

リンクコマップのうち、アプリケーションの code と variable 関係だけ抜粋したものを下記に示します。 

Ｃ言語の初期化ルーチンやライブラリもリンクされるので、item が多く見にくいですが、ポイントは下記です。 

特に、Symbol map には、ヘッダー定義されたシンボルも表示されるので、editor search などで見つけます。  

 

<リンクマップ： xxxx.map> 

MEMORY CONFIGURATION 

         name            origin    length      used     unused 

----------------------  --------  ---------  --------  --------  

  RAM                   00001c00   00004000  000000b4  00003f4c 配置ｱﾄﾞﾚｽ、ｻｲｽﾞ、使用ｻｲｽﾞ 

  FLASH                 00005c00   0000a380  000000be  0000a2c2 

  FLASH2                00010000   00035c00  00000000  00035c00 

 

SECTION ALLOCATION MAP 

 output                                  attributes/ 

section   page    origin      length       input sections 

--------  ----  ----------  ----------   ---------------- 

.bss       0    00001c00    00000014     UNINITIALIZED 

                  00001c10    00000004     main.obj (.bss) main配置ｱﾄﾞﾚｽ、使用ｻｲｽﾞ 

.text      0    00005c32    0000008c      

                  00005c78    0000002a     main.obj (.text:main) 

 

address    name 

--------   ---- 

00001c10   a 

00001c12   b 

00005c78   main 

 

.bss に main の２変数 a,b（2words）が配置され、.text には main-code が ox5c78 番地から 2a バイト配置されて

います。同じことが、 symbol-map からも分かりますが、変数は debugger でアドレス確認したほうが早いです。 
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3.8. その他の留意点 

（１）プロジェクトの移植 

他のマシンで開発した Project を別のマシンに移植するときは、 

Project フォルダー配下をコピーして、Project-> Import Existing CCS….. を使い、Project を取り込みます。 

 

留意すべきは、3.2.項で説明した CGT-version が異なる場合は、警告メッセージが出ますので、移植先の CGT-

version に再設定して、build し直す必要が出てきます。２台の CCSｖ４の事前バージョン管理が必要となります。 

 

Workspace ごとコピーして、Switch Workspace で移植するのは、避けたほうが無難です。Workspace には、その PC

の開発状況・設定状況などの情報も書かれていますので、間違いを引き起こす恐れがあります。 

 

 

（２）CCSｖ4の速度アップ設定 

Windows-> Preferences、C/C++ ->Editor -> Content Assist を選択、Auto Activation 欄の３つのチェックを外し

ます。これでサーチが停止しますので、Editor でソース修正時の速度が上がります。 

 

 

 

（３）リスト行番号の表示 

同じ Preferences 画面で、 General-> Editors-> Text Editors : Show Line Numbers にチェックします。 

（ただし、行番号は印刷されません） 
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（４）自動 Rebuild の停止 

Debug 時の Program Load のとき、デフォルト設定では自動で Rebuild されます。 

自動 Rebuild を止める方法は、下記の Rebuid the program のチェックをはずして停止できます。 

 

 

  以上 
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