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Stellaris® Development and Evaluation Kits for 
IAR Embedded Workbench® 
The Stellaris Development and Evaluation Kits provide a low-cost way to start designing with 
Stellaris microcontrollers using IAR System’s Embedded Workbench tools. The boards can 
function as either a complete evaluation target, or as a debugger interface to any external 
Stellaris device.  

Requirements 
 You have a PC with a USB interface, running Microsoft® Windows 2000, XP, or Vista 
 You have the Stellaris Evaluation Kit Documentation and Software CD or the standalone 

IAR CD found in the Development Kit 
 
CAUTION: There is a known electrical issue with the FT2232 device that is used in the  
on-board In Circuit Debug Interface (ICDI). Some USB hubs can cause the device to 
misbehave, with symptoms ranging from failed enumeration to corrupt data transfers. If you 
experience trouble when using the on-board ICDI, try connecting the USB cable directly to 
one of the USB ports on your PC or laptop. 
 

IAR Embedded Workbench®  

This quickstart shows you how to install the KickStart™ version of the IAR Systems 
Embedded Workbench tools, and how to use it to build and run an example application on 
your Stellaris Evaluation Board. 

Step 1: Install Embedded Workbench 
1. Insert the Evaluation Kit Documentation and Software CD or the standalone IAR CD 

into the CD-ROM drive of your computer. If Autoplay is enabled on your PC, the 
index.htm file opens automatically in your default web browser. If not, use Windows 
Explorer to open it manually. 

2. With the Evaluation Kit CD, click on the Tools button and then the IAR Logo to start 
the setup program. If the setup program does not start, use Windows Explorer to view 
the files on the CD and double-click the EWARM-KS-CD-n.nn.exe file located in the 
Tools\IAR\ directory.  
 
With the standalone CD, follow the installer dialog. 

3. Click on the “Install Embedded Workbench” link to begin the tool installation. You 
must register with IAR to receive license information (by clicking on “Get License”) 
before you can install the tools. If you have any questions about installation, follow 
the instructions detailed in the IAR quickstart documentation, which can be accessed 
by clicking “QuickStart Installation Information” in the main window of the splash 
screen. 

 1 



Q U I C K S T A R T  –  I A R  T O O L S  
 
 

Rev. 1.8  2 

 

 

Step 2: Install the StellarisWare® Package 

A full set of C-based peripheral drivers is provided, covering all peripherals and functionality 
of the Stellaris devices.  The StellarisWare package includes various example applications 
with project files for all major tool vendors that support Stellaris, including IAR.  To install 
StellarisWare, follow these steps: 

1. Navigate to the Tools tab on the Evaluation Kit Documentation and Software CD, or 
the Software tab on the Development Kit Documentation and Software CD. 
NOTE: If you are navigating the CD using Windows Explorer (or a similar 
application), go to the Tools/ StellarisWare directory. 

2. Click on the 'Install' link next in the StellarisWare section (under Tools) of the CD and 
run the StellarisWare installer. If you prefer to manually install StellarisWare, the 
installer is a self-extracting zip file that is located in the Tools/StellarisWare directory. 
You can use a zip file extraction utility such as WinZip to manually extract the 
contents. 

3. To view the StellarisWare documentation, navigate to the installation directory and 
click on the Stellaris Peripheral Driver Library User’s Guide PDF. 

Step 3: Start the Embedded Workbench IDE and Open a Workspace 
1. Start the IAR Embedded Workbench IDE by selecting it from the Windows Start 

Menu. When the IDE loads, it will have a blank screen that looks like this: 
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2. Open the workspace file that corresponds to your board by clicking 
File>Open>Workspace. The workspace file is located in the StellarisWare tree, which 
was installed on your PC as part of Step 2.  In the StellarisWare tree, the workspace 
files are located in the directory corresponding to your particular board: 

StellarisWare\boards\{board_name} 
 
The IAR tools also install StellarisWare as part of the default installation, but the 
version may be older than what is currently available from the web site.  You can find 
StellarisWare in the IAR tree by looking in: 

C:\Program Files\IAR Systems\Embedded Workbench 5.4 Kickstart 
 
in the folder: 

arm\examples\Luminary\Stellaris\boards\{board_name} 
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Important: For the most recent version of the StellarisWare package, use the standalone 
version found on the Evaluation Kit Documentation and Software CD or check 
www.ti.com/stellaris for the latest software updates. 

Step 4: Build the StellarisWare Components and Example Project 
1. Before any of the examples can be built, the StellarisWare file must be compiled. To 

build the library file, right-click on the driverlib project and select “Make.” 

  

 

 4 

http://www.ti.com/stellaris


Q U I C K S T A R T  –  I A R  T O O L S  
 
 

Rev. 1.8 

2. Right-click the Hello example and select “Set as Active” to make the project the target 
project for debugging. 

  

 

3. Now, right-click on the Hello project once more and select “Make” to build the 
project. 
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Step 5: Debugging a Project 
 
Important: The FTDI driver interface included in the kit is slower than a standard J-Link 
interface and is intended to be used for tool evaluation. Upgrading to a J-Link for your custom 
design allows for much faster download speeds. The J-Link cannot be used with the 
EKI-LM3S811, but is compatible with all other evaluation boards. 

1. Begin a debug session by selecting “Download and Debug” under the Project menu. 
You see the debugger download and verify the application, and stop execution at the 
main() function. 
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2. From here, you can examine and modify memory, program variables and processor 
registers, set breakpoints, step, and perform other typical debugging activities. To run 
the program, select “Go” from the Debug menu or click on the “Go” button (icon). 

 

 

 

 
3. The application starts running, and you should see the text “Hello World!” output to 

the display of the evaluation board. 

Step 6: Build and Run Additional Example Programs 
There are several additional example projects listed in the StellarisWare workspace. If you 
would like to build another example project, right-click the project and select “Set as Active” 
to make it the target for debugging. Then, right-click and select “Make”. Follow the 
instructions from Step 5 to debug the application. The quickstart application that came 
preloaded on the evaluation board is the qs_ev-lm3sxxxx project listed with the examples. 

Creating a New Project  
Once you have gone through the StellarisWare example applications, you may want to create 
your own project to start development.  While you can always start with an existing, simple 
project, sometimes you may want to start fresh. 
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Because the IAR environment uses workspaces to manage projects, you can either create a 
brand new workspace, or add your new project to the existing workspace.  For demonstration 
purposes, you’ll simply add your new project to the existing workspace. 

To add a new project to the workspace, select Project > Create New Project… 

 

You will then see a dialog box asking you what type of project you would like to create.  
Because you’re working with a C source, select the C > main option. 

 
 

Because you’re adding a project to the existing workspace, you will create the project within 
the StellarisWare tree.  You can put it in either the existing StellarisWare\boards directory or 
create a new item in the boards directory that corresponds to either your specific board or 
development.  In this case, you’ll create a new directory called “my_board” in StellarisWare 
boards, and create a new project called “my_project”.  The StellarisWare tree now looks like: 

C:\StellarisWare\boards\my_board\my_project 
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This process creates the basic project as well as adds a simple main.c file.  The project is still 
missing startup code (required for Cortex-M3).  

For startup code, the easiest thing to do is copy a startup_ewarm.c files from one of the other 
StellarisWare examples.  In this case, we’ll copy the file from the Hello project 
(StellarisWare\boards\{board_name}\hello) and place it in the new my_project directory.   

Now the startup code must be added to the project.  Right click on the project and select Add 
> Add Files…  It should take you to the project directory, and because the startup_ewarm.c 
file is already there (you just copied it), simply select it. 
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Before compiling and debugging the project, a few settings must be adjusted in the project 
options.  In addition to setting the processor core, StellarisWare hooks and the debug/flash 
programmer must be configured. 

Setting the Target: 
The first thing to do is tell the project that you’re using a Stellaris device.  In the project 
options (select the project and either go to the project menu and select Options, or right click 
and select Options).  Select the device that closest fits what you’re using. 
 

 

 
 

Adding StellarisWare Hooks: 
The first step is to add the driverlib.a file to your project.  To do this, you’ll follow the same 
file>add procedure described above.  The location of the file is: 
 
C:\StellarisWare\driverlib\ewarm\Exe 

Note, you must tell the file browser to look for library file types, so change the “Files of type” 
drop-down from “Source Files” to “Library/Object Files” or “All Files.” 

To make sure that you have the appropriate pointers to the StellarisWare source and header 
files, you must add some include paths to the project settings.  It’s also a good idea to add 
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some defines for the compiler (“ewarm”) and the part number.  This configuration is used in 
StellarisWare to compile the IAR-specific sections correctly.   

 

 

 

Setting up the Debugger and Flash Programmer: 
The last thing to do is configure the debugger and flash programmer.  In the project options, 
select the Debugger item and choose the “LMI FTDI” option from the driver drop-down 
menu.  Under the Download tab, select “Verify download” and “Use flash loader(s).” 
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With these settings all complete, you can download and debug your simple application.  From 
here you can start adding your own code or calls to StellarisWare drivers (assuming you 
include the correct header files).  The best way to make sure you’ve done everything correctly 
is to go over some of the examples that we provide in the StellarisWare package. 

Conclusion 
You have now installed the IAR Embedded Workbench IDE and used it to build, load, and 
run an example application on your Stellaris Evaluation Board. You have also learned how to 
create a new project from scratch.  From here, you can experiment with the debugger or start 
creating your own application from the ground up, or using the Hello program as an example.
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References 
The following references are included on the Stellaris Evaluation Kit Documentation and 
Software CD and are also available for download at www.ti.com/stellaris: 
 
 Stellaris Evaluation Kit User's Manual 

 StellarisWare Software, Order Number SW-LM3S 

 StellarisWare Peripheral Driver Library User’s Guide, Order Number SW-DRL-UG 

 In addition, the following website may be useful: 

 IAR website at http://www.iar.com 

http://www.ti.com/stellaris
http://www.iar.com/
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