ABSTRACT

This application report describes the performance of the digital signal processing (DSP) CPU extension of the MSP432™ microcontroller (MCU) leveraging the standard CMSIS DSP library in FFT operations. This is a software implementation that demonstrates several high-performance analog and digital integrations through various operations including CPU and DSP (visualization, vector processing), DMA, ADC, and high-speed SPI (color LCD control) with a high-degree of parallel operations.

Related software can be download from www.ti.com/lit/zip/slaa707.

Contents

1 Introduction ............................................................... 2
2 System Description ...................................................... 2
3 Block Diagram ............................................................ 3
4 System Design ............................................................ 4
5 Getting Started Hardware ............................................ 5
6 Getting Started Firmware ............................................ 6
7 Application Execution Performance ............................... 7
8 Software Files .......................................................... 9
9 References ............................................................... 9

List of Figures

1 High-Level Overview .................................................... 2
2 Block Diagram .......................................................... 3
3 Application Flow Chart ............................................... 4
4 Timing Diagram .......................................................... 4
5 Stacked LaunchPad Kit and BoosterPack Module .................. 5
6 BOOSTXL-AUDIO BoosterPack Required Modification ........ 6
7 Importing Project From MSPWare in TI Resource Explorer ...... 7
8 FFT and LCD Operation Per Update Execution Timeline ........ 8
9 FFT Application Current Profile ..................................... 9
1 Introduction

Features of this application include:

- Real-time FFT using accelerated hardware
- Graphical visualization on a color LCD with high-speed serial communication

2 System Description

The Fast Fourier Transform (FFT) algorithm converts a time-domain signal to frequency-domain and vice versa where FFT is manually used in many applications in signal processing. The ARM® Cortex®-M4F DSP extension, in conjunction with the CMSIS DSP Library, is designed to perform vector-based operations such as FFT, FIR, matrix multiplications, and more in an efficient manner. The software example in this application report demonstrates the clock cycles required to execute a real-time 512-point FFT using CMSIS DSP Library. This application report also demonstrates the high-performance features of the MSP432 MCU including the 48-MHz Cortex-M4F CPU and the high-speed SPI communication through graphical data manipulation and FFT data visualization.

Figure 1 shows a high-level overview of the system function.

![Figure 1. High-Level Overview](image)

To get started with this application, the user is required to use the MSP-EXP432P401R LaunchPad™ development kit, and the BOOSTXL-EDUMKII BoosterPack™ plug-in module. See Section 5.2 for help getting started with the Educational BoosterPack MKII with the EXP-MSP432P401R LaunchPad development kit.

2.1 MSP432P401R

The MSP432P401R MCU is a 48-MHz 32-bit Cortex-M4F ultra-low-power MCU with 256KB of flash and 64KB of SRAM. This MCU integrates various digital and analog peripherals, many of which are used by this application, including the 1-Msps 14-bit ADC, the 48-MHz performance, the DSP extension of the Cortex-M4F CPU, the high-performance DMA, and the high-speed SPI serial communication.

Overall, the MSP432P401x is an ideal combination of the TI MSP430™ low-power DNA, advance mixed-signal features, and the processing capabilities of the 32-bit Cortex-M4 RISC engine. The devices ship with bundled driver libraries and are compatible with standardized components of the ARM ecosystem.


2.2 Cortex-M4F With DSP Extension

The MSP432 Cortex-M4F processor features a single-cycle multiply-accumulate (MAC) unit, optimized single instruction multiple data (SIMD) instructions, saturating arithmetic instructions, and a single-precision floating-point unit (FPU). These digital signal control features build on the innovative technology that characterizes the Cortex-M family of processors. These features include a 32-bit core capable of 1.25 DMIPS/MHz for high performance, Thumb®-2 instructions for optimum code density and a Nested Vector Interrupt Controller (NVIC) for outstanding interrupt handling.
The CMSIS DSP library provides a suite of common signal processing functions for use on devices based on the Cortex-M processor. The implementation on Cortex-M4F fully leverages the integrated DSP instructions to provide robust vector math operations including:

- Basic math functions
- Fast math functions
- Complex math functions
- Filters
- Matrix functions
- Transforms
- Motor control functions
- Statistical functions
- Support functions
- Interpolation functions


### 2.3 14-Bit ADC

The MSP432P401R microcontroller has an on-chip 1-Msps 14-bit SAR ADC that is used to continuously sample the microphone output at 8 kHz. The microphone has a front-end operational amplifier. The output of the op amp is connected to ADC channel 10 (P4.3). To ensure a deterministic sampling rate, the ADC is automatically triggered by Timer_A0 channel CCR1.

### 2.4 µDMA

When the ADC sample is completed, the data is automatically moved to one of the two SRAM buffers using DMA channel 7. The µDMA module on the MSP432 MCUs acts as a separate master on the bus and does not interfere or stall the CPU access. The µDMA modules as a master enables parallel operations with the CPU executing code while the ADC sampling and DMA transfers occur.

### 3 Block Diagram

Figure 2 shows the block diagram of the application.

![Figure 2. Block Diagram](image-url)
4 System Design

This application uses the DSP extension of the Cortex-M4F CPU and the CMSIS-DSP library to perform real-time FFT with audio sampled using the onboard 14-bit ADC from microphone on the Educational BoosterPack MK II.

To ensure a real-time performance with no sample loss during processing, this application implements dual-buffered memory to store the ADC samples. When a buffer is full, the application starts processing the buffer while the application continues to sample the ADC in the background into the secondary buffer. A ping-pong scheme is set up for the μDMA, where the primary and alternative channel controls are configured to fill their respective 512-sample-deep data buffer. When the primary data buffer is filled, the DMA switches to the alternative data buffer while FFT processing on the primary data buffer begins in parallel.

Figure 3 shows the application flow chart.

4.1 Real-Time 512-Point Real FFT

The MSP432 MCU combined with the CMSIS-DSP Library supports up to 8192-point real and complex FFTs. This application demonstrates the performance of a 512-point real FFT. This application collects up to 512 ADC samples from the onboard microphone before starting the FFT routine. To ensure real-time FFT performance, this application implements a dual-buffered array where one buffer is always being filled, while the other is processed. The audio is sampled at a rate of 8 kHz using onboard intelligent peripherals such as the timer that automatically triggers the ADC to sample. The advanced μDMA moves the data to memory completely independent of CPU operations. A Hann window function is applied on the sampled data to further reduce the noise from the microphone input. The CMSIS-DSP API arm_rfft_q15() then performs the real FFT where the FFT output contains real values. The magnitude is then calculated and contains 256-point positive and negative frequencies. Because the display is only 128 pixels wide, each two adjacent frequency bins are combined, averaged, and displayed as one bar on the output graph.

Figure 4 shows the timing diagram.
5 Getting Started Hardware

Figure 5 shows that this application uses the MSP-EXP432P401R LaunchPad development kit with the BOOSTXL-EDUMKII Educational BoosterPack plug-in module.

![Figure 5. Stacked LaunchPad Kit and BoosterPack Module](image)

To power the LaunchPad development kit, connect the Micro-USB connector.

5.1 MSP-EXP432P401R LaunchPad Development Kit

The MSP-EXP432P401R LaunchPad development kit is based on the MSP432P401R microcontroller featuring a 48-MHz Cortex-M4F CPU and a wide variety of MSP analog and digital peripherals including the 14-bit ADC, high-speed communication, and enhanced security features. The MSP-EXP432P401R LaunchPad development kit integrates an onboard XDS110 debugger capable of programming and debugging the MSP432P401R MCU through JTAG, SWD, and BSL. The MSP-EXP432P401R LaunchPad development kit includes a standardized 40-pin header to enable interfacing with a wide variety of BoosterPack plug-in modules.

To learn more about this LaunchPad development kit, see [http://www.ti.com/tool/msp-exp432p401r](http://www.ti.com/tool/msp-exp432p401r).

5.2 BOOSTXL-EDUMKII Educational BoosterPack MK II

The BOOSTXL-EDUMKII Educational BoosterPack MK II offers a high level of integration for developers to quickly prototype complete solutions. Various analog and digital inputs and outputs are at your disposal including an analog joystick, environmental and motion sensors, RGB LED, microphone, buzzer, color LCD display, and more.

Figure 6 shows the modifications that this application requires to the BOOSTXL-AUDIO BoosterPack plug-in module.
For more information about the Educational BoosterPack MK II, see http://www.ti.com/tool/boostxl-edumkii.

6 Getting Started Firmware

To get started, download the zip package from www.ti.com/lit/zip/slaa707. Alternatively, the same software can be found in the comprehensive MSPWare software package, which is available directly in the Code Composer Studio™ IDE, from the TI Cloud Resource Explorer, or downloadable as stand-alone package.

6.1 Code Composer Studio™ (CCS) IDE

To get started with CCS:

1. Launch CCS.
2. Navigate to Project → Import CCS Projects.
3. Click Browse.
4. Navigate to the src/CCS folder.
5. Click Finish.

6. Click the debug button to download and debug the project.

If MSPWare is installed and present in the CCS TI Resource Explorer view, steps 2 through 5 may be replaced by navigating to the resource through MSPWare → Development Tools → MSP-EXP432P401R → BoosterPack Examples → BOOSTXL-EDUMKII MicrophoneFFT (see Figure 7) and importing the project directly from this location.
6.2 **IAR Embedded Workbench® (IAR) IDE**

To get started with IAR:
1. Navigate to the /src/IAR folder.
2. Double-click on BOOSTXL-EDUMKII_MicrophoneFFT_MSP432P401R.eww to open the IAR workspace project.
3. Click Project → Make to build the project.
4. Make sure that the Micro-USB is plugged in first to download and debug the application.
5. Click Project → Download and Debug.

7 **Application Execution Performance**

The signal-processing performance includes the clock cycles required to execute each FFT routine. The number of cycles required to perform a 512-point real FFT is approximately 25392 cycles, and approximately 530 µs at 48 MHz (IAR).

The system was designed to minimize the real-time impact due to multiple concurrent resources by leveraging CPU and DMA operations in parallel. DMA and CPU requests and activities may occur concurrently with minimal stalling or wait-states incurred.

The number of cycles required to perform a 512-point complex FFT is approximately 30489 cycles, and takes approximately 635.2 µs at 48 MHz with flash configured with one read wait state (using CCS). With further optimization and benchmarked at zero flash wait states, the 512-point real FFT function alone only takes 25392 cycles (IAR, maximum nondebug optimization settings). Figure 8 shows detailed cycle duration for the entire application. Major operations include: Hann window function on sampled data, FFT calculation, magnitude calculation, maximum peak identification, graph creation, and color LCD screen update.
Table 1 lists the main application operations and their durations.

Table 1. Application Operations and Duration (48 MHz With One Wait State)

<table>
<thead>
<tr>
<th>FUNCTION</th>
<th>DURATION (cycles)</th>
<th>DURATION (ms)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hann window initialization</td>
<td>323952</td>
<td>6.749</td>
</tr>
<tr>
<td>Hann window function</td>
<td>10253</td>
<td>0.2136</td>
</tr>
<tr>
<td>FFT initialization and processing</td>
<td>30490</td>
<td>0.6352</td>
</tr>
<tr>
<td>Magnitude calculation</td>
<td>23515</td>
<td>0.4899</td>
</tr>
<tr>
<td>Maximum peak identification</td>
<td>3378</td>
<td>0.07038</td>
</tr>
<tr>
<td>Redraw graph and update LCD</td>
<td>1209120</td>
<td>25.19</td>
</tr>
</tbody>
</table>
When the current is measured, the educational BoosterPack module is removed from the LaunchPad kit, because the backlight from the LCD on the BoosterPack module significantly contributes to the current on the system and dominates the system current. Figure 9 shows the current periodic interval of the system measuring the ADC while DMA moves the data and calculates the FFT.

Figure 9. FFT Application Current Profile

8 Software Files
Download the software files from www.ti.com/lit/zip/slaa707.

9 References
1. MSPWare Software
2. CMSIS DSP Software Library
3. MSP432P401R Mixed-Signal Microcontrollers
5. MSP-EXP432P401R tool page
IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESD48, latest issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI’s terms and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI’s terms and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily performed.

TI assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of significant portions of TI information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. TI is not responsible or liable for such altered documentation. Information of third parties may be subject to additional restrictions.

Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.

Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause harm and take appropriate remedial actions. Buyer will fully indemnify TI and its representatives against any damages arising out of the use of any TI components in safety-critical applications.

In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI’s goal is to help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and requirements. Nonetheless, such components are subject to these terms.

No TI components are authorized for use in FDA Class III (or similar life-critical medical equipment) unless authorized officers of the parties have executed a special agreement specifically governing such use.

Only those TI components which TI has specifically designated as military grade or “enhanced plastic” are designed and intended for use in military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components which have not been so designated is solely at the Buyer’s risk, and that Buyer is solely responsible for compliance with all legal and regulatory requirements in connection with such use.

TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of non-designated products, TI will not be responsible for any failure to meet ISO/TS16949.

**Products**

| Audio       | www.ti.com/audio |
| Amplifiers  | amplifier.ti.com  |
| Data Converters | dataconverter.ti.com |
| DLP® Products | www.dlp.com     |
| DSP         | dsp.ti.com       |
| Clocks and Timers | www.ti.com/clocks |
| Interface   | interface.ti.com |
| Logic       | logic.ti.com     |
| Power Mgmt  | power.ti.com     |
| Microcontrollers | microcontroller.ti.com |
| RFID        | www.ti-rfid.com  |
| OMAP Applications Processors | www.ti.com/omap |
| Wireless Connectivity | www.ti.com/wirelessconnectivity |

**Applications**

| Automotive and Transportation | www.ti.com/automotive |
| Communications and Telecom   | www.ti.com/communications |
| Computers and Peripherals   | www.ti.com/computers  |
| Consumer Electronics        | www.ti.com/consumer-apps |
| Energy and Lighting         | www.ti.com/energy     |
| Industrial                 | www.ti.com/industrial |
| Medical                    | www.ti.com/medical   |
| Security                   | www.ti.com/security  |
| Space, Avionics and Defense | www.ti.com/space-avionics-defense |
| Video and Imaging           | www.ti.com/video     |

**TI E2E Community**
e2e.ti.com

Mailing Address: Texas Instruments, Post Office Box 655303, Dallas, Texas 75265
Copyright © 2016, Texas Instruments Incorporated