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PGA900 Software Quick Start Guide

Texas Instruments PGA900 is an interface device for piezoresistive and strain gauge pressure sense
elements. The device incorporates analog front end that directly connects to the sense element and has
voltage regulators and an oscillator. The device also includes sigma-delta analog-to-digital converter,
ARM® Cortex®-M0 microprocessor and OTP memory.

This document describes a quick start procedure, PGA900 software architecture, source code directory
structure, and software driver details.

1 Procedure to Build PGA900 Code
1. Download latest Code Composer Studio™ (CCS) from www.ti.com. TI recommends CCS version

6.1.1.00022.
• If the user is using an older version, then migrate to CCS version 6.1.1.00022.
• While migrating to CCS 6.1.1.00022, uninstall older CCS version and perform full fresh installation

of CCS 6.1.1.00022.
2. While installing CCS on machine, use option 'Setup Type: Complete Feature Set'.
3. Check whether rtsv6M0_T_le_eabi.lib is present in following path: C:\ti\ccsv6\tools\compiler\ ti-cgt-

arm_5.2.6\lib\ (use this path if CCS is installed on the C:\ drive, otherwise substitute the appropriate
drive where it was installed).

4. In case rtsv6M0_T_le_eabi.lib is not present in the path from the previous step, then copy
rtsv6M0_T_le_eabi.lib into path C:\ti\ccsv6\tools\compiler\ ti-cgt-arm_5.2.6\lib\ (use this path if CCS is
installed on the C:\ drive, otherwise substitute the appropriate drive where it was installed).

5. Copy PGA900 folder (having PGA900 code) or ‘code’ folder into any path (for example, D:\temp)
6. Launch CCS IDE.
7. Workspace Launcher window pops up.

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU015A
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8. Provide workspace path (for example, D:\temp)

Figure 1. CCS Workspace Launcher

9. Import PGA900 code using Project → Import CCS Projects.

Figure 2. Import CCS Project

http://www.ti.com
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10. Import CCS Projects window will get pop-up as shown in Figure 3.
11. Provide the path in the Select search-directory option (for example, D:\temp).

Figure 3. Select Search-Directory

12. Discovered projects: Option shows PGA900 as shown in Figure 3 or code.
13. Click finish button.
14. Project Explorer window displays the PGA900 folder as shown in Figure 4 or code folder.

http://www.ti.com
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Figure 4. PGA900 Project

http://www.ti.com
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15. Compile PGA900 project using the Project → Build Project option.

Figure 5. PGA900 Build Project

NOTE: In the PGA900 project, Cortex M0 setting is already present. If the user wants to confirm it,
then use Project → Properties → Build → ARM Compiler → Processor Options → Target
processor version.

Figure 6. Target Processor Cortex M0 Selection

http://www.ti.com
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2 Procedure to Generate Intel Hex File
1. Go to menu Project → Properties.

Figure 7. Project Options

2. Select ‘Build’ to see ‘Steps’ as shown in Figure 8.

Figure 8. Build Options

http://www.ti.com
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3. In ‘Post-build steps’, type the Command "${CG_TOOL_HEX}" -i "${BuildArtifactFileName}" -o
"${BuildArtifactFileBaseName}.hex" -order LS -romwidth 32 and in Description field enter ‘Create flash
Image Intel-Hex’ as shown in Figure 9. -order LS indicates little-endian and -romwidth 32 indicates hex
conversion formats width.

Figure 9. Flash Image Intel Hex Configuration

4. Click Apply button.
5. Click OK button.
6. Compile PGA900 code and Intel hex file (PGA900.hex) is generated in the Debug folder.

http://www.ti.com
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3 Procedure to Run PGA900 Firmware on PGA900EVM
The two development platforms are:
• USB2ANY interfacing board along with PGA900GUI and PGA900EVM
• XDS200 USB JTAG emulator and PGA900EVM

3.1 USB2ANY Interfacing Board Along With PGA900GUI and PGA900EVM
The USB2ANY provides the interface communication between the PGA900EVM and the PGA900GUI.

For more details, refer to the PGA900 EVM User's Guide, SLDU011.

3.2 XDS200 USB JTAG Emulator and PGA900EVM
Prerequisites:
• Installed CCS version CCS 6.1.1.00022.
• Spectrum Digital XDS200 USB JTAG Emulator kit
• PGA900 EVM

Connection between the Spectrum Digital XDS200 USB JTAG Emulator and PGA900EVM
1. For details regarding the Spectrum Digital XDS200 USB JTAG Emulator, refer to the XDS200 Quick

Start Guide http://emulators.spectrumdigital.com/files/XDS200_QSG.pdf
2. The Spectrum Digital XDS200 USB JTAG Emulator kit contains three adapters. Connect the CTI20-

ARM10 adapter to XDS200.
3. All XDS200 USB drivers and CCS v6 drivers are included with the CCS6.1.1.00022 software

installation.
4. Connect the included USB cable to a USB port on the host computer and then connect the USB cable

to the XDS200. Windows® recognizes the new hardware connection and completes the XDS200
installation automatically on Windows 7 or higher operating systems. On Windows XP, follow the
hardware installer instructions and answer 'Yes' or 'default' if prompted

5. PGA900EVM should be unpowered at this time. Connect CTI20-ARM10 adapter to connector J6 of
PGA900EVM. Figure 10 shows the orientation.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLDU015A
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Figure 10. XDS200 Emulator Connection to the PGA900EVM

3.2.1 Setup the Target Configuration Options
A Target Configuration tells CCS how to connect to the device. It describes the device using gel files and
device configuration files.
1. PGA900.xml file is available in the 'docs' folder of the software release package.
2. Copy the PGA900.xml file into folder C:\ti\ccsv6\ccs_base\common\targetdb\devices\ (if CCS is

installed on C:\ drive otherwise select appropriate drive).
3. M0_systick.xml, M0_nvic.xml, and pga900_csr.xml files are available in the 'docs' folder of the software

release package.
4. Create folder 'PGA900' in the CCS installation path C:\ti\ccsv6\ccs_base\common\targetdb\Modules\ (if

CCS is installed on C:\ drive otherwise select appropriate drive).
5. Copy M0_systick.xml, M0_nvic.xml, and pga900_csr.xml files into the PGA900 folder path

C:\ti\ccsv6\ccs_base\common\targetdb\Modules\PGA900\ (if CCS is installed on C:\ drive otherwise
select appropriate drive).

6. pga900.gel file is available in the 'docs' folder of the software release package.
7. Copy pga900.gel file into folder C:\ti\ccsv6\ccs_base\emulation\gel\ (if CCS is installed on C:\ drive

otherwise select appropriate drive).
8. Launch Code Composer Studio v6 from the shortcut on the desktop (that was created when CCS v6

was installed).
9. The Code Composer Studio v6 window appears. Click the 'File' menu, then select 'New- → Target

Configuration File'
10. The 'New Target Configuration' window appears.

(a) Type a name for the target configuration file. It will have a .ccxml suffix.
(b) Leave the 'Use shared location' box checked.

http://www.ti.com
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11. Select 'Finish'.

Figure 11. XDS200 Emulator Target Configuration

12. The 'Basic' configuration setup window will appear. Select 'Texas Instruments XDS2xx USB Debug
Probe' from the 'Connection' menu.

Figure 12. XDS200 Emulator Connection Configuration

http://www.ti.com
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13. Board or Device → type filter text as 'PGA900' and select PGA900 device.
14. Select 'Save'.
15. Click Target Configuration.

Figure 13. XDS200 Emulator Device Configuration

http://www.ti.com
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16. The 'Advanced' configuration setup window appears.
17. Select 'Texas Instruments XDS2xx USB Debug Probe_0'.

Figure 14. XDS200 USB Emulator Configuration

http://www.ti.com
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18. 'Connection Properties' setting should be as shown in Figure 15. Table 1 shows the 'Connection
Properties' configured parameters.

19. Select 'Save'.

Figure 15. XDS200 USB Emulator Connection Properties

Table 1. Connection Properties Parameter Configuration

Connection Type Connection Properties
Board data file Auto generate
Emulator I/O Port Number 0
The JTAG nTRST Boot-Mode Disabled – Both EMU pins remain hi-z
The Power-On-Reset Boot-Mode Disabled – Both EMU pins remain hi-z
The JTAG TCLK Frequency (MHz) Adaptive with user specified limit
---Enter a value from 50KHz to 20.0 MHz 1.0MHz
The JTAG Signals Isolation Upon Disconnect Do not isolate JTAG signals when last client disconnects
Apply nReset/SRST pin on the debug header Do NOT pulse this pin on debug probe startup
JTAG/ cJTAG/SWD Mode SWD Mode - User COM port is target UART port

http://www.ti.com
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20. Apply power to the PGA900EVM.
21. Select 'Test Connection'.

Figure 16. XDS200 USB Emulator Test Connection

22. 'Test Connection' report is displayed.

Figure 17. XDS200 USB Emulator Test Connection Report

http://www.ti.com
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3.2.2 Launch the Debugger
1. Open the project and compile the code.
2. Launch the debugger by right-clicking the target configuration and selecting 'Launch Selected

Configuration'.

Figure 18. Launch Debugger

3. The debugger window appears.

Figure 19. Debugger Window

3.2.3 Connect to the Target
1. In the debug window, select which CPU to connect to.

• In this example, the Cortex_M0_0 is selected.
2. Right-click the core and select 'Connect Target'.

• Alternative: Select 'Run → Connect Target'
• Alternative: Use the keyboard shortcut CTRL + ALT + C

http://www.ti.com
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Figure 20. Connect to the PGA900EVM

NOTE: The user can configure the debug button to also automatically connect to the target after
launch. In the CCS Debug perspective: 'Tools → Debugger Options → Auto Run and Launch
Options' and select 'Connect to Target on Debugger Setup'.

http://www.ti.com
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Select Auto Run and Launch Options as in Figure 21.

Figure 21. Auto Run and Launch Options

Select Program/Memory Load Options as in Figure 22.

Figure 22. Program/Memory Load Options

http://www.ti.com
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3.2.4 Load the Application
1. Select 'Run → Load → Load Program'.

Figure 23. Load Program

2. Select 'Browse Projects'. All projects imported into CCS are shown along with their .out file if they exist.
3. Select the .out file to load into the MCU.
4. Select 'Ok'.

3.2.5 Run the Program
Select the green arrow icon on the toolbar or go to 'Run → Resume' (see Figure 24).

Figure 24. Run Program

http://www.ti.com
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3.2.6 Add Variables to the Expression View
To quickly add variables to the expressions view:

Go to 'View → Expressions' and enter name of the global variable, for example, ADC_Count1.

Figure 25. Expressions View

3.2.7 View PGA900 Registers
Go to 'View → Registers' (see Figure 26).

Figure 26. PGA900 Registers

http://www.ti.com
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3.3 PGA900EVM, XDS200 USB JTAG Emulator, and USB2ANY Usage
The following steps show the test scenario for simultaneous use of the XDS200 USB JTAG emulator and
USB2ANY interfacing board along with PGA900GUI with PGA900EVM.
1. XDS200 USB JTAG emulator is used to load the application into PGA900EVM. Run it and debug the

downloaded application.
2. PGA900GUI with USB2ANY interfacing board is used to communicate with PGA900EVM using

COMBUF registers when the PGA900 microcontroller is running. PGA900GUI writes data into the
COM_DIF_TO_MCU register and reads data from the COM_MCU_TO_DIF register while PGA900
microcontroller is running.

4 Troubleshooting XDS200 USB JTAG Emulator
Strategy for troubleshooting XDS200USB JTAG emulator connectivity problems
1. Check that you are using high-quality cables for connections.
2. Determine whether the USB cable is connected to a USB port of the host computer and to the

XDS200.
3. Determine whether the emulator is correctly setup in Windows (that is, are the USB driver, and so

forth, working?) by checking in the Windows system devices control panel. If this is not right, then the
user needs to check the CCS installed version. Recommended CCS version is CCS 6.1.1.00022.

4. Determine whether the CTI20-ARM10 adapter is connected to XDS200 and connector J1 of
PGA900EVM, and check its orientation. Refer to Section 3.2.

5. Determine whether USB2ANY interfacing board is connected to the PGA900EVM. In case it is
connected to PGA900EVM, then disconnect it from PGA900EVM or make sure that the USB2ANY
interfacing board is connected to a USB port of the host computer.

http://www.ti.com
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