This manual describes the operation of the DLP® Discovery™ 4100 Development Kit software (Discovery 4100 Explorer). The Discovery 4100 Explorer software provides control and display functions via USB 2.0 for the DLP Discovery 4100 hardware.

Figure 1. Discovery 4100 Explorer
1 Overview

This manual provides:
- A general description of the DLP Discovery 4100 Explorer Software
- Descriptions of the Discovery 4100 Explorer menus, toolbars and display windows
- Operation instructions

2 Terms and Definitions

DMD—Digital micromirror device
GUI—Graphical user interface
USB—Universal serial bus

3 Software Overview

The DLP Discovery 4100 Explorer Software allows the user to control the DLPC410 controller board hardware via USB 2.0 (or 1.1). The software uses the Discovery 4100 ActiveX™ control API which is documented separately in the DLP® Discovery™ 4100 Development Kit API Programmer’s Guide (DLPU039). The software has controls for building and executing a command script.

The GUI provides users with access to the ActiveX control’s implementations of the following commands:
- Load individual blocks or entire DMD from image file
- Reset individual blocks or global reset
- Clear individual blocks or global clear
- Float all DMD mirrors
- Wait for external global reset input
- Timed delay
- Loop iteration control – Loop for N times or until break
- General purpose digital output control

3.1 DMD Image Control

Images are controlled and displayed in blocks on the DMD. The organization of the DMD blocks varies for different DMD types as shown in Table 1. Blocks can be loaded and displayed individually, or as an entire image (all 16 blocks). Section 3.2 will explain the commands to control the different ways an image can be displayed.

There are numerous combinations of display options available and this manual is not designed to cover them all. This user’s guide will present an overview of how each command can be used to control an image. Section 5 describes how to run a script of commands to control the displaying of an image.

<table>
<thead>
<tr>
<th>TYPE</th>
<th>COLUMNS</th>
<th>ROWS</th>
<th>BLOCKS</th>
<th>ROWS / BLOCK</th>
</tr>
</thead>
<tbody>
<tr>
<td>DLP9500 - 0.95 1080p Type A</td>
<td>1920</td>
<td>1080</td>
<td>15</td>
<td>72</td>
</tr>
<tr>
<td>DLP7000 - 0.7 XGA Type A</td>
<td>1024</td>
<td>768</td>
<td>16</td>
<td>48</td>
</tr>
</tbody>
</table>

For more information on display blocks for each DMD type refer to the DMD datasheets (DLP7000 § 8.4 and DLP9500 § 8.4).

3.2 Image Commands

- Load – Loads image blocks into the DMD memory.
- Load and Reset – Loads image blocks into the DMD memory and displays the contents on the DMD.
- Reset – Displays the contents of memory on the DMD.
4 Graphical User Interface

The Explorer Software user interface consists of a multiple display interface containing a menu bar, toolbar and three display windows: Script Commands Window, Script Window and Status Window. The function of each item is described in the following sections.

4.1 Menu Bar

The menu bar commands provide standard menu access to software commands as shown in Figure 3.

Figure 2. Graphical User Interface Layout

Figure 3. Menu Bar
4.1.1 File Menu

The File menu contains the standard New, Open, Save, Print, and Exit menu items. There are options to open a script or a status and to save a script or a status.

![File Menu]

**Figure 4. File Menu**

4.1.2 View Menu

The View menu allows you to show or hide any of the display windows.

![View Menu]

**Figure 5. View Menu**

4.1.3 DMD Menu

The DMD menu is used to select the DLPC410 Control operation mode.

![DMD Menu]

**Figure 6. DMD Menu**
4.1.4 Execution Menu

The Execution menu contains script commands and configuration options:

- **Run** – Executes all the commands in the list without interruption, repeating script until Stop selected.
- **Run Once** – Executes all the commands in the list without interruption for one cycle.
- **Loop Break** – Exit a “Loop Until Break” script command.
- **Step** – Sets the execution of commands to one step at a time mode.
- **Next Step** – Executes the next script command.
- **Stop** – End execution.
- **Set Start** – Sets the start point of command execution within the script.
- **Set End** – Sets the end point of command execution within the script.

![Figure 7. Execution Menu](image)

4.1.5 Help Menu

The Help menu contains a link to standard Windows help file contents and the command to load the About dialog box.

![Figure 8. Help Menu](image)
4.2 Toolbar

The Toolbar contains buttons to provide you with shortcuts to perform certain operations.

![Figure 9. Toolbar](image)

4.2.1 File Menu Buttons
The first five buttons on the toolbar, New, Open, Save, Save As, and Print, have the same function as the five items in the File menu.

4.2.2 Run, Run Once, Loop Break, Step and Stop Controls
Run, Run Once, Loop Break, Step and Stop icons control the execution of the list of commands in the script window. Command function is as described in Section 4.1.4.

4.2.3 Set Start and End Buttons
Set Start and Set End icons set the start point and end point of command execution within a script.

4.2.4 Help Button
The Help button displays the help contents for the application.
4.3 Script Commands Window

The Script Commands Window, Figure 10, contains a series of Command Tabs with command options for building script commands. A script is built by adding commands to execute the desired sequence of operations on the DMD. To view and select the options associated with a command, click on the corresponding command tab. Once you’ve selected the commands and options, click the Add button to add the command options to the script.

Figure 10. Script Commands Window
4.3.1 Load Tab

Load commands select the image file and specify load operations.

An image file must be selected before the Add button is pressed. To select an image file click the Open Image button and select the image file. Supported image file types are .bmp, .jpg, .gif and .bin. A .bin file is a binary file containing one bit per DMD pixel.

The image data may be loaded to DMD memory by selecting **Load** or the image data may be loaded and the DMD reset to display the image by selecting **Load and Reset**. If **Load and Reset** is not selected the image will not be visible until a separate Reset command is executed.

The entire image may be loaded (**Global**) or individual blocks may be loaded (**Block**). Block numbers may be from 1 to 16. Loading block 16 on a DLP9500 (0.95 1080p) DMD will be ignored since this DMD has only 15 blocks.

The image may be mirrored in the horizontal direction by selecting **Mirror Image**.

Select the desired options and **Add** button to add the command to the script.

![Figure 11. Load Tab](image)
4.3.2 Reset Tab

The Reset command causes the mirrors to change from the current state to the state of that in memory. The contents of memory are determined by the Load or Clear commands. You can choose to reset all the blocks (Global), or you can choose to reset blocks individually using the Single Block option or a group of blocks using one of the Multiple Blocks options. Select the option you want to use and click the Add button to add the command to the script.

![Figure 12. Reset Tab](image-url)
4.3.3 Clear Tab

The Clear Tab commands clear the memory contents of all the blocks using the Global option or individually using the Single Block option by writing zeroes to the contents of DMD memory. The Clear option clears memory only, the Clear and Reset option clears memory and performs a reset to change the display. Select the desired option and click on the Add button to add to script (see Figure 13).

NOTE: The Global option is implemented in software by sequentially issuing a DMD Block Clear command to all the blocks on the DMD.

![Clear Tab](image-url)

**Figure 13. Clear Tab**
4.3.4 Float Tab

The Float Tab command places the DMD in a safe state with the mirrors in the *floated* (nominally flat) condition and no bias applied to the DMD.

![Float Tab Interface](image)

Figure 14. Float Tab
4.3.5 Control Tab

The Control commands tab supports commands for script execution control, external reset, and digital output:

- The Wait for External Reset command will wait 10 seconds for an external global reset triggered by a rising edge on input GPIOA.0. After 10 seconds, execution of the script will resume with the next command in the script. GPIOA.0 is a 2.5-V CMOS input.

- The Delay command delays for the specified time in msec.

- The Loop Until Break command loops until the Break button is clicked.

- The Loop command loops for the specified number of iterations.

- The Set GP Output command sets the value of general purpose digital outputs GPIOA.2-4. Value is entered in decimal. Bits 4, 3, 2 of value control the output state. Bits 7, 6, 5, 1, 0 of value are not used. GPIOA.2-4 are 2.5-V CMOS outputs.

NOTE: For more information on GPIO outputs see the DLP® Discovery™ 4100 Development Kit API Programmer’s Guide (DLPU039 § 5.2.24 and § 6.2.24)

![Control Tab](image)
4.4 Status Window

The Status Window displays the execution status, retrieved information and any responses sent back to the host from the DLP Discovery 4100 Development Kit after a command has been executed.

![Status Window](image)

**Figure 16. Status Window**

4.5 Script Window

The Controller Board GUI uses a Script window to keep track of the images to be loaded and the commands to be executed on the DMD (Figure 17). Once you've added an image and the commands you want to execute to the script, you can change the command order, delete and insert commands at a specified location within the script.

![Script Window](image)

**Figure 17. Script Window**

The application executes commands in the order in which they are entered in the script. In order for the application to execute commands, the first command in the script must be the `Image` command followed by the correct path and file name for an existing image. To learn how to insert an image into the script, see Section 4.3.1.
4.5.1 Inserting Commands

To insert a command in a specified location on the script, select the command from the Commands window, go to the desired location in the script and click the \[INS\] (INS) button at the top of the Script Window.

4.5.2 Moving Commands

To alter the command order, select the command you want to move by clicking on it, then click the \[Up\] (Up) arrow or the \[Down\] (Down) arrow to move it to the desired location.

You can also move a command to the \[First\] (First) position in the script by using the button, or move it to the \[Last\] (Last) position with the button.

4.5.3 Deleting Commands

To delete a command from the script, click on the command you want to delete and click the \[Del\] (Del) button at the top of the Script Window.

5 Script and Status Operations

5.1 Saving Scripts and Statuses

5.1.1 Saving a Script

To save a script, proceed as follows:

1. Select the Script option from the \[Save\] or \[Save As\] icon drop down menu on the tool bar, or select Save Script or Save Script As from the Save option menu on the File menu.
2. Once the selection is made, a common dialog box will appear. Select or type the name of the file you would like to save the script to.
3. Click the \[OK\] button and a message box will appear to notify you that the script has been saved.

5.1.2 Saving a Status

To save the contents of the Status Window, proceed as follows:

1. Select the Status option from the \[Save\] or \[Save As\] icon drop down menu on the tool bar, or select Save Status or Save Status As from the Save option menu on the File menu.
2. Once the selection is made a common dialog box will appear, select or type the name of the file you would like to save the status.
3. Click the \[OK\] button and a message box will appear to notify you that the status log has been saved.

NOTE: Status files are saved with a .sts extension.
5.2  Printing Scripts and Statuses

5.2.1  Printing a Script

To print a script, select the Script option from the (Print) icon drop down menu on the toolbar, or select
the Script item from the Print option menu on the File menu.

5.2.2  Printing a Status

To print the contents of the Status Window, select the Status option from the (Print) icon drop down
menu on the toolbar, or select the Status item from the Print option menu on the File menu.

5.3  Opening Scripts and Statuses

You can open scripts [*.txt] or status files [*.sts] that have been previously saved by clicking the (Open
File) icon on the toolbar or by selecting the Script or Status option from the Open File menu on the File
menu. Once you’ve selected the desired file, the file will be opened and the script or status file will be
displayed in the Script or Status window.

NOTE:  Scripts can be edited with a simple text editor. Therefore, when a script is opened it is
checked for consistency. If a command is missing a matching parameter or a parameter is
missing a matching command, an error dialog will appear and the script will not be opened.
The script must be corrected before it can be opened.

5.4  Creating New Scripts and Statuses

You can create a new script or status file by clicking the New File icon on the toolbar and then selecting
the Script or Status option or by selecting the Script or Status option from the New File menu item on the
File menu.

5.4.1  Creating a New Script

To open a new script, select the Script option from the (New) toolbar icon drop down menu, or select
the Script item from the New option menu on the File Menu.

Once the selection is made, you will first be prompted to save the current script and then a blank script will
be inserted.

5.4.2  Creating a New Status

To open a new status, select the Status option from the (New) toolbar icon drop down menu, or select
the Status item from the New option menu on the File Menu.

Once the selection is made, you will first be prompted to save the current status log and then a blank
status will be inserted.
6 DLP Discovery 4100 Operation

The DLP Discovery 4100 Development Kit is capable of operating at about 10 XGA frames per second or 7 1080p frames per second when connected to a host system’s USB 2.0 port.

6.1 Quick Start Guide on Operation

The following steps must be followed in order to operate the device:

1. Install the software by executing D4100Explorer-1.1-windows-installer.exe. Install the software BEFORE connecting the DLP Discovery 4100 Development Kit with USB. The setup program will install the software and driver INF files necessary for operation.

2. A reboot is recommended before connecting the kit because some systems will not properly install the drivers if the system is not re-booted first.

3. Connect the DLP Discovery 4100 Development Kit board with a USB 2.0 mini-B to Type A cable and apply power to the DLP Discovery 4100 Development Kit. The operating system will detect the USB device and automatically install or prompt to install the driver.

4. Start the DLP Discovery Explorer software from the Start/Texas Instruments/DLP Discovery 4100 Explorer menu.

5. The software will start. The USB connection status and DMD type should be displayed in the lower left status panel (Figure 18):

6. Open an image using the Load Tab / Open Image button.

7. Enter an image command in the script by selecting the desired options in the Load Tab button and
clicking Add.

8. Select and enter commands in the script. You select commands from any one of the command tabs on the Commands Window. Each tab contains a set of related commands and the options assigned to each command. Once you have selected the right combination of commands and options, enter the command into the script by clicking the Add button at the bottom of the command tab. Each tab has an Add button to enter that command into the script.

9. Execute the script. Once the desired list of commands has been entered into the Script Window, click the (Run) icon on the toolbar to begin executing commands. You can also choose to step through the commands using the (Step) icon on the toolbar instead of running through them all. You can also use the Execution menu to perform the same functions. Use the (Stop) icon on the toolbar to stop executing commands.
7 DLPC410 Control Window

The DLPC410 Control window is accessed through the DMD/DLPC410 Control menu and provides direct control of the DLPC410 input signals. No script commands are generated, the control is applied immediately to the DLPC410 when a Set button is clicked.

The upper portion of the window supports reading and setting of the DLPC410 signals used in writing data to the DMD. The current value for ROWMD, ROWADDR, BLKMD, and BLKADDR is displayed in the Current Value column. When a new value is entered in Hexadecimal in the Hex column and the Set button is clicked the value will be sent to the DLPC410. The Load Row button sends one row with repeating values of the 4 digit hex value entered.

The lower portion of the window supports control of the DLPC410 input signals which are control operational modes. Click a button to toggle the current value of the signal.

Refer to the DLPC410 data sheet (DLPS024) for detailed information on the DLPC410 input signals.

Refer to the DLP Discovery 4100 Development Kit API Programmer’s Guide (DLPU039) for detailed information about the ActiveX functions called by the buttons on this DMD/DLPC410 Control menu page.

Figure 19. DLPC410 Control Window
8 About Box

The About Box provides version information about various software and hardware of the DLP Discovery 4100 Development Kit.

![About Box](image)

Figure 20. About Box

9 Links

For more information about Texas Instruments DLP Discovery 4100 Development Kit visit www.ti.com/tool/dlpd4x00kit.
IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESD48, latest issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI’s terms and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI's terms and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily performed.

TI assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party or the intellectual property of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of significant portions of TI information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. TI is not responsible or liable for such altered documentation. Information of third parties may be subject to additional restrictions.

Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.

Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause harm and take appropriate remedial actions. Buyer will fully indemnify TI and its representatives against any damages arising out of the use of any TI components in safety-critical applications.

In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI’s goal is to help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and requirements. Nonetheless, such components are subject to these terms.

No TI components are authorized for use in FDA Class III (or similar life-critical medical equipment) unless authorized officers of the parties have executed a special agreement specifically governing such use.

Only those TI components which TI has specifically designated as military grade or “enhanced plastic” are designed and intended for use in military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components which have not been so designated is solely at the Buyer’s risk, and that Buyer is solely responsible for compliance with all legal and regulatory requirements in connection with such use.

TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of non-designated products, TI will not be responsible for any failure to meet ISO/TS16949.

<table>
<thead>
<tr>
<th>Products</th>
<th>Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio</td>
<td><a href="http://www.ti.com/audio">www.ti.com/audio</a></td>
</tr>
<tr>
<td>Amplifiers</td>
<td>amplifier.ti.com</td>
</tr>
<tr>
<td>Data Converters</td>
<td>dataconverter.ti.com</td>
</tr>
<tr>
<td>DLP® Products</td>
<td><a href="http://www.dlp.com">www.dlp.com</a></td>
</tr>
<tr>
<td>DSP</td>
<td>dsp.ti.com</td>
</tr>
<tr>
<td>Clocks and Timers</td>
<td><a href="http://www.ti.com/clocks">www.ti.com/clocks</a></td>
</tr>
<tr>
<td>Interface</td>
<td>interface.ti.com</td>
</tr>
<tr>
<td>Logic</td>
<td>logic.ti.com</td>
</tr>
<tr>
<td>Power Mgmt</td>
<td>power.ti.com</td>
</tr>
<tr>
<td>Microcontrollers</td>
<td>microcontroller.ti.com</td>
</tr>
<tr>
<td>RFID</td>
<td><a href="http://www.ti-rfid.com">www.ti-rfid.com</a></td>
</tr>
<tr>
<td>OMAP Applications Processors</td>
<td><a href="http://www.ti.com/omap">www.ti.com/omap</a></td>
</tr>
<tr>
<td>Wireless Connectivity</td>
<td><a href="http://www.ti.com/wirelessconnectivity">www.ti.com/wirelessconnectivity</a></td>
</tr>
</tbody>
</table>

Mailing Address: Texas Instruments, Post Office Box 655303, Dallas, Texas 75265
Copyright © 2016, Texas Instruments Incorporated