Preface ....................................................................................................................................... 4
1 Kit Contents, eZ430-F2013 .................................................................................................... 5
2 eZ430-F2013 Overview ........................................................................................................ 5
3 Software Installation ............................................................................................................ 6
4 Hardware Installation ........................................................................................................... 6
5 Flashing the LED Demo Using IAR ..................................................................................... 6
6 Flashing the LED Demo Using CCS .................................................................................... 7
7 Using the MSP430F2013 Target Board and Debugging Interface Independently .............. 7
8 Where To Go For More Information ................................................................................... 7
9 Frequently Asked Questions ............................................................................................... 8
10 Schematics ........................................................................................................................ 9
If You Need Assistance

Support for the MSP430 device and the eZ430-F2013 is provided by the Texas Instruments Product Information Center (PIC). Contact information for the PIC can be found on the TI web site at www.ti.com. Additional device-specific information can be found on the MSP430 web site at www.ti.com/msp430 and www.ti.com/ez430.

NOTE: Kickstart is supported by Texas Instruments

Although Kickstart is a product of IAR, Texas Instruments provides the support for it. Therefore, please do not request support for Kickstart from IAR. Please consult the extensive documentation provided with Kickstart before requesting assistance.

FCC Warning

This equipment is intended for use in a laboratory test environment only. It generates, uses, and can radiate radio frequency energy and has not been tested for compliance with the limits of computing devices pursuant to subpart J of part 15 of FCC rules, which are designed to provide reasonable protection against radio frequency interference. Operation of this equipment in other environments may cause interference with radio communications, in which case the user at his own expense will be required to take whatever measures may be required to correct this interference.
1 Kit Contents, eZ430-F2013

- One eZ430-F2013. The hardware is housed inside a plastic enclosure that may be opened in order to separate the MSP-EZ430D target board from the MSP-EZ430U debugging interface.
- One MSP430 Development Tool CD-ROM which contains several documents including the following related to the eZ430-F2013:
  - MSP430x2xx Family User's Guide, SLAU144
  - MSP-FET430 FLASH Emulation Tool User's Guide Errata, SLAZ027
  - eZ430-F2013 User's Guide (this document)
  - IAR Embedded Workbench KickStart Version
  - Code Composer Studio MCU Edition

2 eZ430-F2013 Overview

The eZ430-F2013 is a complete MSP430 development tool providing all the hardware and software to evaluate the MSP430F2013 and complete an entire project in a convenient USB stick form factor. The eZ430-F2013 uses the IAR Embedded Workbench or Code Composer Studio Integrated Development Environment (IDE) to provide full emulation with the option of designing a stand-alone system or detaching the removable target board to integrate into an existing design. The USB port provides power to operate the ultra-low-power MSP430 so no external power supply is required.

All 14-pins on the MSP430F2013 are accessible on the MSP-EZ430D target board for easy debugging and interfacing with peripherals. Additionally, one of the digital I/O pins is connected to an LED for visual feedback. The MSP430F2013 includes 16-MIPS performance, a 16-bit Sigma Delta Analog-to-Digital converter, a 16-bit timer, Watchdog timer, brownout detector, a USI module supporting SPI and I2C, and five low-power modes drawing as little as 0.5 µA standby.

Figure 1. eZ430-F2013 Development Tool

![Figure 1. eZ430-F2013 Development Tool](image-url)
3 Software Installation

The latest versions of these IDEs are available from the MSP430 web site at www.ti.com/msp430.

1. Insert the MSP430 CD-ROM into your computer. It should start automatically, and the MSP430 start page will then be displayed. You can also use a browser to open "index.htm" that is located in the root directory of the MSP430 CD-ROM. The eZ430-F2013 is compatible with Windows XP.

2. Select Software → IAR Workbench Kickstart or Software → Code Composer Studio and follow the instructions.

3. Respond to the prompts to install the software. The installation procedure will install IAR and TI files. Finish the installation.

4 Hardware Installation

1. Install IDE of preference, either IAR or CCS.

2. Drivers will be installed automatically during IDE install.

3. Plug in the eZ430 emulator.

5 Flashing the LED Demo Using IAR

This section demonstrates how to setup a project for the eZ430-F2013 and download the application to the MSP430F2013. The sample program will blink the LED on the MSP-EZ430D target board.

Start the Workbench (Start → Programs → IAR Systems → IAR Embedded Workbench Kickstart for MSP430 V3 → IAR Embedded Workbench).

1. Use File → Open Workspace to open the file at C:\Program Files\IAR Systems\Embedded Workbench 4.0\430\FET_examples\Flashing the LED.eww. The workspace window will open.

2. Click the msp430x2xx (C – SpyBiWire) tab at the bottom of the workspace window that corresponds to the eZ430-F2013.

3. Set the correct device by clicking on Projects → Options → General Options → Target and select the MSP430F2013 from the device list.

4. In the Options windows, go to FET Debugger → Setup → Connection and select TI USB FET to use the USB interface.

5. Use Project → Rebuild All to build and link the source code. You can view the source code by double-clicking on the project, and then double-clicking on the displayed source file.

6. Use Project → Download & Debug to start the C-SPY debugger. C-SPY will erase the device Flash, and then download the application object file to the device Flash.

7. Use Debug → Go to start the application. The LED should flash!

8. Use Debug → Stop Debugging to stop debugging, to exit C-SPY and to return to the Workbench.

9. Use File → Exit to exit the Workbench.

Congratulations, you've just built and tested your first MSP430 application.
6 Flasing the LED Demo Using CCS

This section demonstrates how to setup a project for the eZ430-F2013 and download the application to the MSP430F2013. The sample program will blink the LED on the MSP-EZ430D target board.

Start CCS (Start → Programs → Texas Instruments → Code Composer Studio v4 → Code Composer Studio v4).
1. Project → Import Existing CCS/CCE Eclipse Project
2. Select Root Directory: C:\Program Files\Texas Instruments\CCSv4\msp430\examples\example projects\msp430x2xx C Example
3. Click Finish.
4. Use Target → Debug Active Target to begin the debug session.
5. If there is a device mismatch, click ignore.
6. Use Target → Run to start the application.
7. Observe blinking LED.
8. Use Target → Terminate All to exit debug session.
9. Use File → Exit to exit the IDE.

Congratulations, you've just built and tested your first MSP430 application.

7 Using the MSP430F2013 Target Board and Debugging Interface Independently

The eZ430-F2013 may be used as a stand-alone development board. Additionally, the MSP-EZ430D target board may also be detached from the debugging interface and integrated into another design.

The plastic enclosure can be removed to expose the MSP-EZ430U debugging interface and the MSP-EZ430D target board. The MSP-EZ430D target board is disconnected from the debugging interface by gently pulling the two boards apart.

The target board can be used in a stand-alone design by interfacing to the 14-pins of the MSP430F2013. Holes in the MSP-EZ430D target board provide direct access to each pin of the MSP430F2013. Please refer to the MSP430F2013 Data Sheet for descriptions of each pin's function.

The MSP-EZ430U debugging interface may also be used as a standard Flash Emulation Tool for all devices in the MSP430F20xx family of microcontrollers. Target boards using other supported MSP430F20xx devices may be designed and flashed using the MSP-EZ430U debugging interface.

8 Where To Go For More Information

The primary sources of MSP430 information are the device-specific data sheets and user's guides. The most up to date versions of the user's guide documents available at the time of production have been provided on the CD-ROM included with this tool. The most current information is found at www.ti.com/msp430. Information specific to the eZ430-F2013 development tool can be found at www.ti.com/ez430.

MSP430 device user's guides and the FET user's guide may be accessed from the main page on the CD-ROM under the User's Guides section. The FET user's guide includes detailed information on setting up a project for the MSP430 using IAR or CCS.

Documents describing the IAR tools (Workbench/C-SPY, the assembler, the C compiler, the linker, and the librarian) are located in common\doc and 430\doc. The documents are in PDF format. Supplements to the documents (i.e., the latest information) are available in HTML-format within the same directories. 430\doc\readme_start.htm provides a convenient starting point for navigating the IAR documentation.

Documents describing CCS are located in the CCS "documentation" folder. This folder contains the CCS user's guide in PDF format.
9 Frequently Asked Questions

1. What devices can be programmed with the MSP-EZ430U debugging interface?
   MSP430F200x, 'F201x, 'G2x01, 'G2x11, 'G2x21, and 'G2x31

2. Does the eZ430-F2013 support fuse blow?
   The MSP-EZ430U debugging interface lacks the JTAG security fuse blow capability. To ensure firmware security on devices going to production, the USB Flash Emulation Tool or the Gang Programmer, which include the fuse blow feature are recommended.

3. What is the voltage supplied to the MSP-EZ430D target board from the debugging interface?
   The MSP-EZ430U debugging interface supplies a regulated 3.6 V to the MSP-EZ430D target board.

4. Can other programming tools interface to the MSP-EZ430D target board?
   The MSP-EZ430D target board will work with any programming tool supporting the 2-wire Spy Bi-Wire interface. Both the MSP430 USB FET and the Gang Programmer support these devices.

5. What versions of IDEs are supported?
   The eZ430-F2013 is supported by IAR Embedded Workbench 3.40A and IAR Embedded Workbench (Kickstart Version) FET_R449 or higher and CCE v3 or higher.

6. What are the part numbers for the connectors between the MSP-EZ430U emulator and the MSP-EZ430D target board?
   Header: Mill-Max 850-10-004-20-001000 (Digi-Key part number ED8650-ND)
   Socket: Mill-Max 851-93-004-20-001000 (Digi-Key part number ED8850-ND)
   Mill-Max: http://www.mill-max.com

7. Why does can't the debugger get started (IAR Error: Failed to initialize device)?
   First, check in the Device Manager that the COM Port assigned to the eZ430 does not conflict with port already in use. You may disable the conflicting port or assign a new COM port to the device. Check all devices that use a serial port; even devices that do not show up in the Device Manager.
   Second, check if capacitors C6 or C9 are missing on the MSP-EZ430U debugging interface are populated. These capacitors may have been unknowingly removed while opening the enclosure.

8. What is the difference between the 4-pin and 6-pin headers?
   The 4-pin and 6-pin headers are identical from a JTAG perspective. The 6-pin header has two additional pins (pin 1 and pin 6) that can perform UART communication. See the schematics in Section 10 for details.
Figure 2. MSP-eZ430U Schematic (1 of 2)
Figure 3. MSP-eZ430U Schematic (2 of 2)
Figure 4. MSP-EZ430D Schematic
Figure 5. eZ430-F2013 PCB
IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements, and other changes to its products and services at any time and to discontinue any product or service without notice. Customers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All products are sold subject to TI's terms and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI's standard warranty. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by government requirements, testing of all parameters of each product is not necessarily performed.

TI assumes no liability for applications assistance or customer product design. Customers are responsible for their products and applications using TI components. To minimize the risks associated with customer products and applications, customers should provide adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right, copyright, mask work right, or other TI intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information published by TI regarding third-party products or services does not constitute a license from TI to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of TI.

Reproduction of TI information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive business practice. TI is not responsible or liable for such altered documentation. Information of third parties may be subject to additional restrictions.

Resale of TI products or services with statements different from or beyond the parameters stated by TI for that product or service voids all express and any implied warranties for the associated TI product or service and is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.

TI products are neither designed nor intended for use in automotive applications or environments unless the specific TI products are designated by TI as “enhanced plastic.” Only products designated by TI as “enhanced plastic” are suitable for automotive use. Buyers acknowledge and agree that they are solely responsible for all legal and regulatory requirements in connection with such use. TI products are neither designed nor intended for use in environments in which any failure of such products and/or system may reasonably be expected to cause severe personal injury or death, unless officers of the parties have executed an agreement specifically governing such use. Buyers represent that they have all necessary expertise in the safety and regulatory ramifications of their applications, and acknowledge and agree that they are solely responsible for all legal, regulatory and safety-related requirements concerning their products and any use of TI products in such safety-critical applications, notwithstanding any applications-related information or support that may be provided by TI. Further, Buyers must fully indemnify TI and its representatives against any damages arising out of the use of TI products in such safety-critical applications.

TI products are neither designed nor intended for use in military/aerospace applications or environments unless the specific TI products are designated by TI as military-grade or “enhanced plastic.” Only products designated by TI as military-grade meet military specifications. Buyers acknowledge and agree that any such use of TI products which TI has not designated as military-grade is solely at the Buyer's risk, and that they are solely responsible for compliance with all legal and regulatory requirements in connection with such use. TI products are neither designed nor intended for use in environments in which any failure of such products and/or system may reasonably be expected to cause severe personal injury or death, unless officers of the parties have executed an agreement specifically governing such use. Buyers represent that they have all necessary expertise in the safety and regulatory ramifications of their applications, and acknowledge and agree that they are solely responsible for all legal, regulatory and safety-related requirements concerning their products and any use of TI products in such safety-critical applications, notwithstanding any applications-related information or support that may be provided by TI. Further, Buyers must fully indemnify TI and its representatives against any damages arising out of the use of TI products in such safety-critical applications.

TI products are not authorized for use in safety-critical applications (such as life support) where a failure of the TI product would reasonably be expected to cause severe personal injury or death, unless officers of the parties have executed an agreement specifically governing such use. Buyers represent that they have all necessary expertise in the safety and regulatory ramifications of their applications, and acknowledge and agree that they are solely responsible for all legal, regulatory and safety-related requirements concerning their products and any use of TI products in such safety-critical applications, notwithstanding any applications-related information or support that may be provided by TI. Further, Buyers must fully indemnify TI and its representatives against any damages arising out of the use of TI products in such safety-critical applications.

TI products are neither designed nor intended for use in military/aerospace applications or environments unless the specific TI products are designated by TI as military-grade or “enhanced plastic.” Only products designated by TI as military-grade meet military specifications. Buyers acknowledge and agree that any such use of TI products which TI has not designated as military-grade is solely at the Buyer's risk, and that they are solely responsible for compliance with all legal and regulatory requirements in connection with such use. TI products are neither designed nor intended for use in environments in which any failure of such products and/or system may reasonably be expected to cause severe personal injury or death, unless officers of the parties have executed an agreement specifically governing such use. Buyers represent that they have all necessary expertise in the safety and regulatory ramifications of their applications, and acknowledge and agree that they are solely responsible for all legal, regulatory and safety-related requirements concerning their products and any use of TI products in such safety-critical applications, notwithstanding any applications-related information or support that may be provided by TI. Further, Buyers must fully indemnify TI and its representatives against any damages arising out of the use of TI products in such safety-critical applications.

Following are URLs where you can obtain information on other Texas Instruments products and application solutions:

<table>
<thead>
<tr>
<th>Products</th>
<th>Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amplifiers</td>
<td>Audio</td>
</tr>
<tr>
<td>Data Converters</td>
<td>Automotive</td>
</tr>
<tr>
<td>DLP® Products</td>
<td>Communications and Telecom</td>
</tr>
<tr>
<td>DSP</td>
<td>Computers and Peripherals</td>
</tr>
<tr>
<td>Clocks and Timers</td>
<td>Consumer Electronics</td>
</tr>
<tr>
<td>Interface</td>
<td>Energy</td>
</tr>
<tr>
<td>Logic</td>
<td>Industrial</td>
</tr>
<tr>
<td>Power Mgmt</td>
<td>Medical</td>
</tr>
<tr>
<td>Microcontrollers</td>
<td>Security</td>
</tr>
<tr>
<td>RFID</td>
<td>Space, Avionics &amp; Defense</td>
</tr>
<tr>
<td>RF/IF and ZigBee® Solutions</td>
<td>Video and Imaging</td>
</tr>
<tr>
<td></td>
<td>Wireless</td>
</tr>
</tbody>
</table>

Mailing Address: Texas Instruments, Post Office Box 655303, Dallas, Texas 75265
Copyright © 2010, Texas Instruments Incorporated