This user’s guide describes the operation of the Texas Instruments Codec Control software and the AIC3110/AIC3100/AIC3120 EVM. Codec Control provides a graphical user interface for supported TI audio codecs. The software is compatible with Microsoft Windows XP, Vista and Windows™ 7.

The information in a caution or a warning is provided for your protection. Read each caution and warning carefully.

Contents

1 Introduction ................................................................................................................... 2
2 Control Software ........................................................................................................ 2
   2.1 Control Software ............................................................................................... 2
   2.2 Installation ......................................................................................................... 2
   2.3 Concepts ............................................................................................................ 3
   2.4 EVM Window .................................................................................................... 3
   2.5 Dialogs and Active Objects ............................................................................... 4
   2.6 EVM Applications ............................................................................................ 9
   2.7 Firmware Update .............................................................................................. 10
   2.8 Script Syntax ..................................................................................................... 11
3 AIC3110/AIC3100/AIC3120 EVM ........................................................................... 12
   3.1 Overview .......................................................................................................... 12
   3.2 Getting Started .................................................................................................. 12
   3.3 EVM Applications ............................................................................................ 12
   3.4 Jumpers, Connectors, Test ................................................................................ 13
4 EVM Schematics ........................................................................................................ 14

List of Figures

1 EVM Window ............................................................................................................. 3
2 Initialization Script ..................................................................................................... 5
3 Command Dialog ...................................................................................................... 6
4 Register Inspector ...................................................................................................... 7
5 DAC Filter ................................................................................................................ 8
6 Filter Coefficients .................................................................................................... 9
7 EVM Applications .................................................................................................... 10
1 Introduction

The Codec Control software is intended to facilitate evaluation of TI audio codecs. It includes a script interpreter, a block-diagram based graphical user interface, a register inspector and supplemental features (for example digital filter calculator) depending on codec capabilities.

The AIC3110/AIC3100/AIC3120 EVM works together with the Codec Control software. It connects to a PC via USB and enumerates as a USB class audio device. Once configured with the Codec Control software, the EVM acts as a sound card which can play back audio from the PC.

2 Control Software

This chapter explains how to use the Codec Control software together with a TI audio codec EVM.

2.1 Control Software

The Codec Control software exposes most features of a supported TI audio codec EVM through an intuitive graphical user interface.

NOTE: Before Windows on the PC can use the TI audio converter EVM as a sound card, the EVM must be configured (sampling rate, audio routing, internal amplifier settings etc.) with the Codec Control software. This will happen automatically once an EVM is detected by the Codec Control software.

2.2 Installation

Download the Codec Control software (slac366.exe) from the TI audio codec product folder at http://www.ti.com and launch the program (double click on slac366.exe).

This file is a self-extracting archive. The default target folder is:
C:\Program Files\Texas Instruments\CodecControl
Click the Unzip button to complete the installation.

The Codec Control software is now available in the target folder. The name of the executable is CodecControl.exe

To launch the CodecControl software, navigate to the target folder with the Windows Explorer and double click CodecControl.exe.

2.3 Concepts

The CodecControl software presents a block diagram view of a supported TI audio codec EVM.

The block diagram consists of active objects that can react to user input (for example switches or amplifiers with variable gain that show a volume control on a mouse click event).

NOTE: Active Objects – Each active object will change color to red if the mouse cursor is above the object. Clicking the object will trigger its function.

Some active objects are linked to control register(s) of the TI audio codec. The Codec Control software will update the appropriate register(s) whenever an active object is triggered. If a register that is linked to an active object is changed via other components (for example the script interpreter or the register inspector), the active object will change its state accordingly.

The Codec Control software will automatically detect a supported TI audio codec EVM once it is connected to a USB port of the PC.

If no TI audio codec EVM is connected to the PC, the control software also supports an EVM simulation mode, where it is possible to retrieve script commands based on user input within the block diagram.
Simulation mode is only available, if no TI audio codec EVM is attached to the PC. Choose File→New EVM simulation… and select an EVM from the list of supported TI audio codec EVMs.

2.4 EVM Window

At the top of the EVM window is a tool bar with buttons to change between different use cases:

- **Full featured evaluation**
- **Playback only**
- **Record only**
- **Touch Screen Only**

Availability of each use case depends on the TI audio codec EVM – some buttons may be grayed out, indicating that the use case is not available (this does not mean that the use case cannot be implemented for this TI audio codec).

Each use case has its own initialization script, which will run if a use case is selected by clicking on one of the use case buttons. The initialization script contains register settings for the TI audio codec to configure the device for a specific use case.

The toolbar contains a control that determines the zoom factor. Change the zoom by selecting the desired zoom factor.

To move the block diagram, click on a blank area within the block diagram and drag the diagram with the mouse.

At the bottom of the EVM window is a status bar that provides information about the state of the communication between the control software and the TI audio codec EVM. It also shows hints about elements in the block diagram, for example the I2C™ page and register / bit location of a selected switch.
Audio signal paths (both digital and analog) will change color from black once they are activated via switches. This feature visualizes all audio paths and immediately highlights if a path is enabled.

### 2.4.1 Using Active Objects

Moving the mouse pointer over an active object will light up the active object (the color of the object turns red).

For example, the Class-A/B HP Driver left amplifier active object will turn from its inactive state to its active state when the mouse pointer enters the amplifier symbol:

Clicking the activated object will trigger its function. In the case of the amplifier active object, the function is a volume control. Moving the volume control slider changes the volume setting of the amplifier (it is also possible to change the volume by clicking onto the number within the amplifier symbol and typing the new gain setting). The Codec Control software updates the appropriate register in the TI audio codec and as a result the volume on the headphone output will change accordingly.

### 2.5 Dialogs and Active Objects

The Codec Control software contains several dialog windows that give access to additional features. Most dialogs are linked to active objects and are opened by clicking on the active object.

A few dialogs are not linked to active objects and are opened using the View menu.

#### 2.5.1 Init Script Dialog

Each use case owns a unique initialization script which will automatically run when a supported TI audio codec is detected or if the user selects another use case.

To show or edit the initialization script, choose View->Init Script… from the main window menu bar.
2.5.2 Command Dialog

Open the command dialog (View→Command…) to write, edit, load, save and run command scripts. Command scripts are text files that contain commands to communicate with the TI audio codec. The syntax is described in Script Syntax.
Figure 3. Command Dialog

- The main area of the command dialog is the command buffer (editable text) which contains the command script. To run the command script, click the Run button.
- The smaller read only text area on the right side of the command dialog displays control data read from the TI audio codec. The Clear button clears the Read Data field.
- The one line text edit field on the left bottom allows single command execution.
- The Record check box enables recording of commands generated by the control software.

Figure 3 shows a recording of the volume control for the left Class-A/B HP Driver amplifier of a TLV320AIC3111 (note that the Record checkbox is checked).

A single command to read four bytes starting at address 0x28 was executed and the result is displayed in the Read Data field.

2.5.3 Register Inspector

The register inspector dialog (View→Register Inspector…) gives access to all registers of the TI audio codec.
The register inspector displays the content of the TI audio codec registers. To trigger reading the content of one page, click the Refresh button.

- The Page edit field selects the page to be displayed.
- The addr column shows the address of the registers within the selected page in decimal notation.
- The description column contains a description for each register. If the register has no function assigned, it is declared Reserved.
- The data columns show the data of each register (one byte). The first data column uses decimal notation, the second uses hexadecimal notation. It is possible to change the register value by clicking into one of the data fields and typing the new value (either decimal or hexadecimal).
- The numbered columns show the register content in binary notation. Read/Write bits are shown solid black or red; read only bits are gray or dark red. Red numbers represent bits that recently changed. To change a single writeable bit, click on the bit and it will flip.

2.5.4 DAC Filter

This tool is available for TI audio codecs that include digital biquad filters.
This tool displays the combined frequency response, the combined phase response and the individual frequency response of multiple digital biquad filters (depending on the capabilities of the TI audio codec). Solid lines show the frequency response. The dashed line shows the combined phase response. Individual frequency response is enabled by checking the right check box in the Enable column.

Zoom is available by holding Ctrl and drawing a zoom window with the left mouse button or dynamically zooming the gain range with the right mouse button. To cancel zoom, click the right mouse button while not pressing any key.

Each biquad has its own unique handle with a unique color. To change the frequency and gain of a biquad, grab and drag its handle.

Each biquad can be configured for parametric EQ, Shelf (Bass and Treble), High Pass, Low Pass, Phase Shift, Notch.

Some filters (for example High Pass filter) have sub-types that can be selected by the SubType column.

Due to digital range limitations, the biquads will automatically scale, if the biquad coefficients exceed the limitations. The coordinate system will shift accordingly to reflect the resulting attenuation.

Coefficients are automatically sent to the TI audio codec – the filter response can be verified in real-time.

Some filter parameters may lead to unstable filter

**CAUTION**

If the filter becomes unstable, loud noise may occur.
To retrieve the biquad coefficients, click the Coeff button. This will open a window with the biquad coefficients:

![Coefficients Window](image)

Figure 6. Filter Coefficients

The coefficients may be used for a customer’s filter implementation. The format is compatible with the TI audio codec that was detected by the Codec Control software.

### 2.6 EVM Applications

Some TI audio codec EVMs contain an EEPROM that can store EVM applications, for example:

- Initialization scripts
- Parameter patch scripts

The CodecControl software contains a browser to access the applications stored in the EEPROM. To access the browser, select File->EVM Applications…
Applications stored in the EEPROM are listed in a tree view.

To add an application, choose Add Application from the context menu (right mouse click within the tree view).

To change the name of an application, select the application, single click on the application and type the new name.

Each application owns one or several scripts. The scripts consist of a sequence of commands that program the TI audio codec (or EVM components). Examples are initialization scripts.

To add a script to an application, choose Add Script from the context menu. Double click on the script to open a command window. The command window has an open button to choose a script via a file dialog or alternatively it is also possible to write the script within the command window.

Some TI audio codecs have one or more push buttons that select an application or a script within an application. Please refer to the EVM user’s guide for further information about how to select applications and scripts for a specific EVM.

Click Update EVM to program the EEPROM.

Scripts are stored in a compiled binary format on the EEPROM and cannot be read back. A red lock next to the application name highlights scripts that reside in the EEPROM but can not be viewed in the command window.

To change the sequence of scripts or applications, drag a script or application to the new position.

### 2.7 Firmware Update

TI may publish new firmware for TI audio codec EVMs in the future. To program a new firmware to a TI audio codec EVM, choose File→Update Firmware… and select the new firmware file.

The update process takes a few seconds (there is no progress bar) and will be finished once the update firmware dialog disappears.

The EVM must be disconnected and reconnected to complete the firmware update process.
2.8 Script Syntax

A script is a text file that contains data to send to a device.

Each line in a script file is one command. No provision is made for extending lines beyond one line, except for the > command. A line is terminated by a carriage return.

The first character of a line is the command. Commands are:

- r  Read from the serial control bus
- w  Write to the serial control bus
- >  Extend repeated write commands
- #  Comment
- i  Set interface bus to use
- b  Break
- d  Delay
- f  Wait for Flag

Command: r <address> <register> <length>
- <address> is the device address in hexadecimal format. For example 30 for device address 0x30.
- <register> is the register in hexadecimal format that will be read from.
- <length> is the number of bytes that will be read from <register> in auto-increment mode.
  The result will be displayed in the right-side output window of the command interpreter dialog.

Command: w <address> <register> <data ...>
- <address> is the device address in hexadecimal format. For example 30 for device address 0x30.
- <register> is the register in hexadecimal format that will be written to.
- <data...> is a sequence of bytes that will be written to the <register> in auto-increment mode. Each byte is in hexadecimal format.

Command: > <data ...>
This command continues a write sequence in a new line.
- <data...> is a sequence of bytes that will be written in auto-increment mode. Each byte is in hexadecimal format.

Command: # [optional comment]
This command indicates a comment.

Command: i <interface>
- <interface> is i2c for I2C or spi for SPI

Command: b [optional comment]
[optional comment] is a string of characters. The command interpreter will show a modal dialog with the optional comment. Script execution will resume once the dialog is closed.

Command: d <time>
This command suspends script execution by at least <time> milliseconds.

Command: f <address> <register> <mask> [optional timeout]
This command suspends script execution until the value read from <address> <register> matches <mask>
- <address> is the device address in hexadecimal format. For example 30 for device address 0x30.
- <register> is the register in hexadecimal format that will be read from.
- <mask> is a 8-bit binary format mask that is compared with the data from the device. Each bit can be 0, 1 or X.
  For example: <mask> = 010XX01X tests, if the data from the device has D7=0, D6=1, D5=0, D4=don’t care, D3=don’t care, D2=0, D1=1, D0=don’t care.
[optional timeout] specifies how long (milliseconds) the command interpreter will poll the device if the data doesn’t match the <mask>

3 AIC3110/AIC3100/AIC3120 EVM
This chapter contains information about the AIC3110/AIC3100/AIC3120 EVM

3.1 Overview
The AIC3110/AIC3100/AIC3120 evaluation module is an easy to use, small form-factor system that allows access to all features of the AIC3110/AIC3100/AIC3120 via a USB interface and a PC running the CodecControl software.

It consists of:
- AIC3110/AIC3100/AIC3120 codec
- Headphone output
- Class-D speaker terminals
- Microphone input
- Analog volume control
- USB interface
- User interface
  - LEDs
  - Buttons
- Control interface test points
- Digital audio interface test points

3.2 Getting Started
To get started with the AIC3110/AIC3100/AIC3120 EVM:
- Install the CodecControl software (see 2.2).
- Launch the CodecControl software.
- Plug a headphone into J4.
- Connect the EVM to the PC via a mini USB-B to USB-A cable. The CodecControl software will automatically detect the EVM and run an initialization script, which will configure the AIC3110/AIC3100/AIC3120 EVM for audio playback through the headphone jack.
- Play and/or record music with any Windows application (e.g. Windows Media Player, YouTube, iTunes…)

3.3 EVM Applications
The AIC3110/AIC3100/AIC3120 EVM supports multiple EVM applications that can be stored in the on-board EEPROM.

SW2 cycles through applications. LED D1 indicates, which application is active by blinking N times when SW1 selects application #N.

SW3 cycles through patches. LED D2 indicates, which patch is applied by blinking N times when SW2 selects patch #N

The first application (if present) is the boot application – the boot application contains a script that is intended to initialize the AIC3110/AIC3100/AIC3120. It will be skipped by SW1.

The first script of each application contains the application itself. Subsequent scripts of each application other than the boot application are loaded as patches to the application each time SW2 selects a patch.

It is possible to program complex use cases to the EVM and execute them without having to run the CodecControl software.
A simple example is to program the AIC3110/AIC3100/AIC3120 initialization script from the CodecControl software to the boot application. Afterwards, the EVM acts as a USB sound card without requiring the CodecControl software.

3.4 **Jumpers, Connectors, Test**

- **W1**: 1-2: Select analog volume control potentiometer. 2-3: Select microphone detection.
- **W2**: Insert to apply right channel mic-bias voltage to microphone connector.
- **W3**: Insert to apply left channel mic-bias voltage to microphone connector.
- **W4**: AVDD wire loop. Cut and insert ampere meter to measure AVDD current.
- **W5**: SPVDD wire loop. Cut and insert ampere meter to measure SPVDD current.
- **W6**: HPVDD wire loop. Cut and insert ampere meter to measure HPVDD current.
- **W7**: DVDD wire loop. Cut and insert ampere meter to measure DVDD current.
- **W8**: IOVDD wire loop. Cut and insert ampere meter to measure IOVDD current.
- **TP1**: I2C SCL
- **TP2**: I2C SDA
- **TP3**: MCLK for codec
- **TP4**: I2STM™ DIN to codec
- **TP5**: I2S BCLK
- **TP6**: I2S DOUT from codec
- **TP7**: I2S WCLK
- **TP12**: Reset
- **TP13**: GPIO1 from codec
- **TP14**: GND
- **TP15**: TP8, TP9, TP10, TP11, TP12: Not used by AIC3110/AIC3100/AIC3120
- **J1**: Mini USB-B connector
- **J2**: Microphone input
- **J3**: Class-D speaker terminal
- **J4**: Headphone output
- **SW1**: Reset codec
- **SW2**: Select EVM application
- **SW3**: Select patch script
IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESD48, latest issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI’s terms and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI’s terms and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily performed.

TI assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of significant portions of TI information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. TI is not responsible or liable for such altered documentation. Information of third parties may be subject to additional restrictions.

Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice.

Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause harm and take appropriate remedial actions. Buyer will fully indemnify TI and its representatives against any damages arising out of the use of any TI components in safety-critical applications.

In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI’s goal is to help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and requirements. Nonetheless, such components are subject to these terms.

No TI components are authorized for use in FDA Class III (or similar life-critical medical equipment) unless authorized officers of the parties have executed a special agreement specifically governing such use.

Only those TI components which TI has specifically designated as military grade or “enhanced plastic” are designed and intended for use in military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components which have not been so designated is solely at the Buyer’s risk, and that Buyer is solely responsible for compliance with all legal and regulatory requirements in connection with such use.

TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of non-designated products, TI will not be responsible for any failure to meet ISO/TS16949.

### Products
- **Audio**: www.ti.com/audio
- **Amplifiers**: amplifier.ti.com
- **Data Converters**: dataconverter.ti.com
- **DLP® Products**: www.dlp.com
- **DSP**: dsp.ti.com
- **Clocks and Timers**: www.ti.com/clocks
- **Interface**: interface.ti.com
- **Logic**: logic.ti.com
- **Power Mgmt**: power.ti.com
- **Microcontrollers**: microcontroller.ti.com
- **RFID**: www.ti-rfid.com
- **OMAP Applications Processors**: www.ti.com/omap
- **Wireless Connectivity**: www.ti.com/wirelessconnectivity

### Applications
- **Automotive and Transportation**: www.ti.com/automotive
- **Communications and Telecom**: www.ti.com/communications
- **Computers and Peripherals**: www.ti.com/computers
- **Consumer Electronics**: www.ti.com/consumer-apps
- **Energy and Lighting**: www.ti.com/energy
- **Industrial**: www.ti.com/industrial
- **Medical**: www.ti.com/medical
- **Security**: www.ti.com/security
- **Space, Avionics and Defense**: www.ti.com/space-avionics-defense
- **Video and Imaging**: www.ti.com/video

Mailing Address: Texas Instruments, Post Office Box 655303, Dallas, Texas 75265
Copyright © 2016, Texas Instruments Incorporated