Using Position Manager T-Format Library on IDDK Hardware and Software

User's Guide
## Contents

1 Introduction to IDDK ................................................................. 4
2 Hardware Configuration ............................................................ 4
3 Hardware Overview ................................................................. 5
  3.1 Functional Blocks ......................................................... 5
  3.2 Processor Section (Control Processor Slot – H1) ......................... 6
  3.3 Position Encoder Suite .................................................... 7
  3.4 Power Supply ................................................................. 8
4 Hardware Resource Mapping .................................................... 8
  4.1 Digital Signal Mapping .................................................... 8
  4.2 Jumpers and Switches ..................................................... 9
  4.3 Headers and Connectors .................................................. 9
5 Hardware Setup Instructions for PM T-Format Library Evaluation ........ 9
6 Software Setup for PM T-Format Evaluation Example Projects ........... 10
  6.1 Installing Code Composer and controlSUITE ....................... 10
  6.2 Software Flow Diagram .................................................. 10
7 Setup Code Composer Studio to Work With TMDXIDDK379D ............ 11
  7.1 Configuring a Project ..................................................... 13
  7.2 Build and Load the Project ............................................. 14
  7.3 Setup Watch Window and Graphs ..................................... 15
  7.4 Run the Code ............................................................... 15
  7.5 Next Steps ................................................................. 16
8 References .............................................................................. 16
List of Figures

1  IDDK EVM Kit ................................................................................................................ 5
2  Layout of IDDK EVM With its Functional Macros .......................................................... 6
3  Processor Block ............................................................................................................. 6
4  Position Sensor Suite .................................................................................................... 7
5  T-Format/EnDat/BiSS Interface Header ......................................................................... 7
6  Power Supply Block ....................................................................................................... 8
7  Software Flow Diagram for the Example Project PM_tformat_systemtest ....................... 10
8  Configuring a New Target ............................................................................................. 11
9  Adding PM T-Format Example Project to Workspace .................................................... 12
10 Selecting the F2837x_RAM Configuration .................................................................. 13
11 Selecting the CPU(s) to Connect .................................................................................. 14
12 Configuring the Expressions Window .......................................................................... 15

List of Tables

1  Hardware Macros in IDDK Used for PM T-Format Evaluation .......................................... 5
2  Digital Signal Mapping on Control Card H1 .................................................................. 8
3  Purpose of Jumpers and Switches ................................................................................. 9
4  Headers and Connectors ............................................................................................... 9
1 Introduction to IDDK

The DesignDRIVE Kit (IDDK) is a single platform that makes it easy to develop and evaluate design solutions for many industrial drive and servo topologies. The IDDK offers support for a wide variety of motor types, sensing technologies, encoder standards and communications networks, as well as easy expansion to develop with real-time Ethernet communications and functional safety topologies, enabling more comprehensive, integrated system solutions. Based on the real-time control architecture of TI’s C2000™ microcontrollers (MCUs), the kit is ideal for the development of industrial inverter and the servo drives used in robotics, computer numerical control machinery (CNC), elevators, materials conveyance, and other industrial manufacturing applications.

The IDDK offers an integrated drive design with a full-power stage to drive a three-phase motor, easing the evaluation of a diverse range of feedback sensing and control topologies. The kit includes a 180-pin HSEC controlCARD based on the TMS320F28379D C2000 Delfino™ MCU, which integrates dual C28x real-time processing cores and dual CLA real-time co-processors, providing 800 MIPS of floating-point performance with integrated trigonometric and FFT acceleration.

The sophisticated sensing peripherals on the TMS320F28379D MCU, including sigma-delta filter modules with up to eight input channels, four high-performance 16-bit ADCs and eight windowed comparators, enable the IDDK to support shunt, flux gate/HALL, and sigma-delta current sensing simultaneously. For position feedback, the IDDK leverages integrated MCU support for resolver and incremental encoder interfaces. In addition, customers can also explore configuration options that allow the MCU to be placed on either side of the high voltage isolation barrier.

The kit is designed to plug into 110V/220V AC mains, delivers up to 8 Amps, and is rated to drive motors up to one horsepower.

This document covers the kit contents and hardware details, and explains the functions and locations of various connectors present on the board. This document supersedes all the documents available for the kit.

For more details, see the DesignDRIVE Development Kit IDDK Hardware Reference Guide (SPRUI23).

2 Hardware Configuration

To experiment with IDDK for the Position Manager T-Format Library evaluation, the following components are needed:

- An IDDK EVM
- TMDXCNC28379D
- USB-B to A cable
- Encoder/connectors NOT included in the kit – required for evaluation
  - T-FormatEncoder from Heidenhain (for example, TS5700N8501)
  - Cable – length as needed by the application (max 100m)
  - Adapter to connect cable to IDDK

C2000, Delfino, Code Composer Studio are trademarks of Texas Instruments.
All other trademarks are the property of their respective owners.
– An external isolated 15 V power supply needed for MCU code development (preferably with a barrel connector commonly referred to as DC jack). Power supply EMSA150120-P5P-SZ is used for testing.
– PC with Code Composer Studio™ (CCSv6 or greater) installed

• IDDK Hardware Reference Guide located at:
  `controlSUITE\development_kits\TMDSIDDK_v2.0\~Docs\`

• For the schematic details of the IDDK EVM, refer to the schematic file located at:
  `controlSUITE\development_kits\TMDSIDDK_v2.0\IDDK_HwDevPkg\IDDK_HwDevPkg_v2.2.1`

![Figure 1. IDDK EVM Kit](image)

3 Hardware Overview

This section describes the subset of the components required for the Position Manager T-Format Library evaluation only. Complete hardware overview of the kit can be obtained from DesignDRIVE Development Kit IDDK Hardware Reference Guide (SPRUI23) available on controlSUITE.

Evaluation of the Position Manager T-Format Library requires usage of:

• Processor (CPU) block for control
• Position encoder suite
• On-board power supplies

3.1 Functional Blocks

Table 1 illustrates the subset of functional blocks on the DesignDRIVE Development Kit IDDK Hardware, along with the macro names used for the Position Manager T-Format Library evaluation.

<table>
<thead>
<tr>
<th>Functional Block</th>
<th>Macro Reference</th>
<th>Macro Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Supplies</td>
<td>M9</td>
<td>DC Power Supply – Linear Reg 15 V-5 V/3.3 V</td>
</tr>
<tr>
<td>Position Encoder Suite</td>
<td>M12</td>
<td>T-Format Encoder Interface</td>
</tr>
<tr>
<td>Processor/ControlCard</td>
<td>H1</td>
<td>All other functions</td>
</tr>
</tbody>
</table>
Each functional block, and the macros that make them, are presented in brief detail in the following sections. The layout of various macros in the board is given in Figure 2. Schematic details of the individual macros are available at:

```
controlSUITE\development_kits\TMDSIDDK_v2.0\IDDK_HwDevPkg\IDDK_HwDevPkg_v2.2.1
```

**Figure 2. Layout of IDDK EVM With its Functional Macros**

### 3.2 Processor Section (Control Processor Slot – H1)

The IDDK is designed around the main control processor card in slot H1. This is designed to plug in a C2000 Delfino (TMS320F28379D) MCU control card TMDXCNCD28379D designed with a HSEC180-pin edge connector (see Figure 3).

**Figure 3. Processor Block**
3.3 Position Encoder Suite

This block provides a range of position encoder and sensing interfaces (see Figure 4) such as:

- QEP
- Resolver
- Sin-Cos
- T-Format/EnDat/BiSS

![Figure 4. Position Sensor Suite](image)

The PM T-Format Library evaluation uses this interface for T-Format communication.

3.3.1 T-Format Encoder

This is designed as a macro, referred to as M12, which is a common interface for T-Format encoders. H6 is the external interface header and it only interfaces digital signals as shown in Figure 5. GPIO32 is used to control on/off of the 5 V supply details in Table 2.

![Figure 5. T-Format/EnDat/BiSS Interface Header](image)

PM T-Format Library evaluation uses this interface for T-Format communication.
3.4 **Power Supply**

The kit only needs via M9 that has a power supply jack JP1 and a toggle switch SW1. External (15 V) power supply can be fed in through JP1 while SW1 should be turned on to feed the linear regulators of M9. External power supply is preferred to power the controller during code development so that the board operates in low voltage. This ensures a safe environment as there is no high-voltage node present on the board.

![Figure 6. Power Supply Block](image)

4 **Hardware Resource Mapping**

Section 4.1 through Section 4.3 shows hardware resource requirements and signal mapping for the PM T-Format Library evaluation on IDDK.

4.1 **Digital Signal Mapping**

Table 2 shows the functional mapping of signals connected to the control processor on H1 that are relevant to PM T-Format Library evaluation.

<table>
<thead>
<tr>
<th>IDDK Signal Name</th>
<th>MCU GPIO</th>
<th>MCU Peripheral Associated With GPIO</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1-SPIB-CLK</td>
<td>7</td>
<td>PEM CLK</td>
<td>Encoder SPI Clock out</td>
</tr>
<tr>
<td>En-DO</td>
<td>24</td>
<td>SPIB</td>
<td>SPI I/f for Abs Encoder</td>
</tr>
<tr>
<td>En-DI</td>
<td>25</td>
<td>SPIB</td>
<td>SPI I/f for Abs Encoder</td>
</tr>
<tr>
<td>C1-SPIB-CLK</td>
<td>26</td>
<td>SPIB</td>
<td>SPI I/f for Abs Encoder</td>
</tr>
<tr>
<td>C1-SPIB-STE</td>
<td>27</td>
<td>SPIB</td>
<td>SPI I/f for Abs Encoder</td>
</tr>
<tr>
<td>En-PwrEn</td>
<td>32</td>
<td>GPIO output</td>
<td>Power Enable for Abs Encoder</td>
</tr>
<tr>
<td>En-TxEn</td>
<td>34</td>
<td>(GPIO) PEM TX En</td>
<td>Tx Enable for Abs Encoder</td>
</tr>
</tbody>
</table>
4.2 Jumper and Switches

The jumpers shown in Table 3 need to be populated for the PM T-Format Library evaluation.

<table>
<thead>
<tr>
<th>Jumpers and Switches</th>
<th>Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Main] - J6-J8</td>
<td>Populate</td>
<td>Jumper to bring out linear regulator block M9 voltages</td>
</tr>
<tr>
<td>[Main] - J10</td>
<td>Populate</td>
<td>Connects GPIO to T-Format Clock</td>
</tr>
<tr>
<td>[Main] - J12</td>
<td>Don't Populate</td>
<td></td>
</tr>
<tr>
<td>[Main] - J13</td>
<td>Populate</td>
<td>Connect SPISTE to ground</td>
</tr>
<tr>
<td>[Main] - J14-17</td>
<td>Don't populate</td>
<td></td>
</tr>
<tr>
<td>[Main] - J18</td>
<td>Populate (1-2)</td>
<td>Connects Encoder data out (En-Do-1 to the processor)</td>
</tr>
<tr>
<td>[Main] - J19-J21</td>
<td></td>
<td>GND headers for probe access</td>
</tr>
<tr>
<td>[M9] – SW1</td>
<td>Turn ON</td>
<td>Select 15 V supply from JP1 or onboard from M8 to generate 5 V and 3.3 V</td>
</tr>
</tbody>
</table>

4.3 Headers and Connectors

Table 4 shows the headers and connectors available on the board.

<table>
<thead>
<tr>
<th>Headers/Connectors</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[M9] – JP1</td>
<td>15 V DC power supply jack adaptor</td>
</tr>
<tr>
<td>[Main] - H1</td>
<td>180 pin HSEC connector slot for control processor card</td>
</tr>
<tr>
<td>[Main] – H6</td>
<td>4x2 header for T-Format</td>
</tr>
</tbody>
</table>

5 Hardware Setup Instructions for PM T-Format Library Evaluation

1. Ensure default configuration. Make sure that jumpers [Main]-J6, [Main]-J7 and [Main]-J8 (in front of macro M9) and resistors [Main] R8-R13 are populated, and that GND plane resistors R14 and R15 are mounted as shown in the Various GND Planes on the Bottom of Board and Default Connection of Various GND Planes figures of the Power Supplies section in the DesignDRIVE Development Kit IDDK v2.2 - Hardware Reference Guide (SPRUI23).

2. Unpack the TMDXCNCD28379D control card and slide it in the connector slot of [Main]-H1. Push down vertically using even pressure on both ends of the card until it cannot slide down further. Spread open the retaining clips, if present, to remove the card and pull the card out by applying even force at the far edges.

3. Connect a USB cable to connector J1 on the control card. The control card isolates the JTAG signals between the C2000 device and the computer. LED D2 on the control card should light.

4. Connection to the encoder:
   (a) Prepare an adapter to connect the cable to the IDDK T-Format interface ([Main] – H6 4x2 header).
   (b) Typically, the following connections are needed from IDDK to the encoder:
      (i) D+ → Data + signal
      (ii) D- → Data - signal
      (iii) 5 V → Encoder Power Supply
      (iv) GND → Ground
   (c) Cable connections between the Encoder and IDDK. Insert the header created using the Adapter mentioned above in 4a into ([Main] – H6 4x2 header) of IDDK; the other end of the Adapter connects to the Male side of the cable. The Female end of the cable connects to the encoder.

   To make the appropriate connections, see the encoder/cable specifications and schematics IDDK hardware (located in ControlSuite).
5. Ensure that the toggle switch [M9]-SW1 is in “Int” position. Connect an isolated 15 V DC power supply to [M9]-JP1.

6. Turn on the toggle switch [M9]-SW1, then [M9]-LD1 should turn on. Note that more LEDs on the control card should light up indicating that the control card is receiving power from the board.

6 Software Setup for PM T-Format Evaluation Example Projects

6.1 Installing Code Composer and controlSUITE

1. Install Code Composer v6.x or later from http://www.ti.com/tool/CCSTUDIO, if not already installed.


3. T-Format Library is available at:
   `<base>` install director is
   C:\ti\controlSUITE\libs\app_libs\position_manager\vX.X
   The following sub-directory structure is used:
   `<base>`\Doc - Documentation
   `<base>`\Float - Contains implementation of the library and corresponding include file
   `<base>`\examples - Example using T-Format Library

6.2 Software Flow Diagram

The software flow used in the example project `PM_tformat_systemtest` is depicted in Figure 7.

![Software Flow Diagram for the Example Project PM_tformat_systemtest](image)
7 Setup Code Composer Studio to Work With TMDXIDDK379D

1. Open “Code Composer Studio”. Note that this document assumes that version 6 or later is used.

2. Once Code Composer Studio opens, the workspace launcher may appear that would ask to select a workspace location. Note that workspace is a location on the hard drive where all the user settings for the IDE (which projects are open), what configuration is selected, and so forth are saved. This can be anywhere on the disk, the location mentioned below is just for reference. Note that if this is not your first-time running Code Composer the dialog below may not appear).
   - Click the “Browse…” button
   - Create the following path by making new folders as necessary:
     C:\c2000 projects\CCSv6_workspaces\PM_tformat_eval_workspace
   - Uncheck the box that says “Use this as the default and do not ask again”.
   - Click “OK”

3. This will open a ‘Getting Started’ tab with links to various tasks from creating a new project, importing an existing project, to watching a tutorial on CCS. You can click the ‘Import Project’ icon that will skip the procedure to step 2 in Section 7.1. Or, you can close the ‘Getting Started’ Tab and go to next step.

4. Code Composer is configured in order to know which MCU it will be connecting to. This is done by setting up the ‘Target Configuration’. All of these are already set up and configured in “xds100v2_F2837x.ccxml” (provided as part of the files in the project), therefore, the user can skip to step 1 in Section 7.1. However, for general information regarding setting up this configuration file, steps 6, 7 and 8 can be used.

5. A new configuration file can be set by clicking “View → Target Configuration. This will open the Target Configuration window. In this window, click on . Give a name to the new configuration file depending on the target device. If “Use shared location” checkbox is checked, then this configuration file can be stored in a common location by CCS for use by other projects as well. Then, click Finish.

6. This should open up a new tab as shown in Figure 8. Select and enter the following options:
   (a) Connection – Texas Instruments XDS100v2 USB Emulator (or) Texas Instruments XDS100v2 USB Debug Probe
   (b) Device – the C2000 MCU on the control card, TMS320F28379D, for example
   (c) Click Save and close

![Figure 8. Configuring a New Target](image)

7. Click “View → Target Configurations”. In the “User Defined” section, find the file that was created in steps 6 and 7. Right click on this file and select “Set as Default”. To use the configuration file supplied with the project, click “View → Target Configurations, expand “Projects → PM_tformat_systemtest, and right-click on the “xds100v2_F2837x.ccxml” and “Set as Default” files. This tab also allows you to reuse the existing target configurations and links them to specific projects.
8. Add the PM TFormat evaluation example project into the current workspace by clicking “Project → Import CCS Project”.
   (a) Select the project by browsing to:
   
   C:\ti\controlSUITE\libs\app_libs\position_manager\v1_00_00_00\tformat\examples\PM_tformat_systemtest

   ![Image of CCS Eclipse Projects screen](image)

   Figure 9. Adding PM T-Format Example Project to Workspace

   (b) If there are multiple projects in this directory, choose the projects to import and then click Finish. This copies all of the selected projects into the workspace. There is only one project in Figure 9, select it and click Finish.
7.1 Configuring a Project

1. Assuming this is your first time using Code Composer, the xds100v2-F2837x should have been set as the default target configuration. Verify this by viewing the xds100v2-f2837x.ccxml file in the expanded project structure and an [Active/Default] status written next to it. By going to “View → Target Configurations”, you can edit existing target configurations or change the default or active configuration. You can also link a target configuration to a project in the workspace by right clicking on the Target configuration name and selecting Link to Project.

2. The project can be configured to create code and run in either Flash or RAM. You can select either of the two, however, RAM configuration is used most of the time for lab experiments and Flash configuration for production. As shown in Figure 10, right-click on an individual project and select Active Build Configuration → CPU1_RAM configuration.

![Figure 10. Selecting the F2837x_RAM Configuration](image-url)
7.2 Build and Load the Project

1. Open the tformat.h file and make sure that TFORMAT_FREQ_DIVIDER is set as needed; save this file. For more details, see the C2000 Position Manager T-Format Library Module User’s Guide (SPRUI71).

C:\ti\controlSUITE\libs\app_libs\position_manager\v1_00_00_00\tformat\Doc\PM_tformat_Lib.pdf

2. Right click on the Project Name and select “Rebuild Project”, then watch the Console window. Any errors in the project will be displayed in the Console window.

3. On successful completion of the build, click the “Debug” button 🚀 (located in the top-left side of the screen). The following window may pop up if it is the first time that it is used, requesting that you select which of the two CPUs (in F28379x) to connect to (see Figure 11). Select CPU1 by clicking the box next to CPU1.

![Figure 11. Selecting the CPU(s) to Connect](image)

4. The IDE will automatically connect to the target, load the output file into the device, and change to the Debug perspective.

5. Click the Tools → Debugger Options → Program / Memory Load Options. You can enable the debugger to reset the processor each time it reloads the program by checking “Reset the target on program load or restart” and click “Remember My Settings” to make this setting permanent.

6. Click on the “Enable silicon real-time mode” button 🕐, which auto selects the “Enable polite real-time mode” button 🕑. This allows you to edit and view variables in real time. Do not reset the CPU without disabling these real-time options.

7. Select YES to enable debug events, if a message box appears. This will set bit 1 (DGBM bit) of the status register 1 (ST1) to a “0”. The DGBM is the debug enable mask bit. When the DGBM bit is set to “0”, memory and register values can be passed to the host processor for updating the debugger windows.
7.3 Setup Watch Window and Graphs

1. Click View → Expressions on the menu bar to open a watch window to view the variables being used in the project. Add variables to the watch window as shown in Figure 12. It uses the number format associated with variables during declaration. You can select a desired number format for the variable by right clicking on it and choosing. Figure 12 shows a typical expressions window.

![Figure 12. Configuring the Expressions Window](image)

Alternately, a group of variables can be imported into the Expressions window, by right clicking in the Expressions Window and clicking Import, then, browse to the .txt file containing these variables. Browse to the root directory of the project and pick ‘PM_tformat_systemtest_VAR.txt’ and click OK to import the variables shown in Figure 12.

2. Click on the Continuous Refresh button in the watch window. This enables the window to run with real-time mode. By clicking the down arrow in this watch window, you can select “Customize Continuous Refresh Interval” and edit the refresh rate of the watch window. Note that choosing too fast an interval may affect performance.

7.4 Run the Code

1. Run the code by pressing the Run Button in the Debug Tab.

2. The project should run and the values in the watch window should continuously update. Below are screen captures of typical CCS perspectives while using this project. You may want to resize the windows according to your preference.

3. Once complete, reset the processor (Run → Reset → CPU Reset) and terminate the debug session by clicking (Run → Terminate). This halts the program and disconnects Code Composer from the MCU.

4. As the encoder sends the position information, observe the same in the watch window, turns variables.

5. If the encoder is not mounted on a spinning Motor, you can manually rotate the encoder shaft and observe the position changing in the watch window.
7.5 Next Steps

It is not necessary to terminate the debug session each time you change or run the code. Instead, the following procedure can be followed:

1. After rebuilding the project, (Run → Reset → CPU Reset), (Run → Restart), and enable real-time options. Once complete, disable real-time options and reset the CPU. Terminate the project if the target device or the configuration is changed (Ram to Flash or Flash to Ram) and prior to shutting down CCS.

2. Customize the project to meet your encoder and application requirements. Change the encoder type in the encoder.h file.

3. Modify the example code as needed and perform tests with different cable lengths.

8 References

- DesignDRIVE Development Kit IDDK Hardware Reference Guide (SPRUI23)
IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESD48, latest issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI’s terms and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI’s terms and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily performed.

TI assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of significant portions of TI information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. TI is not responsible or liable for such altered documentation. Information of third parties may be subject to additional restrictions.

Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.

Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause harm and take appropriate remedial actions. Buyer will fully indemnify TI and its representatives against any damages arising out of the use of any TI components in safety-critical applications.

In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI’s goal is to help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and requirements. Nonetheless, such components are subject to these terms.

No TI components are authorized for use in FDA Class III (or similar life-critical medical equipment) unless authorized officers of the parties have executed a special agreement specifically governing such use. Only those TI components which TI has specifically designated as military grade or “enhanced plastic” are designed and intended for use in military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components which have not been so designated is solely at the Buyer’s risk, and that Buyer is solely responsible for compliance with all legal and regulatory requirements in connection with such use.

TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of non-designated products, TI will not be responsible for any failure to meet ISO/TS16949.

<table>
<thead>
<tr>
<th>Products</th>
<th>Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio</td>
<td><a href="http://www.ti.com/audio">www.ti.com/audio</a></td>
</tr>
<tr>
<td>Amplifiers</td>
<td>amplifier.ti.com</td>
</tr>
<tr>
<td>DSP</td>
<td>dsp.ti.com</td>
</tr>
<tr>
<td>Interface</td>
<td>interface.ti.com</td>
</tr>
<tr>
<td>Logic</td>
<td>logic.ti.com</td>
</tr>
<tr>
<td>Power Mgmt</td>
<td>power.ti.com</td>
</tr>
<tr>
<td>Microcontrollers</td>
<td>microcontroller.ti.com</td>
</tr>
<tr>
<td>RFID</td>
<td><a href="http://www.ti-rfid.com">www.ti-rfid.com</a></td>
</tr>
<tr>
<td>OMAP Applications Processors</td>
<td><a href="http://www.ti.com">www.ti.com</a> omap</td>
</tr>
<tr>
<td>Wireless Connectivity</td>
<td><a href="http://www.ti.com/wirelessconnectivity">www.ti.com/wirelessconnectivity</a></td>
</tr>
</tbody>
</table>

Mailing Address: Texas Instruments, Post Office Box 655303, Dallas, Texas 75265
Copyright © 2016, Texas Instruments Incorporated