Texas Instruments
Productivity Solutions Home PageTI Map/SearchFeedbackTI Home
Avigo HomeProduct InformationAvigo On The WebInternational InformationGetting the Most from AvigoAvigo Support

 

 

Previous FAQ Question 17 Next FAQ

How do I troubleshoot the serial communications process?

To begin with, follow the given steps exactly. Do not deviate from them, as each is necessary.

  1. Remove Avigo from the docking station.
  2. Put Avigo into the docking station, making sure it is seated firmly and that the bottom is flush against the cradle.
  3. Turn Avigo ON.
  4. Tap the apps. icon. Avigo should display boxes that contain icons such as Memory, Security, Setup, Sketch, etc. If it does not, you are probably in an edit mode. Tap any checks for open keyboards and open entries. Tap apps. again, and you should be at the proper screen. You cannot link to Avigo while in an edit entry mode.
  5. Tap the Sync icon. Tap the option for Serial - com port. The button "Synchronize Now" should be listed.
  6. Tap the apps. icon.
  7. On the PC, execute the Avigo Manager software. (Note: Start this software even though you may have initially received the error through Intellisync)
  8. In Avigo Manager, select File/Port Setup....
  9. In Port Setup..., Click on the "Avigo" driver option. (You cannot make a serial connection using "Other") Take note of what Port Number is currently selected. Click OK.
  10. In Avigo Manager, Click Edit/Applications. Avigo Manager should now begin to communicate with the handheld. If Avigo Manager has managed to establish communication with the handheld, Avigo's display will change from the apps. screen to the Sync screen. If no errors are listed, the transmission was successful. Your problem was resolved in one of the earlier steps. (If you originally received a serial communications error in Intellisync, restart Intellisync, select Options/Settings, verify that you have the same COM port selected here as in Avigo Manager, and resync. You should not receive a serial communications type error.)
  11. If a problem still exists, the error "The connection failed. Please check that you have selected the proper option on the synchronize screen and are not in the middle of entering data." will be displayed. Check and note whether an error message appears on the handheld. Remove Avigo from the cradle. Put Avigo back into cradle. Push down on the top of Avigo to verify that it is actually sitting completely on the cradle pins.
  12. Repeat Step 9.

If a problem still exists, you will need to check some additional information on your system.

If you have Windows 95:

  1. Minimize the Avigo Manager software.
  2. In Windows 95, select Start/Settings/Control Panel/Modems/Diagnostics
  3. Take note of what is Installed for the COM port that was listed in Avigo Manager. It should say "No Modem Installed". If not, that port cannot be used since a modem or serial mouse is already accessing it. Check to see whether a port is listed with "No Modem Installed". If none are available, you may be unable to link with Avigo at this time. For more information on modem related serial communication issues see the FAQ entry on "Serial Port communications and your Modem". If the port does say "No Modem Installed", you may have the docking station plugged into the wrong serial port, the serial port could be defective, or something else in the process could be wrong. If available, try plugging the docking station into the 2nd serial port. For tips on determining whether a serial port may be defective see the FAQ entry on "Checking for a defective serial port". For advanced troubleshooting options, see the FAQ entry on "Advanced troubleshooting options".

If you have Windows NT 4.0:

  1. Minimize the Avigo Manager software.
  2. In Windows NT 4.0, select Start/Settings/Control Panel/Modems
  3. Take note of whether the modem is attached to the same COM port that is selected in Avigo Manager. If so, you may be unable to link with Avigo at this time. For more information on modem related serial communication issues see the FAQ entry on "Serial Port communications and your Modem". If your port is not listed, you may have the docking station plugged into the wrong serial port, the serial port could be defective, or something else in the process could be wrong. If available, try plugging the docking station into the 2nd serial port. For tips on determining whether a serial port may be defective see the FAQ entry on "Checking for a defective serial port". For advanced troubleshooting options, see the FAQ entry on "Advanced troubleshooting options".

 

   

     Contacting TI

     Avigo Manuals

     Avigo FAQ Index

Collapsed OutlineSoftware Updates

Collapsed OutlineAvigo Developers Corner

Productivity Solutions Home PageTI Map/SearchFeedbackTI Home
(c) Copyright 1998 Texas Instruments Incorporated. All rights reserved.
Trademarks