
Demonstrating 
DDR-less EtherCAT® Slave on AMIC110 

 
User’s Guide: 

http://processors.wiki.ti.com/index.php/PRU_ICSS_EtherCAT  
 

TI Reference Design: 
http://www.ti.com/tool/TIDEP-0105  

Presenter
Presentation Notes
Hello everyone, the PRU-ICSS (Programmable-Realtime Unit Industrial Communications Sub-System) EtherCAT® package is designed for the Sitara™ processor family to enable customers to add EtherCAT slave protocol support to their system. This video will demonstrate how to test the reference design for DDR-less EtherCAT® Slave on the AMIC110 development platform.

http://processors.wiki.ti.com/index.php/PRU_ICSS_EtherCAT
http://www.ti.com/tool/TIDEP-0105


Presenter
Presentation Notes
EtherCAT® (Ethernet for Control Automation Technology) continuously grows to establish itself as a dominant, industrial, Ethernet network. The DDR-less EtherCAT reference design serves as a reference for a completely new and low-cost, DDR-less, EtherCAT slave implementation on the AMIC110, a multiprotocol industrial communications system on a chip. This reference design showcases the ability to run a full EtherCAT slave stack entirely on the internal memory of the SoC. Significant system bill of materials (BOM) and board savings are achieved with this reference design by eliminating an external ASIC and DDR. Additionally, applications such as connected industrial drives and communications modules can significantly benefit from the faster speeds that are achieved by eliminating external memory transfers for EtherCAT.

http://www.ti.com/tool/TIDEP-0105
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Presenter
Presentation Notes
Three major software components, the physical layer, data link layer, and application layer, comprise the EtherCAT slave implementation on the AMIC110 device, similar to other Sitara processors from TI.The first component is the physical layer, PHY, which provides all physical layer functions needed to transmit and receive data over standard twisted-pair cables.In EtherCAT layer 2, the data link, the PRU real-time cores execute the tasks of datagram processing, distributed clocking, address mapping, error detection and handling, and host interface. PRUs also emulate the EtherCAT register space in the internal shared memory. With their deterministic real-time processing capability, the PRUs handle EtherCAT datagrams with consistent and predictable processing latency.The third component is the EtherCAT slave stack, which runs on the Arm® processor and an industrial application that is dependent on the end equipment in which this solution is used. For the application layer connection, different process data interfaces (PDI) are available. Typical interface options vary from 32-bit to 8- or 16-bit parallel I/O interfaces or serial interfaces like SPI.
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Presenter
Presentation Notes
Now let’s proceed to the demonstration.First, we will set up the AMIC110 ICE Development PlatformNext, we will install the required software and tools.Then, we will generate EtherCAT project files and build the full feature EtherCAT slave application.After the application is successfully built, we will flash the binaries to the AMIC110 ICE board and run the EtherCAT slave application.Finally,  we will verify the application functionality with TwinCAT 3 EtherCAT master. 

http://processors.wiki.ti.com/index.php/pru_icss_ethercat
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Presenter
Presentation Notes
Let’s begin with the hardware setup.



Set Up Hardware 

5V 
XDS200 to PC 

Ethernet to PC 

Presenter
Presentation Notes
To set up the hardware, first connect an Ethernet cable from the J6 port on the AMIC110 ICE board to an Ethernet port on the host PC. Next, attach the XDS200 debug probe to the JTAG connection on the board and connect the other end to the host PC via USB. Finally, connect a 5V power supply to the board.



Software setup 
• Code Composer Studio (CCS): http://processors.wiki.ti.com/index.php/Download_CCS 

– Version  8.0.0.00016 

• Processor SDK RTOS for AM335x: http://www.ti.com/tool/PROCESSOR-SDK-AM335X 
– Version 5.0 

• PRU-ICSS EtherCAT Slave software: http://www.ti.com/tool/PRU-ICSS-INDUSTRIAL-SW  
– Verson 1.00.06  

• EtherCAT Slave Stack Code (SSC): https://www.ethercat.org/  
– Version 5.12 

• TwinCAT 3: https://www.beckhoff.com/english.asp?download/tc3-downloads.htm 
– Version 3.1 

• Windows Patch Utility: https://sourceforge.net/projects/gnuwin32/files/patch/2.5.9-7/  

• Text file format converter: https://sourceforge.net/projects/dos2unix/ 

Presenter
Presentation Notes
Please note that the software version numbers will change over time. At the time of filming the version numbers listed on the screen were used.

http://processors.wiki.ti.com/index.php/Download_CCS
http://www.ti.com/tool/PROCESSOR-SDK-AM335X
http://www.ti.com/tool/PRU-ICSS-INDUSTRIAL-SW
https://www.ethercat.org/
https://www.beckhoff.com/english.asp?download/tc3-downloads.htm
https://sourceforge.net/projects/gnuwin32/files/patch/2.5.9-7/
https://sourceforge.net/projects/dos2unix/
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Presenter
Presentation Notes
Next, let’s take a look at the software required to run the demonstration.



Install CCS 

http://processors.wiki.ti.com/index.php/Download_CCS 

Presenter
Presentation Notes
It is recommended to install all of the TI software in its default location, C:\ti. Please note that if you choose to install in a custom directory some modification of scripts will be required in later steps.

http://processors.wiki.ti.com/index.php/Download_CCS


Install CCS 

http://processors.wiki.ti.com/index.php/Download_CCS 

Presenter
Presentation Notes
If you have not already done so, please first install Code Composer Studio. Make sure that Sitara AMx Processors and TI XDS Debug Probe Support boxes are checked during installation. 

http://processors.wiki.ti.com/index.php/Download_CCS


Install Processor SDK 

http://www.ti.com/tool/PROCESSOR-SDK-AM335X 

Presenter
Presentation Notes
Next, install Processor SDK RTOS for AM335x and PRU-ICSS EtherCAT Slave software in the same directory as CCS. 

http://www.ti.com/tool/PROCESSOR-SDK-AM335X


Install Processor SDK 

http://processors.wiki.ti.com/index.php/PRU_ICSS_EtherCAT  

Presenter
Presentation Notes
Next, install Processor SDK RTOS for AM335x and PRU-ICSS EtherCAT Slave software in the same directory as CCS. 

http://processors.wiki.ti.com/index.php/PRU_ICSS_EtherCAT
http://processors.wiki.ti.com/index.php/PRU_ICSS_EtherCAT


Install PRU-ICSS EtherCAT slave   

http://www.ti.com/tool/PRU-ICSS-INDUSTRIAL-SW 

Presenter
Presentation Notes
The final piece of TI software is the PRU-ICSS EtherCAT Slave software. Install it in the same directory as CCS. 

http://www.ti.com/tool/PRU-ICSS-INDUSTRIAL-SW


Install EtherCAT slave stack code 

https://www.ethercat.org/ 

Presenter
Presentation Notes
After the TI software is installed, you will need to install the EtherCAT slave stack code. Please note that the slave stack code is required in order to build the full feature application. If you do not have access to the slave stack code at this time, you will still be able to use the demo application.

https://www.ethercat.org/


Install Beckhoff TwinCAT 3 

https://www.beckhoff.com/english.asp?download/tc3-downloads.htm 

Presenter
Presentation Notes
Next, you need to install the TwinCAT 3 software. Select the complete installation.

https://www.beckhoff.com/english.asp?download/tc3-downloads.htm


Install patch utilities: GnuWin and dos2unix 

https://sourceforge.net/projects/gnuwin32/files/patch/2.5.9-7/  
 https://sourceforge.net/projects/dos2unix/  

 

Presenter
Presentation Notes
Finally, you will need to install the Windows Patch Utility and a text file format converter in order to apply patches in later steps.

https://sourceforge.net/projects/gnuwin32/files/patch/2.5.9-7/
https://sourceforge.net/projects/gnuwin32/files/patch/2.5.9-7/
https://sourceforge.net/projects/gnuwin32/files/patch/2.5.9-7/
https://sourceforge.net/projects/dos2unix/
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Presenter
Presentation Notes
Next we will walk through the necessary steps to generate and build the EtherCAT slave application.



Generate and build application 
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Presenter
Presentation Notes
Next we will walk through the necessary steps to generate and build the EtherCAT slave application.



Generate and build application 
• Video Capture 

1. Generating the EtherCAT source files 
• Option 1: Generating EtherCAT sources using patch file 
• Option 2: Generating EtherCAT sources using Beckoff SSC Tool 

2. Copy source files 
3. CCS Product discovery 
4. Modify projectCreate.bat file 
5. Run projectCreate.bat AM335x arm ethercat_slave_full 
6. Apply thumb mode patch 
7. Rebuild the PDK to generate thumb mode LLD libraries 
8. Open CCS and import the project 
9. Set to release build configuration and build 

 
 

 

Presenter
Presentation Notes
To build the full feature EtherCAT slave application we must first generate patched versions of the EtherCAT source files for Sitara processors. These files can be generated via two different methods:Generating EtherCAT sources using patch file (http://processors.wiki.ti.com/index.php/PRU_ICSS_EtherCAT#Generating_EtherCAT_sources_using_the_Patch_file_.28Option_.231.29)Generating EtherCAT sources using Beckoff SSC Tool (http://processors.wiki.ti.com/index.php/PRU_ICSS_EtherCAT#Generating_EtherCAT_sources_using_Beckhoff_SSC_Tool_.28Option_.232.29)Please note that you should use only one of these methods. I.E. do not generate the sources using the SSC tool and then apply the patch on top of those files.Option 1: Generating EtherCAT sources using patch fileLaunch the Windows Command Prompt (start->run->cmd) and CD to [INSTALL-DIR]\third_party\protocols\ethercat_slave\patch directory which contains the patch file, TI_ECAT.patchConvert the patch file to DOS format by running the [Dos2Unix/Unix2Dos-DIR]\bin\unix2dos.exe TI_ECAT.patch command.Next, CD to the directory containing the windows patch utility and execute the patch.exe -i [INSTALL-DIR]\third_party\protocols\ethercat_slave\patch\TI_ECAT.patch -d c:\SSC_V5i12\SlaveFiles\src command.Option 2: Generating EtherCAT sources using Beckoff SSC ToolAlternatively, you can generate source files using the SSC tool.First, navigate to the directory where you have installed the slave stack code and run EtherCAT Slave Stack Code Tool.exe to install the SSC Tool.Open the SSC tool and click the import button. Browse for the TI_AM335x_1i0i6i0.xml file located at [INSTALL-DIR]/third_party/protocols/ethercat_slave/patchSelect custom in the dialog box and select TI [AM335x] Sample <Texas Instruments Incorporated> from the listSelect EtherCAT Slave -> Synchronization from the Slave Project Navigation sidebar and make sure that DC_SUPPORTED is set to 1Save the project to a local directory.Click Project -> Create new slave files to generate the EtherCAT source files for the selected TI device. They will be saved to the same location as the project.After completing option 1 or option 2 copy the source files (.c and .h) to the [INSTALL-DIR]/protocols/ethercat_slave/ecat_appl/EcatStack directory.Now that we have the EtherCAT stack code, we can move on to generating the application.Before running the projectCreate script, we must install the Processor SDK products into CCS. To do this, simply open CCS and it should automatically discover the new products. You can confirm their installation by going to Window -> Preferences -> Code Composer Studio -> Products. If products were not automatically discovered you can click Rediscover to find them. After confirming that the products are installed, close CCS.After closing out of CCS, open the file [INSTALL-DIR]/protocols/<protocol name>/projects/projectCreate.bat file and edit the CCS_INSTALL_DIR, CCS_WORKSPACE_LOC, IA_SDK_HOME, PDK_INSTALL_PATH, PROJECT_CREATE_DIR, and PROJECT_CREATE_OPTIONS_FILE_DIR variables to align with your environment. Note that if you chose to install TI software in the default C:\ti location there will be very little modification necessary. After modifying the script, CD to the [INSTALL-DIR]/protocols/<protocol name>/projects directory and run the projectCreate.bat AMIC11x arm ethercat_slave_full command. The ethercat_slave_full project will be generated in the [INSTALL-DIR]/protocols/<protocol name>/projects/ directory.Now that the project has been created, we need to import and build in CCS.Before building, we must first patch the Processor SDK for Thumb mode binaries. A patch file is included at [INSTALL-DIR]/protocols/pdk_patches/04.03.00/AM335x_PDK_thumb_mode.patch. Apply this patch to the rules_a8.mk file.After the PDK patch is applied, the PDK needs to be cleaned and rebuilt to generate the thumb mode LLD libraries. To rebuild PDK, refer to the link show. http://processors.wiki.ti.com/index.php/Rebuilding_The_PDK. After applying the thumb mode patch and rebuilding the PDK, launch CCS and import the project from the [INSTALL-DIR]/protocols/<protocol name>/projects/ directory via the Project -> Import CCS Projects menu.Right click on the ethercat_slave_full_AMIC11x_arm project and select Build Configurations -> set active -> AMIC11x_release configuration. The release build configuration is configured by defualt to compile in on-chip, or DDR-less, execution mode.Build the project.



Load and run application 
 

 

 

 

 

Set up 
hardware 

Install 
required 
software 

Generate and 
build application 

Load and run 
application 

Validate  
application 

results 

Presenter
Presentation Notes
Now that we have built our application, it’s time to flash it to the board and run.



Load and run application 
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Presenter
Presentation Notes
During normal operation, users are required to flash SBL in 0x0 and App at 0x20000. In DDRless mode, the SBL has to load additional binaries to PRU0 IRAM and PRU1 IRAM and store the TIESC EEEPROM. The flash memory map pictured on screen is set to flash the application binaries.The load location for binaries loaded by the bootloader is configured by providing the location in the TI IMAGE header appended to these binaries. The prebuilt ti image binaries for ecat_frame_handler and ecat_host_interface can be found at [INSTALL-DIR]/protocols/ethercat_slave/firmware/v1.0/. Binaries with and without the TI IMAGE header are provided. Binaries that contain the TI IMAGE header have a _ti suffix. An example pair is ecat_frame_handler.bin and ecat_frame_handler_ti.bin. Be sure to use the _ti versions of these binaries. 
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Presenter
Presentation Notes
A pre-built binary of tiesc_eeprom can be found at path [INSTALL-DIR]/protocols/ethercat_slave/ecat_appl/iceAM335x/Alternatively, you can use the Beckhoff SSC tool to generate the eeprom binary.



• Video 
1. Create the eeprom binary 
2. Create target configuration 
3. Launch target config and connect to A8 core 
4. Load the spi flash writer 

• Go through flashing the 5 binaries 
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Load and run application 

Presenter
Presentation Notes
The eeprom binary can be generated from an ESI file using the SSC tool. To do this, first open the SSC tool.Go to Tools -> EEPROM programmer In EEPROM programmer go to File -> Open and select the [IA_SDK_HOME]\protocols\ethercat_slave\ecat_appl\esi\TI_ESC.xml ESI fileIn the device description drop down menu select TIESC-001Finally, click File -> Save as and save the file as tiesc_eeprom.bin To configure the location of the eeprom binary in device memory you can use the tiimage.exe tool which is provided at [pdk_install_path]\packages\ti\starterware\tools\ti_image. To use this tool provide the device memory location and the binary you would like to append the TI IMAGE to. To configure tiesc_eeprom.bin type tiimage.exe 0x4030F400 NONE tiesc_eeprom.bin tiesc_eeprom_ti.bin.Binaries are programmed to the SPI flash using the flash writer tool at <PDK_INSTALL_DIR\packages\ti\starterware\tools\flash_writer\spi_flash_writer_AM335X.out. To run the flash writer program we must first create a target configuration for the AMIC110. Create the target configuration in CCS via File -> New -> Target Configuration File. Select Texas Instruments XDS2xx USB Debug Probe as the connection and ICE_AMIC110  as the board. Save the target configuration and the click test connection. You should receive a message, The JTAG DR Integrity scan-test has succeeded.Now, right click on your target configuration file and select Launch Selected Configuration. The CCS Debug perspective will open.Right click on the CortexA8 core and select Connect Target. Go to Run -> Load -> Load Program  and browse for the spi flash writer executable. Once the executable is loaded, click the Resume (F8) button.The flash writer program will print options to the CCS console window. Choose option 1 to flash an image to the board. You will be prompted to enter the full path to the image and provide a memory offset.The first image is the bootloader which can be found at [pdk_install_dir]\packages\ti\starterware\binary\bootloader\bin\amic110-ddrless\gcc\bootloader_boot_mcspi_noDDR_a8host_release_ti.bin. It has an offset of 0.After receiving a Verify…Success message from the flash writer program. Click the restart button in CCS to go on to the next binary.The next image to flash is the tiesc_eeprom_ti.bin with an offset of 10000.Next we will flash ecat_host_interface_ti.bin to offset 14000 and ecat_fram_handler_ti.bin to offset 19000. These binaries can be found at [INSTALL-DIR]/protocols/ethercat_slave/firmware/v1.0/Finally, we will flash the application, or app, to location 20000. The app file is located in the AMIC11x_release directory of your ethercat_slave_full project.After flashing all of the binaries, click the terminate button to disconnect from the AMIC110.
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Now, press the reset button on the AMIC110. You should see the pictured LEDs turn on.



Validate application results 
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Presentation Notes
Now that the application is running, we can verify its functionality using the TwinCAT 3 program.



Validate application results 
Video: 
• Copying ESI files to TwinCAT 
• Creating a TwinCAT project 
• Installing Ethernet Drivers 
• Scanning for devices 
• Checking device state 
• Changing LED status 

Presenter
Presentation Notes
Before opening TwinCAT, we need to copy over the ESI file for our application. The ESI file for the EtherCAT slave full application is [INSTALL-DIR]/protocols/ethercat_slave/ecat_appl/esi/TI_ESC.xml.This file needs to be copied to the <Drive>:\TwinCAT\3.1\Config\Io\EtherCAT folder.After copying over the ESI file, open the TwinCAT XAE (VS 2013) application and create a new TwinCAT XAE project via the File > New > Project > TwinCAT Project menu.Next, go to TwinCAT > Show Real Time Ethernet Compatible Devices and install your Ethernet adapter. It should now show up under “installed and ready to use devices”Make sure that an Ethernet cable is connected from the J6 port on the AMIC110 to the Ethernet port on you PC before proceeding to the next step.In the solution explorer on the left go to your TwinCAT project -> I\O -> right click on Devices -> ScanA TwinCAT device should be detected. Check the box next to it and click OK.Click yes on the scan for boxes pop upThe TI Box should automatically be detected Click yes on the pop-up to activate free runGo to TwinCAT project -> I\O -> Devices -> Device 2 (EtherCAT) -> Box 1 (TIESC-001) and select the Online tab. The device state should be OP.Next click on DO Outputs -> LED -> Led[n] to select an LED. Click on the Online tab and then click Write… to set a new LED valueChange the LED from 0 to 1 and click OK. You should see the LED change on the AMIC110.



For more information 
• DDR-less EtherCAT Slave on AMIC110 Reference Design: 

http://www.ti.com/tool/TIDEP-0105  

• AMIC11x Device Product Overview: 
http://www.ti.com/processors/sitara/industrial-ethernet/amic11x/overview.html  

• EVM Tool Folder: http://www.ti.com/tool/tmdxice110   

• Processor SDK RTOS for AM335x: http://www.ti.com/tool/PROCESSOR-SDK-AM335X  

• PRU-ICSS EtherCAT Slave software: http://www.ti.com/tool/PRU-ICSS-INDUSTRIAL-SW  

• EtherCAT User Guide: http://processors.wiki.ti.com/index.php/PRU_ICSS_EtherCAT  

• For questions about this training, refer to the E2E Community Forums for Sitara at 
http://e2e.ti.com/support/arm/sitara_arm/ 

Presenter
Presentation Notes
This concludes the demonstration for DDR-less EtherCAT® Slave on AMIC110�For more information, refer to the links shown.Thank you for taking the time to watch this demonstration. If you have any questions, please post them on the Texas Instruments E2E forum at e2e.ti.com

http://www.ti.com/tool/TIDEP-0105
http://www.ti.com/processors/sitara/industrial-ethernet/amic11x/overview.html
http://www.ti.com/tool/tmdxice110
http://www.ti.com/tool/PROCESSOR-SDK-AM335X
http://www.ti.com/tool/PRU-ICSS-INDUSTRIAL-SW
http://processors.wiki.ti.com/index.php/PRU_ICSS_EtherCAT
http://e2e.ti.com/support/arm/sitara_arm/
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