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概要 

MSP430F5xxおよびMSP430F6xxデバイスには、ブートストラップ・ローダー(BSL)をフラッシュ・メモリ内の保護された場所
に配置することができます。出荷されるすべてのデバイスには標準的なTI BSLが搭載されていますが、このBSLを消去して、カ
スタムメイドのBSLを同じ場所にプログラミングすることが可能です。これにより、カスタム通信インターフェイスの使用、ス
タートアップ(起動)・シーケンス等の可能性が生まれます。このドキュメントの目標は、BSLのメモリの基本について説明する
とともに、TIの標準的なBSLソフトウェアについても説明し、各顧客に合ったカスタム・プロジェクトで利用できるようにする
ことです。 

このアプリケーション・レポートには、MSP430G2xデバイスで使用できる小サイズのデモ用BSLも記載されています。エント
リ・シーケンスによりコードの更新が開始され、新しいユーザー・コードを送信してフラッシュに保存できるようになります。

ステータスの通知用として、1バイトのフィードバックが提供されます。エントリ・シーケンス、データ、フィードバック用と
してはTA0ベースのUART通信が使用されます。 

このアプリケーション・レポートで説明されている、付随するプロジェクト(資料)およびソース・コードは、 次のURLからダウ
ンロードできます。http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/CustomBSL/latest/index_FDS.html. 
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2 カスタム・フラッシュベース・ブートストラップ・ローダー (BSL)の作成 
 

1 5xxおよび 6xxブートストラップ・ローダーのカスタマイズ 

1.1 BSLメモリのレイアウト 
BSLメモリは、フラッシュの2キロバイト・セクションです。このフラッシュの具体的な位置は、各デバイス個別のデータ・シー
トに記載されています。ただし、通常はアドレス0x1000～0x17FF間に存在します。このメモリの各種セクションも保護するこ
とが可能です。(MSP430F5xx and MSP430x6xx Family User’s Guide (SLAU208)で説明されているように)この保護は、SYSBSLC
レジスタにフラグをセットすることでイネーブルになります。 
 

1.1.1 Z領域 

BSLメモリが保護されている場合は、BSLメモリを読み出したり、BSLメモリ外の場所からBSLメモリ内にジャンプしたりする
ことはできません。これは、BSLを消去からより完全に保護するため、および誤ったBSLの実行を防ぐためです。ただしBSLメ
モリ空間全体を上記のように保護すれば、意図的にBSLを起動したり、特定のパブリックBSL関数を使用する等のどのような方
法を用いても、ユーザーのアプリケーション・コードがBSLを呼び出すことはできなくなります。 
 
Z領域は、制御された方法を使用して、保護されたBSLに公的にアクセスできるようにするために設計された特殊なメモリ・セ
クションです。Z領域はアドレス0x1000～0x100F間に存在するBSLメモリの1セクションであり、外部アプリケーション・コー
ドからこのセクションにジャンプしたり、このセクションを読み出したりすることが可能です。Z領域は、BSLメモリ内の任意
の位置へのジャンプを実行することが可能なゲートウェイとして機能します。デフォルトのTI BSLでは、BSLの先頭へのジャン
プおよびBSLのパブリック関数へのジャンプ用にこの領域を使用します。 
 

1.1.2 BSL用に予約されたメモリ位置 

次に示すように、BSLメモリには定義済み値の格納用に予約された固有の位置も用意され、BSLの起動が確実に正しく行われる
ようになっています。 
 

0x17FC～0x17FF 
JTAG Key: すべてのバイトが0x00か0xFFであれば、デバイスはJTAGに自由にアクセスできます。それ以外の値ではJTAGにア
クセスできません。JTAG Keyの詳細については、MSP430F5xx and MSP430x6xx Family User’s Guide (SLAU208)を参照し
てください。 

0x17FA 
BSL起動ベクタ。BSL呼び出し時に最初に実行される命令のアドレスです。 

0x17F8 
予約 

0x17F6 
BSLアンロック・シグネチャ1: 正しくプログラムされたBSLを示すために、このワードを0xC35Aとセットする必要があります。 
このワードがセットされないとBSLは起動しません。 

0x17F4 
BSLアンロック・シグネチャ2: 正しくプログラムされたBSLを示すために、このワードを0x3CA5とセットする必要があります。
このワードがセットされないとBSLは起動しません。 

0x17F2 
BSL保護関数ベクタ: BSL保護関数( protect function)の最初の命令のアドレスです。 
この関数の詳細については、このアプリケーション・レポートで後述します。 
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1.2 デバイスの起動シーケンス 
電源が投入されると、デバイスでは最初にBSLシグネチャをチェックします。BSLシグネチャに適切な値が存在していれば、デ
バイスによりBSL保護関数が呼び出されます。BSL保護関数についてはセクション1.2.1で詳細に説明されていますが、主な責務
はBSLメモリを保護し、ユーザー・アプリケーションに代わってBSLを起動する必要があるかどうかを通知することです。デバ
イスの起動シーケンスは、図1のフロー・チャートに従って起こります。 

 
図 1 デバイスの起動シーケンス 
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4 カスタム・フラッシュベース・ブートストラップ・ローダー (BSL)の作成 
 

1.2.1 BSL保護機能 

BSL保護機能は、BORの後と、ユーザー・コードの実行前に呼び出される機能です。このコードに課された時間的および機能的
な制限はありませんが、この関数が戻らない場合は、デバイスが完全に応答しなくなります。さらに、戻り関数での遅延が長す

ぎると、デバッグ中に問題が発生する可能性があります。BSL保護機能の最も基本的な役割は、BSLメモリの保護、およびBSL
保護機能を抜けた後にBSLまたはユーザー・コードを実行する必要があるかどうかの判定という2つの基幹機能(essential functions)
を実行することです。 
 
BSL保護機能は、スタック・ポインタがデフォルトの位置にセットされた状態で呼び出されます。デフォルトの位置は使用され
るデバイスごとに異なります。スタック・ポインタを変更したり、スタック・ポインタのデータ値を操作したりすると、間違い

なくデバイスが応答しなくなります。このような場合は、再プログラミングまでも含めて一切の処置が不可能になります。デバ

イスによっては、スタック・ポインタ空間(stack pointer space)が非常に限られており、BSL保護機能内でスタック・ポインタ
を使用しすぎるとメモリ・オーバーフローの原因となる可能性があります。正しいふるまいを確実に実現するには、スタックの

アクセスを制限するか、スタック・ポインタを別の場所に移す必要があります。デバイスがBSL保護機能から確実に正しく戻る
ようにするには、戻る前にスタック・ポインタを回復させる必要があります。 
 

1.2.1.1 BSLメモリの保護 
SYSBLSCレジスタのサイズ・ビットと保護ビットをセットすることで行われます。これは、BSLの呼び出しが要求されるかど
うかに関係なく行われます。これらの特定ビットの詳細については、MSP430F5xx and MSP430x6xx Family User’s Guide 
(SLAU208)を参照してください。 
 

1.2.1.2 BSL呼び出しのチェック 
BSL_Protect関数では、BSLを起動するか、(存在する場合は)アプリケーション・コードを起動するかを通知する必要もありま
す。 これは、R12のビットを次のように定義された値にセットすることで行われます。 
 

ビット 0 
0: JTAGステートを、JTAG Keyのステートに基づいて判定する必要があることを通知します。 
1: JTAG Keyを上書きして、 JTAGをオープン状態に保ちます(主にBSLのデバッグに使用されます)。 

ビット 1 
0: BSLを起動してはならないことを通知します。 
1: BSL起動ベクタの値をPCにロードしてBSLを起動する必要があることを示します。 
 
注意する必要があるのは、BSLを呼び出す必要があるかどうかを判定するための方法が、全面的にBSL保護機能に依存している
ことです。TIの供給するUART BSLでは、SYSBSLINDビットをチェックして、特定ピンでトグル(切り替え)・シーケンスが発
生しているかどうかをチェックします。ただし、TI供給のUSB BSLには、アプリケーション要件に基づくまったく異なる起動
基準(startup criteria)があります。USB電力が存在し、デバイスがブランクの場合は、BSLを起動する必要があることがBSL_Protect
関数により通知されるため、USBを介してブランクのデバイスをプログラム可能です。ただしカスタムBSLでは、ユーザー・コー
ドを既知のCRC値と照合して正しくプログラムされたユーザー・コードのみが実行を開始するようにする等、想定可能なほとん
どすべての基準を使用することが可能です。 
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1.3 TI供給の BSLソフトウェア 
各MSP430x5xxおよびMSP430x6xxデバイスには、事前プログラムされたBSLが付属しています。このBSLの使用方法について
は、 MSP430 Programming Via the Bootstrap Loader (BSL) (SLAU319)で説明されています。このレベルでBSLに精通してい
ることが、以降のセクションの前提となります。TI供給のBSLは、IAR KickStart用に作成され、IARKickStartを使用してコン
パイルされています。 
 

1.3.1 ソフトウェアの概要 

TI供給のBSLは、きわめてモジュール化の進んだ方法で作成されています。必要なカスタマイズのレベルに応じて、各種のソー
ス・ファイルを再利用したり置換したりすることが可能です。 
BSLコードの主なセクションは、次の3つです。 
 

ペリフェラル・インターフェイス 
このコード・セクションでは、BSLコア・コマンドの受信と検証を担当します。このことを実現するために、任意のハードウェ
アやプロトコル(ラッパー・バイト等)を使用できます。実際の送信メカニズムとプロトコルは、BSLのその他の部分(rest)とは関
連がありません。重要なのは、このコード・セクションではパケットを受信するよう要求された場合に、自らに送信されたデー

タをすべて正しく受信したことを認識するまで戻らないということです。BSLはユーザー・メモリの消去とプログラムに使用さ
れるため、ペリフェラル・インターフェイスがフラッシュベースの割り込みベクタを使用することはできません。イベント・ポー

リングか、RAMベースの割り込みベクタを使用する必要があります。 

コマンド・インタプリタ 
このコード・セクションでは、供給されたBSLコア・コマンドのバイトを解釈します。 ペリフェラル・インターフェイスがエラー
なしで正常にバイトを受信したことを前提にしていますが、必ずしも受信バイトがBSLプロトコルにとって正しいかどうか(例え
ば、正しくないコマンドが送信されていないかどうか)を前提にしていません。このコードでは、受信されたコア・コマンドを
BSLコア・コマンド・リスト(SLAU319参照)に従って解釈し、BSL APIを呼び出して受信コマンドを実行します。  

BSL API 
このコード・セクションでは、コマンド・インタプリタ～読み出し/書き込み対象メモリ間の抽象化層を提供し、メモリのロック
解除(unlocking)、メモリへの書き込み、メモリからの読み出し、CRC(巡回符号検査)という全局面(aspect)を扱います。また、
可能な場合は常にセキュリティを扱うコード・セクションでもあります。これにより、コマンド・インタプリタではセキュリティ

の問題を気遣うことなく、要求の生成と応答の送信を簡素に行うことが可能になります。また、このモデルにより、きわめて安

全性の高いカスタムBSLを生成することが可能になります。TIから供給されるセキュリティ検査および対策(security checks and 
measures)のメリットをあらゆるカスタムBSLが享受できるように、BSL APIはどのようなカスタムBSLにおいても、置き換え
は、ほとんど無いセクションであるとみなされています。 
 

1.3.2 ソフトウェア・ファイルの詳細 

このセクションでは、すべての関数の詳細を(パラメータや返り値等まで)説明しているわけではありません。この情報は、ヘッ
ダ・ファイルとソース・ファイルの関数コメント(function comments)に記載されています。このセクションの目標は、ソースを
一読しただけでは明快に理解できない可能性のある、個々のファイルの重要な担当(responsibilities)を目立たせることです。 
 

1.3.2.1 BSL430_Low_Level_Init.s43 
このファイルでは、予約されたメモリ位置、BSL_Protect関数、Z領域内の公的に利用可能な(publically available)関数等の低レ
ベルBSL局面(aspect)を扱います。通常、ここで必要となるカスタマイズは次に挙げるものだけです。 
 

 異なる条件でBSLを呼び出すためにBSL_Protect関数を変更する。 

 最終的なBSLイメージ用に、0xFFFF以外の値をJTAG keyの位置に書き込む。 

 付加的な関数をZ領域に追加して、ユーザー・コードを介して実行できるようにする。 
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1.3.2.2 BSL_Device_File.h 
このファイルは、ある特定のデバイス派生品(device variations)を抽象化して、すべてのBSLソース・コード・ファイルをデバイ
ス間で同じに扱うために使用されます。デバイスのインクルード・ファイル、ポートの再定義、クロック速度等、すべてのデバ

イス固有情報が記載されている場所です。さらに、次に示すようなカスタムBSLの定義も記載されています。すべてのBSLにす
べての定義が有効であるわけではなく、このファイルに記載のない定義もあることに注意してください。 
 

MASS_ERASE_DELAY 
ロック解除時に、ACKを送信する前に使用される遅延値 
 

INTERRUPT_VECTOR_START 
BSLパスワードの開始アドレス用の定義 
 

INTERRUPT_VECTOR_END 
BSLパスワードの終了アドレス用の定義 
 

SECURE_RAM_START 
RAMの先頭(The start of the RAM)であり、安全のためにBSL起動時に上書きされる必要があります。これは通常、最低位のRAM
値です。RAMはこのアドレス～スタック・ポインタ間でクリアされます。  
 

TX_PORT_SEL 
このポート定義の集まりは、TX/RXポートを個別のポート・ピンから抽象化し、ペリフェラル・インターフェイスのソース・コー
ドを変更しなくてもこれらの値をデバイス間で変更できるようにするために使用されます。 

RAM_WRITE_ONLY_BSL 
これが定義されると、コンパイルされるBSLのサイズが大幅に小さくなります。この小サイズ版では、デバイス内のRAMへの書
き込みと、ロック解除(unlock)、PCの設定、データ受信に必要なコマンドの受信のみが可能になります。スペースを節減し、USB
スタックを2kBのBSLメモリに収納するために、USB BSL内で使用されます。RAM書き込み専用(write-only)BSLは、完全なBSL
をRAMにロードして、このBSLを起動してさらに通信を行うために使用されます。 

RAM_BASED_BSL  
これが定義されると、BSL がBSLメモリでなくRAMの外で実行されている場合に必要となる、API内のコード・セクションがイ
ンクルードされます。これは主にフラッシュ書き込み時の遅延に対応するためであり、BSLがRAMの外(USB BSL等)で実行さ
れている場合にのみ使用されます。  

USB_VID 
USB BSL用のベクタIDです。 

USB_PID 
USB BSL用のプロダクトIDです。 

SPEED_x 
これは、外付けオシレータ速度を定義するために使用され、USB BSLの起動シーケンスでテストされます。この場合の値はヘル
ツ単位のそのままの値です(例えば、 24000000は24MHzとなります)。 

SPEED_x_PLL 
デバイスのヘッダ・ファイルからの、SPEED_x 定義内に記述されているオシレータ速度についての対応するPLL定義です。 
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1.3.2.3 lnk430FXXXX_BSL_AREA.xcl 
カスタム・リンカ・コマンド・ファイルです。プロジェクト・コードの出力をBSLメモリ位置に配置します。 
さらに、前述の予約されたBSLメモリ・セクション用の定義も備えています。通常、このファイルを変更する必要はないはずで
す。BSLリンカ・コマンド・ファイルの種類によっては、リセット・ベクタの出力が意図的に、正しいデバイスRESETベクタ位
置以外の場所に配置されます。こうすると、保護されたBSLメモリへのジャンプをデバイスが継続的に試みることになり、その
結果リセットが発生して無限リセット・ループを起こします。 
 

1.4 カスタム・ペリフェラル・インターフェイスの生成 
既存のBSLソフトウェアは、別の通信インターフェイスへの移植が容易です。これが可能なのは、通信を扱うペリフェラル・イ
ンターフェイス・コードと、BSLソフトウェアのその他部分が非常に緩やかに結合しているためです。カスタム・ペリフェラル・
インターフェイスを実装するには、ファイルBSL430_PI.hにある次のような関数を定義する必要があります。 
 

1.4.1 PI_init () 

この関数では、次の3つを主に管理します。 
 通信ペリフェラルを初期化して、データ受信開始のステートに入るようにする。 
 デバイスのクロック・システム(通常は8MHzですが、他のコードは独立しているため、その他の値でも可能です)を初

期化する。 
 BSL430_Command_Interpreterの値 "BSL430_ReceiveBuffer" と "BSL430_SendBuffer" を、データ・パケットが格

納される位置にセットします。RAM (UART用等の)にある同一バッファでも、ペリフェラル(USB用等)に使用される
別の位置でもかまいません。これらのポインタでBSLコア・コマンドの先頭バイト(first byte)をポイントする必要があ
ることに注意してください。したがって、ペリフェラル・インターフェイスのバッファがラッパー・バイト用にさらに

大きいバッファをRAMで使用する場合は、これらのポインタでそのバッファ内部をポイントする必要があります。 
  

1.4.2 PI_receivePacket() 

BSLの主なループ関数(primary loop function)です。この関数ではコア・コマンド用のすべてのバイトを受信し、その結果に基
づいてコア・コマンドに値を返します。返り値の定義は次の通りです。 
 

DATA_RECEIVED 

データが正常に受信されました。コマンド自体が有効であるかどうかを検証するためのチェックは行われませんが、バイトはホ

ストが送信したとおりに正しく受信されており、安全に処理できます。  

RX_ERROR_RECOVERABLE 

パケットの受信中に何らかのエラーが発生しました。パケットは失われましたが、受信関数( receive function)を再度呼び出すこ
とが可能です。 

RX_ERROR_REINIT 

パケットの受信中にエラーが発生したために、それ以上パケットを受信する前にPI_init() 関数を再度呼び出す必要がある場合の
ために予約されています。 

RX_ERROR_FATAL 

パケットの受信中にエラーが発生し、それ以上の通信が不可能になった場合のために予約されています。完全なシステム再起動

が必要になります。 

PI_DATA_RECEIVED 

パケットが受信され、ペリフェラル・インターフェイスによって処理されたことを通知します。PI_receivePacket()関数を再度
呼び出すこと以外のアクションは不要です。 
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1.4.3 PI_sendData(int bufSize) 

この関数は、コマンド・インタプリタが送信バッファを応答(reply)で満杯にした時に、コマンド・インタプリタによって呼び出
されます。送信するバイト数をペリフェラル・インターフェイス側で認識できるように、バッファ内のデータのサイズがパラメー

タとして渡されます。 
 

1.5 BSLの開発とデバッグ 

1.5.1 開発とテスト 

BSLメモリの保護が原因で、BSLコードのデバッグと開発は難しいものになりがちですが、新しいペリフェラル・インターフェ
イス等の「高レベル」の開発の場合は、ユーザー・コード・フラッシュの外部で実行するアプリケーションとして容易にBSLを
開発することが可能です。 
 

 プロジェクト・ビルドからBSL430_Low_Level_Init.s43を削除します (IAR内のファイルを右クリックして "remove from 
build"を選択)。 

 CONFIGディレクトリからリンカ・コマンド・ファイルを使用して、BSL を"FLASH_AREA"に置きます (Project -> 
Options -> Linker -> Config -> Override default)。 

 BSL呼び出しシーケンス中にデバイスをリセットせずに、外部アプリケーション(BSL_Scripter.exe等)を実行します。 
 正しくないパスワードを送信したり、一括消去(mass erase)を起動したりしないでください (IARではRESETベクタを

自動的にビルドするため、パスワードはこれに含まれることを忘れないようにしてください)。 
 

BSL_Protect関数の開発とデバッグのために、 シミュレータを使用することも、デバッグ中にBSLメモリ保護ビットをオープン
状態にしておくことも可能です。どちらの場合も、"Run to Main" のチェックを外しておく必要があります。 
 

1.5.2 特記事項とヒント 

BSLコードは、RAM内の最高位アドレスと最低位アドレスでRAMを使用します。このため、BSLが複数のデバイスをターゲッ
トとする場合は、RAM容量が最小のデバイスをターゲット(IARの場合は Project -> Options -> General Options -> Device)とす
る必要があります。また、SECURE_RAM_STARTは最高位の共有アドレスにセットする必要があります。 
 
デバイスのBSLは、次に示すバージョンのIARを使用してビルドされています。 
MSP430F5438A と CC430F6137: IAR 5.3 KickStart  (IAR C/C++ コンパイラ 4.20.1を併用) 
MSP430F5529: IAR 4.11C KickStart (IAR C/C++ コンパイラ 4.11Bを併用) 
 

1.5.3 USB BSL外付けオシレータの周波数 

USB BSLではルーチンを使用して、アプリケーションで使用される外付けオシレータの速度を測定します。測定は、外付けクロッ
クの速度を既知の較正済み内部クロックと比較することで行われます。この方法で、デフォルトのBSLを修正せずに、ある特定
の外付けオシレータ周波数で使用できるようになります。アプリケーションで他の周波数を使用する場合は、SPEED_x値とそ
れに対応するSPEED_x_PLL値を変更できます。この2つは、最高速度から最低速度へという順番になっている必要があります。
使用する速度が一種類のみの場合でもすべての値を定義する必要がありますが、定義する周波数は同一にできます。  
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上記のコード例に示されているように、既知の周波数を1種類だけ使用する場合でも、計測ループをUSBペリフェラル・インター
フェイスに残しておくことが重要となります。水晶発振回路(クリスタル)の起動(startup)を可能にするための遅延にも使用され
るためです。 
 

2 G2xxブートストラップ・ローダーの生成とカスタマイズ 

2.1 対象となるシステム仕様(Target System Specification) 
このブートストラップ・ローダーは、MSP430G2001(MSP430バリュー・ラインのデバイス・メンバの中では現時点で最小サイ
ズの製品)で使用することを目的として設計されています。ただし、他の G2xxデバイスに合わせて修正することも容易に可能と
なっています。その場合に必要となる修正は、このアプリケーション・レポートに記載されています。 
 

 
図 2 機能ブロック図、MSP430G2x01 

 
BSLでは、次のようにメモリ・サイズが重要となります。 

RAM: 128バイト 
フラッシュ: 512バイト、MSP430G2001でのセグメント1つ  
Info A: 64バイト－ DCO較正データ2バイト(1 MHzの場合) 
Info B, C, D: それぞれ64バイト 

 

2.2 BSLの仕様 
このアプリケーション・レポートで紹介されているBSLは、ひとつの単純な要件に従っています。その要件とは「簡素さ」です。
それに加えて、デバイスで使用可能なリソースがこのBSLの機能のしかたに大きく影響しています。 
 

注: このBSLを、他の TIのBSL製品と混同しないようにしてください。ROMかフラッシュかを問わず、このBSLは他
のMSP430 BSL製品をベースにして作られたわけではありません。 

 

2.2.1 機能性 

使用可能なコード・サイズに関しては、ひとつの機能だけが実装されます。そのフローは以降のセクションで説明されます。正

確にこの順番でないとコードを実行できないことに注意してください。 



JAJA458                                      www.tij.co.jp 

10 カスタム・フラッシュベース・ブートストラップ・ローダー (BSL)の作成 
 

 

2.2.1.1 エントリ・シーケンス 

BSLに入ることが可能なのは、デバイスがリセット・イベントから抜けた時、かつBSL_entryピンがLowにプルされている時の
みです。 
 

2.2.1.2 同期 
エントリ・シーケンスの後、BSLはSYNC文字の待機中となります。SYNC文字は、BSLエントリが偶然によるものではないこ
とを確認するために使用されます。 
 
1バイトが受信されるまで、デバイスは永続的にループし続けることに注意してください。このバイトがSYNC文字と一致すれば、
BSLでは動作を継続します。一致しない場合は、BSLによりリセット・イベントが生成されます。 

SYNC文字 = 0xBA 
 

2.2.1.3 直前のフラッシュ内容の消去 
SYNC文字が正常に受信された後、BSLでは直ちにメイン・フラッシュを消去して、新しいデータに備えます。 
 
ユーザー・コードはメイン・フラッシュに存在していますが、そのコード空間を割り込みベクタ・テーブルと共有しています。

そのため、BSLではBSLをポイントしているリセット・ベクタを復元するための処置を直ちにとる必要があります。復元にはフ
ラッシュ・セグメント1つあたり約16msの時間がかかりますが、最低でもその2倍の時間の間、デバイスの電圧を一定に保つ必
要があります。個別のデバイスのデータ・シートを参照して、ひとつのデバイスに存在するフラッシュ・セグメントの数を判断

してください。  

警告(CAUTION) 

フラッシュの消去～リセット・ベクタ復元完了までの期間中、システムはロッ

クアウト状態の発生に対して非常に脆弱となっています。ロックアウトが発生

した場合は、デバイスに再度アクセスすることはできなくなります。 

 

2.2.1.4 新しいユーザー・データの受信と書き込み 
消去が発生した後、BSLではユーザー・データを1バイトずつ受信できるようになります。ハンドシェイクは行われないため、
システムの予測するデータのサイズは非常に正確となります。このデータ・サイズは、使用可能なメイン・フラッシュの総サイ

ズから2バイトを引いた値となります。 範囲は最低位のフラッシュ・アドレスからリセット・ベクタまでですが、リセット・ベ
クタ自体は入りません。 
 

2.2.1.5 データの検証 
デーががすべて受信された後、1バイトのみのXORチェックサムがデバイスに送信されます。BSLではこのチェックサムを、書
き込まれたフラッシュ・データについて計算したチェックサムと比較します。 
 
チェックサムが一致すれば、BSLではACK文字(0xF8)を返します。チェックサムが一致しない場合は、NACK (0xFE)が返され
ます。 
 

2.2.2 メモリのフットプリント 

このアプリケーション・ノートで使用されているような小サイズのデバイスにブートストラップ・ローダ―を実装する際に最も

難しい問題になるのが、コードのサイズです。その本質から見て、BSLは常にメモリ内に存在して、ロックアウト状態が発生し
ないようにする必要があります。ロックアウト状態になると、デバイスにアクセスできなくなります。 
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BSLのユーザー・コード更新中にBSLコードが変更されないようにするには、ユーザー・コードとは別のフラッシュ・セクショ
ンにBSLが常駐している必要があります。MSP430G2001デバイスには使用可能なメイン・フラッシュ・セクションがひとつし
かないため、BSLの常駐先は残りの唯一のフラッシュ部分、つまり情報メモリ(総使用可能サイズ254バイト)とする必要がありま
す。  
 

2.2.3 ペリフェラル 

MSP430G2xxデバイスの中には、通信モジュールが搭載されていないものもあります。したがって、シンプルなソフトウェア・
ベースのインターフェイスが使用されます。通信機構がシンプルなため、非ハンドシェイク型UARTが使用されます。 
効率的にこのソフトウェアUARTを実装するために「ボー・レート9600、データ・ビット8個、ストップ・ビット1個、パリティ
無し」という設定でTimer_Aと2つのGPIOピンが使用されます。 
 
さらに、RSTピンを介したデバイス・リセットと連動して、1つのGPIOピンを使用してBSL起動シーケンスを開始します。 
 

表 1 ピン割り当て 

ピン 機能(関数) LaunchPadピン 
P1.3 BSL_entry Switch S2(スイッチ S2) 
P1.1 UART RxD(データ受信) Cross connect(相互接続)! TXD(データ送信) 
P1.2 UART TxD(データ送信) Cross connect(相互接続)! RXD(データ受信) 
RESET RESET(リセット) RESET(リセット) 
USB Backchannel UART and power 

(バックチャネルUARTと電力) 
UST～Host (UST～ホスト間) 

2.3 実装 
プロジェクトはBSL部と、メインまたはユーザー・アプリケーション部の2つに分割されます。各種ニーズに応じて、C言語版ま
たはアセンブリ言語(ASM)版の ユーザー・コードが入手可能です。 
 

2.3.1 BSLアセンブラ・コード 

BSL用のすべてのコードは、MSP430G2xxBSL_CCS(IAR).asmに記載されています。内容は次の通りです。  
 リセット割り込みテーブル・ステートメント (エントリ・ポイント) 
 BSLコード 
 小サイズのユーザー・アプリケーション例 (デモ目的でのみLEDを点灯) 

 

2.3.1.1 DCO較正データの保存 
BSLコードは情報メモリに存在するため、InfoAに格納されているDCOの較正データを保存して復元することが重要となります。
試作中は、これを次のように手動で行うことができます。 
 

 
 
量産(production)段階では、これはさらに容易になります。情報メモリが空のため、書き込みの前に消去する必要がないとみな
せるためです。元のデータを使用するには、コードを変更する必要があります。 GANG430等、大多数の量産プログラマ(production 
programmer) でも、フラッシュ・データを「保全する」機能をサポートしています。 
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2.3.1.2 リンカ・コマンド・ファイル 
もう一つ重要なBSLのファイルが、コードとデータの場所を定義するリンカ・コマンド・ファイルです。リンカ・コマンド・ファ
イルはCCSとIARではわずかに異なりますが、「BSLとアプリケーション・コードを置く場所をリンカに伝える」という概念は
同じです。 
 
2.3.1.2.1 リンカ・コマンド・ファイルの配置 
デフォルトでは、IDEに付随する標準的なリンカ・コマンド・ファイル が選択・使用されます。このBSLプロジェクトの場合は、
ファイルにいくらか修正を加える必要があります。 

表 2 リンカ・コマンド・ファイル 

CCS IAR 
CCSでは自動的にデフォルトのリンカ・コマンド・ファ
イルをプロジェクト・ディレクトリにコピーします。
ファイルには、CCS Project Explorerを使用してアクセ
ス可能です。 

IARでは、インストール・パスからデフォルトのリンカ・
コマンド・ファイルを直接選択して使用します。通常のパス
は次の通りです。 
C:\Program Files\IAR Systems\EWB MSP430 
5.20\430\config 

標準的なファイル名 
lnk_msp430g2001.cmd lnk430g2001.xcl 

元のファイルの保持方法 
CCSではファイルをプロジェクトにコピー済みです  元のファイルをプロジェクト・ディレクトリにコピー

して、デフォルトのファイルを保全する必要がありま
す。  

カスタマイズされたファイルを明確に区別するために変更された後のファイル名 
lnk_msp430g2001_bsl.cmd  lnk430g2001_bsl.xcl 

 

2.3.1.2.2 リンカ・ファイルの修正 
このBSLプロジェクトの場合は、次のような修正をファイルに加える必要があります。 

表 3リンカ・ファイルの修正 

CCS IAR 
情報メモリ・セグメントがデータ用に使用されなくなっているため、削除することが可能です 

MEMORYセクション内の次の4行を削除するか、コメ
ント化(/* および */)します 
/*INFOA: origin = 0x10C0, length = 0x0040 */ 
/*INFOB: origin = 0x1080, length = 0x0040 */ 
/*INFOC: origin = 0x1040, length = 0x0040 */ 
/*INFOD: origin = 0x1000, length = 0x0040 */ 

次の5行を削除するか、コメント化(//)します  
//-Z(CONST)INFO=1000-10FF  
//-Z(CONST)INFOA=10C0-10FF  
//-Z(CONST)INFOB=1080-10BF  
//-Z(CONST)INFOC=1040-107F  
//-Z(CONST)INFOD=1000-103F 

この使用されなくなったメモリは、BSLと表示(labeled)され、かつコードが含まれる新しいメモリ・ブロック1
つに割り当てられます。下記の行が、直前にt削除またはコメント化された行の下に追加されます。 

BSL : origin = 0x1000, length = 0x00FE  -P(CODE)BSL=1000-10FD 
メモリ領域への内容の割り当て 

SECTIONS部から次の4行を削除します。 
/* MSP430 INFO FLASH MEMORY SEGMENTS */ 
/* .infoA : {} > INFOA *//* .infoB : {} > INFOB */ 
/* .infoC : {} > INFOC */ 
/* .infoD : {} > INFOD */ 
 

上のステートメントですでに行われています。 
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これらの行の下に、次の1行を追加します。 
bsl : {} > BSL /* BSL CODE */ 
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2.3.1.2.3 IDE がカスタム・リンカ・ファイルを使用するようにする 
このBSLプロジェクトの場合は、次のような修正をファイルに加える必要があります。 

表 4 カスタム・リンカ・ファイルの使用 

CCS IAR 
リンカ・コマンド・ファイルがプロジェクト・パスに
存在している場合(これがデフォルト)は、アクション
は不要です。 

Project -> Options -> Linker -> Config 
デフォルトのリンカ構成ファイルを、直前に生成した

ファイルで上書き(Override)します。 
xcl ファイルがasmファイルと同じ位置に格納されてい
る場合は、次の用に$PROJ_DIR$ を使用できます。
$PROJ_DIR$\lnk430g2211_bsl.xcl. 
そうでない場合は、フルパスを提供してファイルをポ

イントすることが可能です。 
 

2.3.1.3 プロジェクトの設定 
IDE自体の中にあるプロジェクトが、BLSのもうひとつの重要な部分です。このプロジェクトをセットアップして、正しいデバ
イスを使用したり、InfoAを含めすべての情報メモリ位置に対する消去や書き込みアクセスが行えるようにする必要があります。 

表 5 プロジェクトの設定 

CCS IAR 
ターゲット・デバイスの指定方法 

Project -> Properties -> CCS Build -> General -> 
Device Variant 

Project -> Options -> General Options -> Target -> 
Device 

情報メモリへのアクセス 
Debug Properties -> Target -> MSP430 Properties -> 
Download 
Options -> Erase options: 
メイン・メモリ、情報メモリ、保護対象情報メモリを
消去します。 

Project -> Options -> Debugger -> FET Debugger -> 
Download: 
ロックされたフラッシュ・メモリの消去と書き込みア
クセスを可能にし、メイン・メモリと情報メモリを消
去します。 

 

2.3.2 ユーザー・アプリケーション 

参考の目的で、点滅LEDの例が提供されています。 
 
このプログラムは、他のあらゆるユーザー・アプリケーション同様、BSLを修正しなくてもダウンロードしてデバッグできます。 
 
BSLとユーザー・アプリケーションの間では、プログラムの開始位置以外に相互作用はありません。これは、BSLがこの開始位
置にジャンプして、それがコードであるとみなすためです。データがこの位置に格納されている等の場合は、ユーザー・アプリ

ケーションが正しく起動しなくなります。開始位置はデバイスとプログラム言語によって異なります (表6参照)。 

表 6 ユーザー・アプリケーション 

CCS IAR 
アセンブリ 

ラベリング直後にユーザー・アプリケーションが起動します。 
.text  RSEG コード 

コード例 
mainApp_CCS.asm  mainApp_IAR .asm 

C 
ユーザー・アプリケーションがmain() 関数として起動します。
実際の主要開始位置はcinit() 関数に依存するため、コンパイラ

とリンカが位置を管理します。 
コード例 

mainApp.c 
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2.4 BSLの動作 
2.4.1 ハードウェアのセットアップ 
デモ用としては、MSP430G2xxがLaunchPadプラットフォームに装着されており、表7に記載の接続が行われることが前提とな
ります。 

表 7 BSLデモのセットアップ 

ピン 機能(関数) LaunchPadピン 
P1.3 BSL_entry Switch S2(スイッチ S2) 
P1.1 UART RxD(データ受信) TXD(データ送信) (相互接続) 
P1.2 UART TxD(データ送信) RXD(データ受信) (相互接続) 
RESET RESET(リセット) RESET(リセット) 
USB (バックチャネルUARTと電力)  UST～Host (UST～ホスト間) 

 
 

 
図 3 デモ用セットアップ 

 

2.4.2 ホストへの接続 

デモを実行するには、LaunchPadを ホストPCに接続する必要があります。これによりボードに電源が投入され、 Spy-Bi-Wire を
介したコードのダウンロードがデバッグ用に可能になり、またBSL動作にとって最も重要なことですが、 UARTインターフェイ
スが提供されます。すべてのLaunchPadのオンボード・エミュレーション回路には自由に使えるアプリケーションUARTが搭載
されています。アプリケーションUARTを使用して、USB ～UARTブリッジ～ホストPCという接続が実現されます。 
 

注: 電圧とタイミングの要件が合う限り、上記以外のどんな方法を使用してもデバイスにUARTインターフェイスを提
供することは可能です。 
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2.4.2.1 COMポートの決定 
LaunchPadがホストに接続された後、どのCOMポートを割り当てるかを決める必要があります。  
Windows® XPのシステムでは「デバイス マネージャ」を使用してCOMポートが決められます。「デバイス マネージャ」は
devmgmt.mscを実行することで起動できます。 

 
図 4 Windows® XPの「デバイス マネージャ」画面例 

 
「Ports(COM & LPT)」という見出しのセクション内に、LaunchPadが「MSP430 Application UART」として表示されているは
ずです。 
COMポートの番号は、この名前の右側に記載されています。 例えば図4の画面例では「COM11」となっています。 
 

2.4.2.2 COMポートのセットアップ 
COMポートは用途の広いインターフェイスであるため、初期化して「ボー・レート9600、データ・ビット8個、ストップ・ビッ
ト1個、パリティ無し」という正しい設定にすることが重要です。 
 
上記のことを行うもっとも簡単な方法は、端末プログラム(terminal program)を使用することです。端末プログラムは、このBSL
を使用するためにも必要です。このアプリケーション・レポートでは、シンプルでありながら強力なHTermという端末プログラ
ムを使用します。これはhttp://www.der-hammer.info/terminal/hterm.zipからダウンロードでき、このアプリケーション・レポー
トを執筆している時点では(as of this writing)無償です。また、HTerm はLinuxシステムにも使用できます。 
 
セクション2.4.2.1に記載のCOMポートを選択し、ポート値を設定して、デバイスに接続します。 
 

 
図 5  HTermのCOMポート構成の画面例 

 
注: Htermはこの目的に使用できる多くのプログラムのひとつであり、あくまでこのプロジェクト用のGUIの一例とし
て使用されているにすぎません。 
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2.4.3 BSLを動作させるための標準的な手順(Sequence) 

新しいデータをデバイスのフラッシュに保存するために、BSLが次の手順で使用されます。 
 
1. LaunchPad上のリセット・ボタンを押したままにして、MSP430G2xxをリセット・ステートにします。 
2. LaunchPad上のボタンS2 (BSL_entry ピン)を押して、リセット・ボタンを放します。デバイスがBSLモードになったら、S2
を放します。 

3. SYNC文字をホストからデバイスに送信します。 
4. (フラッシュ・セグメント数(NumberOfFlashSegments) × 16 × 2) ms以上待機して、デバイスがフラッシュを消去し、割り込
みベクタを復元するための時間を十分に取ります。  

5. ユーザー・コードをバイト単位でホストからデバイスに送信します。 
6. チェックサムをホストからデバイスに送信します。 
7. 応答 (ACK またはNACK) をデバイスから読み出します。 
8. 応答(answer)がACKの場合は、BSLの行った強制リセットによりデバイスがすでにアプリケーション・モードになっています。 
9. 応答(answer)がNACKまたは無反応の場合は、ACKが受信されるまでこの手順を反復して実行します。 
 
HTermには"Send File" ボタンがあり、これを使用して、バイナリファイルに格納されたデータを送信できます。このドキュメ
ント経由で入手可能なZipアーカイブには、BSLを検証するためのユーザー・コード(ファームウェア)のファイルが入っています。
また、数字の形式を気にせずに同期文字を送信するためのSYNC.binファイルも入っています。 
 

2.4.4 BSLを介してダウンロードするための新規コードの生成 

2.4.4.1 カスタム・アプリケーションの生成 
顧客アプリケーションの開発は常に、仕様の作成、コーディング、デバッグ、テストという手順で行われます。この時点では、

プロジェクトにBSLを組み込む(インクルードする)必要はありません。 
 
便宜のため、C言語とアセンブリ言語で作成された2つのプロジェクト・デモが入手可能であり、アプリケーション開発の開始点
として使用できます (詳細についてはセクション2.3を参照)。 
 

注: 情報メモリはユーザー・コード用には使用できません。デバッグ・オプションの'erase Info memory(情報メモリ
を消去)' のチェックを外して、この領域が誤って使用されないようにしておくとよいでしょう。 

 

2.4.4.2 較正データの保存 
試作中は、1MHzのDCOの較正データを保持しておくことが重要となります。このデータは、BSL実行中にホストと安定した通
信を行うために使用されます。またDCO較正データは、ユーザー・アプリケーション内で定義されたクロック周波数用にも役立
ちます。 
 
較正データは、InfoAデータの上書きが発生しないユーザー・アプリケーションのデバッグ中に最も簡単に読み出せます。例え
ば、図6と図7に示す方法で較正値を取り出せます。  

 
図 6 View -> Register -> Calibration_Data (CCS) 
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図 7 View -> Memory: 0x10fe and 0x10ff (CCS) 

 
デバッグ中に、これらの値を記録してBSL asm ファイル内で復元することが重要となります。量産(production)の場合は、量産
プログラマ製品GANG430を使用する等、別の方法で較正データを保存します。  
 

2.4.4.3 ユーザー・アプリケーション・コードを BSL更新ファイルにする 
BSLの更新を意図して、ユーザー・アプリケーションを作っている場合は、 BSLデータを生成することが可能です。 
 

2.4.4.3.1 CCSの使用 
IDEを利用すると、これを最も簡単に行うことができます。アプリケーションがデバイスにダウンロードされた後、メモリを再
度読み出してファイルに保存できます。 
 
View -> Memoryと選択して出てきた画面で、上向き矢印の付いた小さな緑のICのアイコンをクリックすると、メモリの読み出
しと保存を行うことができます(図8参照)。 

 
図 8 CCS内のファイルにデバイスのメモリ内容を保存する 

 
このファイルはこれ以降、(HTerm等の)端末プログラムに対する入力ファイルとして使用できます。このファイルには XORチェッ
クサムが含まれていないことに注意してください。XORチェックサムは次のステップで付加されます。 
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2.4.4.3.2 IARの使用 
IARでは(現時点では) TI Text形式またはIntel Hex形式としてのみメモリ領域を保存できるため、必要なメモリ領域を保存した
後、変換ユーティリティ(hex2bin等)を使用して出力ファイルを変換する必要があります。  
 

2.4.4.4 XORチェックサムの取得 
追加のプログラムを使用せずに正しいチェックサムを取得する最も容易な方法は、デバイスをデバッグ・モードで使用すること

です。 
 

注: デバッガに接続している場合は、ハードウェア上でリセット・スイッチを使用しないでください。リセット・スイッ
チではなく、IDEのソフトウェア・リセット・ボタンを使用してください。 

 

2.4.4.4.1 ユーザー・データの送信 
正しいエントリ・シーケンスの後、ユーザー・コードの全バイト(メイン・フラッシュ・サイズから2バイトを引いた値)がホスト
からデバイスに送信されます。これらのバイトには、XORチェックサムは含まれていません。チェックサムは最後のバイトとし
て送信されます。  
 

2.4.4.4.2 チェックサムの読み出し 
ここで、IDEのデバッグ・セッションを一時停止して、デバイス上で計算されたフラッシュのチェックサムを読み出します。チェッ
クサムは、rCHKSUMという識別名(symbolic name)でコア・レジスタR8に置かれています。 
 

2.4.4.4.3 取得したチェックサムの送信 
ここで、ターゲットを動かして(一時停止解除)、R8から抽出された値をターゲットに送信します。これによりBSLサイクルが完
了し、ACKが受信されることになります。 
 

2.4.4.4.4 データの検証 
チェックサムが正しかったかどうか、およびデバイス内のデータが正しいかどうかを検証するには、BSLを介してフラッシュに
書かれたデータを読み出し(図8参照)、元のフラッシュ・ファイルと比較する必要があります。 
 

2.4.4.4.5 チェックサムの保存 
比較してもエラーが出なければ、チェックサムをファームウェア・ファイルに付加できます。これにより、チェックサムをデバ

イスごとに計算し直さなくても、複数デバイスへのダウンロードが容易に可能になります。  
 

2.4.5 量産(本稼働)に向けての準備 

量産(本稼働)に備えて、デバイスのフラッシュに書き込むための有効なファームウェア・イメージを1つ用意する必要があります。 
 
これを行う簡単な方法は、TI-TXT形式のコードのテキスト版を使用して、BSL TI-TXTの内容をユーザー・アプリケーションに
コピー＆ペーストすることです。 
 
BSLプロジェクトにユーザー・コードを追加します。この方法を使用すると、BSLとユーザー・コード間の通信のデバッグが可
能になるというメリットが得られます。 
 



IMPORTANT NOTICE 


