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BOOST-DRV8848

This document is provided with the BOOST-DRV8848 dual brushed-motor BoosterPack™ as a
supplement to the DRV8848 datasheet (SLLSEL7). This application report details the hardware setup and
operation of the BoosterPack.
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Hardware Views
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Hardware Views
Figure 1 illustrates the BOOST-DRV8848 and Figure 2 pictures the BOOST-DRV8848 connected to the
MSP430G2 LaunchPad™.

Figure 1. BOOST-DRV8848

Figure 2. BOOST-DRV8848 on Top MSP430G2 LaunchPad
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Introduction to the BOOST-DRV8848
The BOOST-DRV8848 is a dual brushed DC motor BoosterPack based on the DRV8848 dual H-bridge
motor driver. This BoosterPack provides a fully-protected, brushed DC motor drive stage in order to
evaluate your motor application.

2.1

Features
•
•

•
•
•
•
•
•

Complete dual brushed DC motor drive stage in a small form factor (1.75 in x 2.0 in)
High output current per H-bridge
– 2-A peak
– 1-A RMS
Parallel mode available for higher current
Wide power supply voltage range 4.0 V – 18.0 V
Fully-protected drive stage including overcurrent, short-circuit, over-temperature, and undervoltage with
reporting through the nFAULT pin
Highlights the compactness of the DRV8848 solution
Combine with TI LaunchPad kits to create a complete brushed DC motor drive and control platform
Optimized for the MSP-EXP430G2 LaunchPad with a user-friendly application to get the motor
spinning in minutes

Figure 3. DRV8848 Solution Size
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Pinout
The LaunchPad interfaces to the BoosterPack over the LaunchPad headers (J1 and J2). Figure 4 gives an
overview of the various control and feedback signals.

Figure 4. BOOST-DRV8848 Pinout
•
•
•
•
•

4

Powered by an external power supply (4 V–18 V) that is connected to the terminal block header (J5)
4-pin terminal block header (J6) for connecting two brushed DC motors
Parallel mode jumper in order to supply 2x current to a single brushed DC motor
Fault reporting through the nFAULT signal and LED
Onboard potentiometer for setting the current limit voltage (VREF)

BOOST-DRV8848
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Operating the Booster Pack

3.1

Requirements
The dual brushed DC motor BoosterPack is not a standalone evaluation board and requires a compatible
LaunchPad kit to provide the appropriate control signals. In addition to the dual brushed DC motor
BoosterPack and a compatible LaunchPad, you will require one/two brushed DC motors and sufficient
power supply.

3.2

Launchpad Configuration
For the MSP-EXP430G2 LaunchPad, keep the P1.0 (LED1) and P1.6 (LED2) jumpers for correct
operation of the Status indication of the BoosterPack firmware. Align the TXD and RXD jumpers
horizontally for operation of the hardware UART with the software application.

Figure 5. MSP-EXP430G2 Jumper Location
For other LaunchPads, ensure that the appropriate jumpers are configured on pins that the BOOSTDRV8848 BoosterPack utilizes.
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Hardware Connection
1. Plug the dual brushed DC motor BoosterPack onto the LaunchPad as shown in Figure 2. The
MSP430G2 LaunchPad will dock with the outer row of the 20-pin headers. The inner row is provided to
maintain compatibility with 40-pin LaunchPads. Orient the terminal block headers towards the USB
connector.
2. Connect the brushed motors to the terminal block header J6.
3. Connect the power supply that will power the brushed motor BoosterPack’s DRV8848 to the terminal
block header J5. The connections have been labeled VM and GND. For full performance, ensure as
much current as your motor may demand is supplied. The brushed motor BoosterPack has a designed
operating range from 4.0–18 V, up to 1-A RMS/2 A peak for each H-Bridge.
4. Enable the power supply.
5. Enable the controller and spin the motor! The BOOST-DRV8848 dual brushed DC motor BoosterPack,
combined with a TI LaunchPad, will provide a complete brushed DC motor evaluation platform. With
the MSP-EXP430G2 LaunchPad and a MSP430G2553, you can take full advantage of TI's pre-written
brushed motor control application (see Section 4 for additional details).
NOTE: At high currents the drive stage can increase to high temperatures.
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Brushed Motor Demo Application

4.1

Introduction
As previously mentioned, the BOOST-DRV8848 dual brushed DC motor BoosterPack has been optimized
to work together with the MSP430G2 Launchpad to provide a complete brushed motor evaluation
platform. With the demo application provided, the brushed motor can be up and spinning in minutes. To
get started with TI's pre-written brushed control application, follow the steps outlined in the next
section.

4.2

Setting up the BOOST-DRV8848 Firmware
1. Load the BOOST-DRV8848 brushed motor control application onto the MSP430G2553 by first
downloading the latest version of Code Composer Studio™ (CCS). This application was developed in
CCS v6.0.0. http://processors.wiki.ti.com/index.php/Download_CCS.
2. Obtain the BOOST-DRV8848 firmware and GUI, by downloading the BOOST-DRV8848 Hardware and
Software Files from the tool folder, www.ti.com/tool/boost-drv8848. This zip folder contains the
complete hardware design files, including the Altium source files, Gerbers, BOM, and schematic, as
well as the Brushed DC Motor Demo firmware and GUI.
3. Flash the MSP430G2553 on the MSP430G2 LaunchPad with the firmware provided. The MSP430G2
LaunchPad, an MSP430G2553, and mini-USB cable are required. The flash can be done in one of the
following two ways:
4. Method 1: Loading the binary .out file (preferred)
• Open Code Composer Studio.
• Select View -> Target Configuration (Figure 6)
• Right click on the User Defined folder and select New Target Configuration (Figure 6)
• Give the Target Configuration a name and select Finish

Figure 6. Target Configuration
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Set up the Target Configuration as shown in Figure 7. Save the Target Configuration file.

Figure 7. Target Configuration Setup
•
•

Go back to View -> Target Configurations
Right click the newly-created Target Configuration file and select Launch Selected Configuration
(see Figure 8)

Figure 8. Launch Selected Configuration
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•

In the Debug Menu, right click on the TI MSP430 USB1_0 connection and select Connect Target
(see Figure 9)

Figure 9. Connect Target Selection
•

After the device connects, go to Run -> Load -> Load Program (see Figure 10). Browse to the
BOOST-DRV8848 Hardware and Software Files folder that was downloaded from the tool folder.
Go into the Application subdirectory and then go into the GUI subdirectory. Select the
appProgram.out file (Application\BOOST-DRV8848_GUIvX.X\appProgram.out).

Figure 10. Load Program Selection
•

After a short delay, the appProgram.out file is loaded onto the MSP430G2553 (see Figure 11). An
error message may display saying that the source was not found. Receiving this message is OK,
as long as the binary was loaded.

Figure 11. Load Program Complete
•

Close CCS
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5. Method 2: Flashing the project through CCS debugger
• Open Code Composer Studio
• Go to File -> Import
• Select Existing CCS Eclipse Projects under the Code Composer Studio tab

Figure 12. Existing CCS Eclipse Projects
•

•
•
•

•

4.3

Check the Copy projects into workspace option and then browse to the BOOSTDRV8848_FIRMWAREvX.X directory located with the Application folder within the BOOSDRV8848 Hardware and Software Files folder. The project should now show up in the
Discovered Projects section. Ensure that it is checked and select Finish.
Select the BOOST-DRV8848_FIRMWAREv1.0 project in the Project Explorer and click the
Debug icon.
CCS now builds the project and loads it onto the MSP430G2533.
Update the binary file that the GUI is referencing (since CCS has recompiled it). Replace the
appProgram.out file (Application\BOOST-DRV8848_GUIvX.X\appProgram.out) with the BOOSTDRV8848_FIRMWAREvX.X.out file (Application\BOOSTDRV8848_FIRMWAREvX.X\Debug\BOOST-DRV8848_FIRMWAREvX.X.out). Delete the old
“appProgram.out” and rename the new file to “appProgram.out
Close CCS

Setting up the BOOST-DRV8848 GUI
1. To the run the BOOST-DRV8848 GUI, first download the latest version of the GUI Composer Runtime.
Register for a TI account if you don’t already have one. Select the appropriate version for your
operating system and follow the installation instructions.
http://processors.wiki.ti.com/index.php/Category:GUI_Composer#GUI_Composer_Downloads
2. After installing the GUI Composer Runtime, copy the BOOST-DRV8848_GUIvX.X folder, located in the
Application directory of the BOOST-DRV8848 Hardware and Software Files folder and paste this folder
into the GUI Composer webapps folder located in the “C:\ti\guicomposer\webapps\” directory.
If a non-default installation directory was selected in Step 1, the top-level directory may differ.
3. To run the GUI, double click the BOOST-DRV8848_GUIvX.X.exe file within the BOOSTDRV8848_GUIvX.X folder of the webapps directory. A shortcut to this .exe can be created in order to
start it from other file locations.
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NOTE: Ensure that the GUI “exe” is exactly two levels below the GUI Composer “webapps” folder.
The GUI will not start if this is incorrect. The path should look similar to this
“C:\ti\guicomposer\webapps\BOOST-DRV8848_GUIvX.X\BOOST-DRV8848_GUIvX.X.exe”.
If a non-default installation directory was selected in Step 1, the top-level directory may differ.

4.4

Spinning the Brushed Motor
After a successful launch of the BOOST-DRV8848_GUIvX.X.exe, the screen in Figure 13 should pop up.
A small period of time may be needed before the GUI connects and the GUI Widgets populate (red X’s
appear on the widgets while the GUI is connecting). If the GUI does not load after a few minutes (X’s
disappear), a connection issue may have occurred. Try restarting the application.

Figure 13. BOOST-DRV8848 GUI

4.4.1

Quick Start
1. Set the nSLEEP pin high in order to enable the DRV8848 device.
2. If you want to operate just one motor with twice the output current of the DRV8848, switch to Parallel
Mode. The device operates in Normal Mode per default. In Parallel Mode, a jumper must be placed
on J3.
3. Ensure the Current Limit is set for your motor requirements. The Current Limit can be adjusted with
the VREF potentiometer (R1).
4. Adjust the speed of the attached motor by sliding the bars for the PWM duty cycle.
5. Choose the decay mode and the direction of the motor by setting the respective buttons DECAY and
DIR for the desired motor.
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GUI Walkthrough (Normal Mode)
Figure 14 illustrates the GUI in normal mode.

Figure 14. GUI (Normal Mode)
The numeric labels indicated in Figure 14 are described in the following numbered list:
1. The nSLEEP button directly controls the nSLEEP pins of the DRV8848. Red indicates LOW (0 V) and
green indicates HIGH (3.3 V). Logic HIGH to enable device, logic LOW to enable low power sleep
mode and reset all internal logic.
2. The PWM slide controls the duty cycle of the applied voltage to the motor. The duty cycle directly
affects the speed of the motor.
3. The DIR and DECAY buttons control the direction and decay mode of the motor. See the DRV8848
datasheet SLLSEL7 for more information on decay modes.
4. nFAULT will assert when the DRV8848 is reporting a FAULT condition. See the DRV8848 datasheet
for more information on the various FAULT conditions.
5. The DRV8848 can operate two brushed DC motors simultaneously with an output current up to 1-A
RMS. The DRV8848 can also parallel the outputs to deliver 2x the current to a single motor. This
button controls the DRV8848 output mode. Place the J3 jumper on the BoosterPack.
6. Revision number reported by the firmware
7. The voltage set by the R1 potentiometer on the BoosterPack (resistor divider from DVDD). This
voltage controls the current limit of the DRV8848.
8. Calculated current limit for the DRV8848
9. The equation for determining the current limit from the VREF voltage and RSENSE resistance.
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4.4.3

GUI Walkthrough (Parallel Mode)
Figure 15 illustrates the GUI in parallel mode.

Figure 15. GUI (Parallel Mode)
•

In Parallel Mode, both outputs are controlled through the B motor inputs.
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See Figure 16 for the schematic connections. You must parallel the outputs from the terminal block
header (J6).

Figure 16. Parallel Mode Operation

5

Hardware Files (Schematic/Gerber)
The complete design files can be found in the tool folder (http://www.ti.com/tool/boost-drv8848) including
the schematic, gerbers, layout files, PCB views, and bill of materials.

14

BOOST-DRV8848

SLVUAE1 – December 2014
Submit Documentation Feedback
Copyright © 2014, Texas Instruments Incorporated

IMPORTANT NOTICE
Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other
changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESD48, latest
issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and
complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI’s terms and conditions of sale
supplied at the time of order acknowledgment.
TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI’s terms
and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent TI deems necessary
to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily
performed.
TI assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and
applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide
adequate design and operating safeguards.
TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or
other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information
published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or
endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the
third party, or a license from TI under the patents or other intellectual property of TI.
Reproduction of significant portions of TI information in TI data books or data sheets is permissible only if reproduction is without alteration
and is accompanied by all associated warranties, conditions, limitations, and notices. TI is not responsible or liable for such altered
documentation. Information of third parties may be subject to additional restrictions.
Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service
voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice.
TI is not responsible or liable for any such statements.
Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements
concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support
that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which
anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause
harm and take appropriate remedial actions. Buyer will fully indemnify TI and its representatives against any damages arising out of the use
of any TI components in safety-critical applications.
In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI’s goal is to
help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and
requirements. Nonetheless, such components are subject to these terms.
No TI components are authorized for use in FDA Class III (or similar life-critical medical equipment) unless authorized officers of the parties
have executed a special agreement specifically governing such use.
Only those TI components which TI has specifically designated as military grade or “enhanced plastic” are designed and intended for use in
military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components
which have not been so designated is solely at the Buyer's risk, and that Buyer is solely responsible for compliance with all legal and
regulatory requirements in connection with such use.
TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of
non-designated products, TI will not be responsible for any failure to meet ISO/TS16949.
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